Kernel upgrade issue 6.1.49

Hello community,

installing the kernel upgrade leads me into rescue mode after reboot.
Reason /boot/efi could not be mounted as vfat module is not loaded.
I recognized libraries are still ponting to 6.1.44 which was previously installed.
I downgraded back to 6.1.44 using the cached pacman packages and was able to boot the system normally.
pacman -U /var/cache/pacman/pkg/linux61-6.1.44 …
pacman -U /var/cache/pacman/pkg/linux61-headers-6.1.44 …
Repeating the upgrade leads back into trouble. I went back to 6.1.44 again.
I experienced this behavior a few times during kernel upgrades in the past, and I had those issues on two different notebooks.
Is there something wrong with the kernel upgrade procedure?

Tried using depmod to reinitialize modules during debugging told me modules are not found in /lib/modules/6.1.44-1-MANJARO. (But 6.1.49. was installed).

Best regards


Exactly how did you update the kernel, and did you do that without updating the rest of the system?


  1. You should never update only part of the system. Manjaro is a rolling release, and partial upgrades are not supported.

  2. The update process rebuilds the initcpios. If you skip that step, then indeed certain modules won’t be found during the boot process.


I used the packet manager from gnome GUI to perform an upgrade, it was about 900MBs as the notebook wasn’t switched on for 1-2 weeks.
The process is called “pacman-manager --updates” (seen in Htop).
After the upgrade the system requested me to reboot → Emergency console.
After investigation of the problem I used pacman -U to went back to 6.1.44 using the linux61-6.1.44* and linux61-headers-6.1.44* package stored in /var/cache/pacman/pkg.

Usually I use pacman-manager or console “pacman -Syu” to upgrade my system. I never install a new kernel on its own. I always use the system upgrade functions.

Only exceptions for installing kernel only was the to went back to 6.1.44 to get back system functionality.

As I experienced this issue the fist time and used a manjaro live usb key with manjaro-chroot script to remount local system and reinstalled kernel this way. Only today I used the workaround by resinstall the old kernel to get it back functional.

Best regards


That will be pamac-manager. There is no such thing as pacman-manager, because pacman is a command-line-only tool. :wink:

This should not have happened. If pamac told you to reboot, then it should have rebuilt the initcpio(s), which does not appear to have happened here. But that said, libpamac — the core of the pamac system — has had issues over these last couple of days, and there have been several updates to correct those.

I would suggest using pacman — command-line — to correct the discrepancies. :arrow_down:

sudo pacman-mirrors -f && sudo pacman -Fy && sudo pacman -Syyu

This should normally pull in the updated kernel again, as well as the corrected versions of libpamac and pamac-cli, and it will rebuild the initcpio(s) — it will show you the output in the terminal.

1 Like

Hello Aragorn,

thanks, your suggested command worked. System upgraded successfully to new kernel.

uname -a
Linux Mate16 6.1.49-1-MANJARO #1 SMP PREEMPT_DYNAMIC Sun Aug 27 23:08:04 UTC 2023 x86_64 GNU/Linux

Thanks and best regards.



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.