Kernel compromised, restoring os?

Hello, i just tried to update the system’s every package this morning and at this end of this update it asked for a system restart for the changes to take place, which i did only for the system to never restart with a “failed to start kernel modules” error and some other things trying to start at the same time, i have read different other post about what seemed to be the same issue but as im a linux newbie i didnt understood everything, something about grub or something, saddly i didnt use any tool like timeshift to backup the whole system but i at least hope there is a way to get back all my folders that were on the desktop as it was hours of work, help please? (i already have manjaro’s image iso on an USB stick ready to do whatever is necessary)

  12Kernel 5.15.49-1-MANJARO 12arch x86_64 12bits 64 12compiler gcc 12v 12.1.0
    12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2131 quiet systemd.show_status=1
    apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1
  12Console N/A 12wm kwin_x11 12Distro Manjaro Linux 12base Arch Linux
  12Type Laptop 12System ASUSTeK 12product ASUS TUF Gaming F15 FX506HM_FX506HM 12v 1.0
    12serial <filter>
  12Mobo ASUSTeK 12model FX506HM 12v 1.0 12serial <filter>
    12UEFI American Megatrends LLC. 12v FX506HM.309 12date 10/05/2021
  12ID-1 BAT1 12charge 58.4 Wh (66.2%) 12condition 88.2/90.2 Wh (97.8%) 12volts 15.2
    12min 15.9 12model ASUS A32-K55 12type Li-ion 12serial N/A 12status discharging
  12RAM 12total 15.37 GiB 12used 2.7 GiB (17.6%)
  12Array-1 12capacity 128 GiB 12slots 4 12EC None 12max-module-size 32 GiB 12note est.
  12Device-1 Controller0-ChannelA-DIMM1 12type no module installed
  12Device-2 Controller1-ChannelA-DIMM1 12type no module installed
  12Device-3 Controller0-ChannelA-DIMM0 12type DDR4 12detail synchronous
    12size 8 GiB 12speed 3200 MT/s 12volts 12curr 1.2 12min 1.2 12max 1.2 12width (bits)
    12data 64 12total 64 12manufacturer Micron Technology 12part-no 8ATF1G64HZ-3G2J1
    12serial <filter>
  12Device-4 Controller1-ChannelA-DIMM0 12type DDR4 12detail synchronous
    12size 8 GiB 12speed 3200 MT/s 12volts 12curr 1.2 12min 1.2 12max 1.2 12width (bits)
    12data 64 12total 64 12manufacturer Micron Technology 12part-no 8ATF1G64HZ-3G2J1
    12serial <filter>
  12Info 12model 11th Gen Intel Core i5-11400H 12socket U3E1 12bits 64 12type MT MCP
    12arch Tiger Lake 12gen core 11 12built 2020 12process Intel 10nm 12family 6
    12model-id 0x8D (141) 12stepping 1 12microcode 0x3E
  12Topology 12cpus 1x 12cores 6 12tpc 2 12threads 12 12smt enabled 12cache 12L1 480 KiB
    12desc d-6x48 KiB; i-6x32 KiB 12L2 7.5 MiB 12desc 6x1.2 MiB 12L3 12 MiB
    12desc 1x12 MiB
  12Speed (MHz) 12avg 1038 12high 1263 12min/max 800/4500 12base/boost 2475/4500
    12scaling 12driver intel_pstate 12governor powersave 12volts 0.7 V 12ext-clock 100 MHz
    12cores 121 1148 122 820 123 1139 124 990 125 1162 126 1117 127 1080 128 1000 129 1263 1210 782
    1211 801 1212 1157 12bogomips 64536
  12Flags 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  12Type itlb_multihit 12status Not affected
  12Type l1tf 12status Not affected
  12Type mds 12status Not affected
  12Type meltdown 12status Not affected
  12Type mmio_stale_data 12status Not affected
  12Type spec_store_bypass
    12mitigation Speculative Store Bypass disabled via prctl and seccomp
  12Type spectre_v1
    12mitigation usercopy/swapgs barriers and __user pointer sanitization
  12Type spectre_v2 12status Vulnerable: eIBRS with unprivileged eBPF
  12Type srbds 12status Not affected
  12Type tsx_async_abort 12status Not affected
  12Device-1 Intel TigerLake-H GT1 [UHD Graphics] 12vendor ASUSTeK 12driver i915
    12v kernel 12arch Gen12.1 12process Intel 10nm 12built 2020-21 12ports 12active eDP-1
    12empty DP-1,HDMI-A-1,HDMI-A-2 12bus-ID 0000:00:02.0 12chip-ID 8086:9a68
    12class-ID 0300
  12Device-2 NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] 12vendor ASUSTeK
    12driver nouveau 12v kernel 12alternate nvidia_drm,nvidia 12non-free 515.xx+
    12status current (as of 2022-06) 12arch Ampere 12process TSMC n7 (7nm)
    12built 2020-22 12ports 12active none 12empty DP-2,DP-3 12bus-ID 0000:01:00.0
    12chip-ID 10de:2520 12class-ID 0300
  12Display 12server 12v 12compositor kwin_x11 12driver 12X
    12loaded modesetting 12alternate fbdev,vesa 12gpu i915 12display-ID :0
  12Monitor-1 eDP-1 12model ChiMei InnoLux 0x1521 12built 2020 12res 1920x1080
    12dpi 142 12gamma 1.2 12size 344x193mm (13.54x7.6") 12diag 394mm (15.5") 12ratio 16:9
    12modes 1920x1080
  12Message GL data unavailable for root.
  12Device-1 Intel Tiger Lake-H HD Audio 12vendor ASUSTeK 12driver snd_hda_intel
    12v kernel 12alternate snd_sof_pci_intel_tgl 12bus-ID 0000:00:1f.3
    12chip-ID 8086:43c8 12class-ID 0403
  12Device-2 NVIDIA 12vendor ASUSTeK 12driver snd_hda_intel 12v kernel
    12bus-ID 0000:01:00.1 12chip-ID 10de:228e 12class-ID 0403
  12Sound Server-1 ALSA 12v k5.15.49-1-MANJARO 12running yes
  12Sound Server-2 JACK 12v 1.9.21 12running no
  12Sound Server-3 PulseAudio 12v 16.1 12running yes
  12Sound Server-4 PipeWire 12v 0.3.52 12running yes
  12Device-1 MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    12vendor AzureWave 12driver mt7921e 12v kernel 12bus-ID 0000:2d:00.0
    12chip-ID 14c3:7961 12class-ID 0280
  12IF wlp45s0 12state up 12mac <filter>
  12IP v4 <filter> 12type dynamic noprefixroute 12scope global 12broadcast <filter>
  12IP v6 <filter> 12type dynamic noprefixroute 12scope global
  12IP v6 <filter> 12type noprefixroute 12scope link
  12Device-2 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    12vendor ASUSTeK 12driver r8169 12v kernel 12port 3000 12bus-ID 0000:2e:00.0
    12chip-ID 10ec:8168 12class-ID 0200
  12IF enp46s0 12state down 12mac <filter>
  12WAN IP <filter>
  12Device-1 IMC Networks Wireless_Device 12type USB 12driver btusb 12v 0.8
    12bus-ID 3-14:7 12chip-ID 13d3:3563 12class-ID e001 12serial <filter>
  12Report rfkill 12ID hci0 12rfk-id 2 12state up 12address see --recommends
  12Message No logical block device data found.
  12Hardware-1 Intel Volume Management Device NVMe RAID Controller 12driver vmd
    12v 0.6 12port N/A 12bus-ID 0000:00:0e.0 12chip-ID 8086:9a0b 12rev 12class-ID 0104
  12Local Storage 12total 491.45 GiB 12used 24.72 GiB (5.0%)
  12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor Intel 12model SSDPEKNU512GZ
    12size 476.94 GiB 12block-size 12physical 512 B 12logical 512 B 12speed 31.6 Gb/s
    12lanes 4 12type SSD 12serial <filter> 12rev 002C 12temp 38.9 C
  12SMART yes 12health PASSED 12on 78 hrs 12cycles 65 12read-units 561,987 [287 GB]
    12written-units 945,454 [484 GB]
  12ID-2 /dev/sda 12maj-min 8:0 12type USB 12model USB Disk 2.0 12size 14.51 GiB
    12block-size 12physical 512 B 12logical 512 B 12type N/A 12serial <filter> 12rev 2.00
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
  12Message No optical or floppy data found.
  12ID-1 / 12raw-size 476.64 GiB 12size 468.09 GiB (98.21%) 12used 24.72 GiB (5.3%)
    12fs ext4 12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2 12label N/A
    12uuid 639b9753-0798-4e56-a12c-1a10572b245a
  12ID-2 /boot/efi 12raw-size 300 MiB 12size 299.4 MiB (99.80%)
    12used 312 KiB (0.1%) 12fs vfat 12block-size 512 B 12dev /dev/nvme0n1p1
    12maj-min 259:1 12label NO_LABEL 12uuid 8A23-8CCC
  12Alert No swap data was found.
  12ID-1 /dev/sda1 12maj-min 8:1 12size 3.41 GiB 12fs N/A 12label MANJARO_KDE_2131
    12uuid 2022-06-24-20-11-10-00
  12ID-2 /dev/sda2 12maj-min 8:2 12size 4 MiB 12fs N/A 12label MISO_EFI 12uuid 3ECF-2322
  12Hub-1 1-0:1 12info Hi-speed hub with single TT 12ports 1 12rev 2.0 12speed 480 Mb/s
    12chip-ID 1d6b:0002 12class-ID 0900
  12Hub-2 2-0:1 12info Super-speed hub 12ports 4 12rev 3.1 12speed 10 Gb/s
    12chip-ID 1d6b:0003 12class-ID 0900
  12Hub-3 3-0:1 12info Hi-speed hub with single TT 12ports 16 12rev 2.0
    12speed 480 Mb/s 12chip-ID 1d6b:0002 12class-ID 0900
  12Device-1 3-3:2 12info USB Disk 2.0 12type Mass Storage 12driver usb-storage
    12interfaces 1 12rev 2.0 12speed 480 Mb/s 12power 100mA 12chip-ID 23a5:5786
    12class-ID 0806 12serial <filter>
  12Device-2 3-14:7 12info IMC Networks Wireless_Device 12type Bluetooth
    12driver btusb 12interfaces 3 12rev 2.1 12speed 480 Mb/s 12power 100mA
    12chip-ID 13d3:3563 12class-ID e001 12serial <filter>
  12Hub-4 4-0:1 12info Super-speed hub 12ports 8 12rev 3.1 12speed 20 Gb/s
    12chip-ID 1d6b:0003 12class-ID 0900
  12System Temperatures 12cpu 53.0 C 12mobo N/A
  12Fan Speeds (RPM) 12cpu 2300
  12Processes 294 12Uptime 20m 12wakeups 1181 12Init systemd 12v 251 12default graphical
  12tool systemctl 12Compilers 12gcc 12.1.0 12clang 13.0.1 12Packages 1365 12pacman 1354
  12lib 415 12flatpak 11 12Client Unknown Client: systemd 12inxi 3.3.19

so boot into manjaro iso, then connect to internet, open terminal, and run this:
sudo manjaro-chroot -a
then we will continue

hello, sorry for late answer, it returns “grub-probe: error: cannot find a GRUB drive for /dev/sda1. check your”

and then something about mounting (ManjaroLinux) on /dev/nvme0n1p2.

and now in the terminal im in [manjaro /]#

ok so you chrooted, the grub probe error is for the usb, so ignore it…
now rerun update again:
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
post the output here

this is the output

::INFO => Mirror pool:
::INFO => Mirror status:
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  1.878 United_States  :
  0.300 Global         :
  1.830 Kenya          :
  1.620 Costa_Rica     :
  1.440 Canada         :
::INFO Writing mirror list
::Global          :
::Canada          :
::Costa_Rica      :
::Kenya           :
::United_States   :
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronizing package databases...
 core                                  167.4 KiB  32.0 KiB/s 00:05 [####################################] 100%
 extra                                1863.6 KiB  2.20 MiB/s 00:01 [####################################] 100%
 community                               7.0 MiB  4.48 MiB/s 00:02 [####################################] 100%
 multilib                              175.5 KiB  3.99 MiB/s 00:00 [####################################] 100%
:: Starting full system upgrade...
warning: pamac-tray-icon-plasma: local (0.1.3-1) is newer than extra (0.1.2-4)
warning: v86d: local (0.1.10-12) is newer than extra (0.1.10-6)
 there is nothing to do```

edit your post to use formatting, click this icon in editor: </> and post the output there…
now post formatted output from:
mhwd-kernel -li && mhwd -l && mhwd -li

Do you run an EOL-Kernel ?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
Currently running: 5.15.49-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515
   * linux518
   * linux515-rt
   * linux518-rt
> 0000:2e:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:01:00.0 (0300:10de:2520) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0300:8086:9a68) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI

Warning: No installed USB configs!

since you have installed 4 kernels, did you try booting with a different one, to see if you still get the failed load modules error?

uh tbh how do i do that? linux newbie yk nvm about current kernel im dumb

do you have a grub menu shown during booting up your pc?

nop when i launch my pc everything starts right away and i directly get the screen to connect into my manjaro user

ok so lets try booting with different kernel first…
run this command:
nano /etc/default/grub
and edit this line to look like this:
GRUB_TIMEOUT_STYLE=menu - its the third line …
then press ctrl+x to save it and run this command:
systemctl reboot
and the grub menu will appear and under advanced options select a different kernel, try first with the 5.15, if it doesnt work try with the 5.15rt, and if its still doesnt work, boot again into manjaro usb and chroot and we will continue

i got this what do i select?

File Name to Write: /etc/default/grub                                                                         
^G Help                    M-D DOS Format             M-A Append                 M-B Backup File
^C Cancel                  M-M Mac Format             M-P Prepend                ^T Browse

what do you mean you got this? did this appeared after you run the
nano /etc/default/grub ?

nvm i just had to press enter im stupid, anyway i did all the steps and it seems to work, everything went back to normal and literally nothing has been lost, thats great you literally are a lifesaver mate tyvm (what do you think may have caused the issue btw? is the 1.18 kernel unreliable or something?).
as my issue is solved do i have to close this post or someone/auto will do it for me?

ok, so you normally booted? post output from:
uname -a

Linux asus-f15 5.15.49-1-MANJARO #1 SMP PREEMPT Wed Jun 22 14:15:49 UTC 2022 x86_64 GNU/Linux

ok so lets reinstall the rest of the kernels:
uninstall them first:
sudo pacman -R linux518 linux515-rt linux518-rt
then install the 5.18:
sudo pacman -S linux518
reboot and select the 518 in the grub menu and see if you can boot with it normally

1 Like

just got this, those are nvidia drivers right?

error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux515-rt breaks dependency 'linux515-rt' required by linux515-rt-nvidia
:: removing linux518 breaks dependency 'linux518' required by linux518-nvidia
:: removing linux518-rt breaks dependency 'linux518-rt' required by linux518-rt-nvidia