Kernel 6.9.0rc1-1 recognized as kernel 6.8.0-1

Installed and booted Kernel 6.9.0rc1-1. But it is recognized as Kernel 6.8.0-1


Hi @ara,

Please provide the output for:

mhwd-kernel --listinstalled

And please don’t post pictured of text. Instead, here’s a tip for you:

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

1 Like

Now read that image you posted again. Even I know what “Genutzt” mean.

1 Like
mhwd-kernel --listinstalled                                      ✔ 
Currently running: 6.8.0-1-MANJARO (linux68)
The following kernels are installed in your system:
   * linux67
   * linux68
   * linux69

Obviously it’s not booted into it. To boot into it:

All available kernels installed on your system will be presented upon booting up. GNU GRUB is visible with a couple of options. Choose “Advanced Options for Manjaro Linux” by using the arrow keys on your keyboard and then ↵ Enter.

On the next screen (as illustrated) are backup copies of each kernel version installed (which will also be automatically removed if or when a kernel version is deleted). To select a kernel, simply use the arrow keys to highlight the desired version, and then press ↵ Enter.

I booted Kernel 6.9.0rc1-1
There is no Kernel 6.8.0-1 on my system, only 6.8.1-2

Well, this :point_down:

Says differently…

So, try the following anyway:

Remove the unwanted one(s):

Version 6.8:

sudo mhwd-kernel --remove linudx68

and 6.7:

sudo mhwd-kernel --remove linux67

And reboot. It should automatically choose 6.9 then. Or whichever’s the latest one.

Maybe install 6.9 yourself and check it?

Nah, I know the tool works, have had many kernels installed.


But hey! i see you’re on the unstabole branch, the the stable one doesn’t yet have it:

$ mhwd-kernel --list
available kernels:
* linux419
* linux510
* linux515
* linux54
* linux61
* linux66
* linux67
* linux68
* linux61-rt
* linux66-rt
* linux67-rt

So I guess that as something to do with it.


post the output of

ls /boot
amd-ucode.img                      initramfs-6.9-x86_64.img
efi                                linux67-x86_64.kver
grub                               linux68-x86_64.kver
initramfs-6.7-x86_64-fallback.img  linux69-x86_64.kver
initramfs-6.7-x86_64.img           memtest86+
initramfs-6.8-x86_64-fallback.img  vmlinuz-6.7-x86_64
initramfs-6.8-x86_64.img           vmlinuz-6.8-x86_64
initramfs-6.9-x86_64-fallback.img  vmlinuz-6.9-x86_64

Broken PKGBUILD or something, don’t have time to check. It does say

Linux manjaro 6.8.0-1-MANJARO #1 SMP PREEMPT_DYNAMIC Tue Mar 26 14:49:48 UTC 2024 x86_64 GNU/Linux

Yep here isn’t update for 6.9:

1 Like

curious a fallback-image but no main-image exists ?

Look at the other column.

what other column ? and i’m looking at the images that are stored at /boot and there is no image of a regular 6.9 kernel. no image → no boot

Those are initramfses. Kernels are named vmlinuz and they are also there…

…in the right column. :eyes:

1 Like

gotcha, thanks. i’m getting old …

1 Like

OK, my bad. It’s a packaging error. Will fix it shortly.
The source is the right one, just the internal patchlevel isn’t set right … :roll_eyes:


The -2 version fixes this. However, the mirrors that should be synced are not. Not even, the global ones have this new version.
I had to transfer the files around the world from the Australian mirror because it synced 4 minutes ago while my Swiss mirror synced 5 minutes ago and does not yet have the new version.
Why is it shown up-to-date on the mirrors page?