Kernel 6.0 on Alder Lake 12th generation

Hello Community!

I just got my brand new laptop, it comes with an i7 12700 and Nvidia 3070 Ti, 64 GB RAM DDR4.
I installed Manjaro/KDE on it and - with my surprise - I face a lot of issues.

  1. Kernel 6.x does not run - it hangs at boot and I need to power off, no way to reboot. I can post a photo of the messages if it is worth it, but maybe you can already tell me that my CPU is not supported by 6.0 yet? And by 5.19 neither? The only working kernel is 5.15.79 LTS.
  2. I have terrible tearing issues with the Intel UHD card. when I disable it from the BIOS, the laptop uses only the nvidia and everything is OK (except that it becomes a heater, too hot to keep it on the laps). I have tried only with modesetting, not with the “old way” using xf86-video-intel + Tearfree option. Does anyone have a straghtforward tip for that?

I have the same CPU with an RTX 3060. Do not use 5.15, it is missing many fixes and improvements for Alder Lake CPUs. 5.19 is EOL.

Adding ibt=off to your kernel parameters is required for >=5.18:

NVIDIA - ArchWiki


Thank you @Yochanan ! I owe you one! :smiley:

I’m now using 6.0.9 flawlessly.

@Yochanan Thank you for this as well!!! Solved my issues. Now running 6.0.11-1!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.