Kernel 5.8.x my system seems to be only running at it’s minimum clock of 800mhz

Thanks for the update!

With Kernel 5.8.0-2 my system seems to be only running at it’s minimum clock of 800mhz. If more information on this is need, please let me know what and where to provide it correctly.

If someone is having issues with reinstalling GRUB on their EFI system, don’t pull a Beerfoo and make sure you also boot your USB device in EFI mode :upside_down_face:
I suppose it should go without saying, but perhaps it would be worth mentioning on the wiki.

Once that was out of the way, everything was super easy.

Thanks Manjaro!

can you provide

inxi MCxxa --no-host 

can you go back with kernel 5.7

Yes i went back to 5.7.

I am assuming you need the inxi output while running 5.8?

How do you check that?
What I see in conky is that 5.8 stays on the base frequency longer. That might be due to the new power management that was added with 5.8. But it definitely uses all frequencies when needed. On an AMD Ryzen 7 2700X that is.

The system was significantly slower than usual even when logging in or starting applications. After a while of wondering what was going on, I looked at conky and noticed that it was stuck at 800mhz, which would not change.

Output of inxi MCxxa --no-host under 5.7 (if output from 5.8 is needed please let me know)

Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <superuser/root required> 
       Mobo: ASUSTeK model: MAXIMUS VI EXTREME v: Rev 1.xx serial: <superuser/root required> UEFI: American Megatrends 
       v: 1603 date: 08/15/2014 

CPU:       Topology: Quad Core model: Intel Core i7-4770K bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 3C (60) 
       stepping: 3 microcode: 28 L2 cache: 8192 KiB 
       flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 56024 
       Speed: 2562 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 801 5: 800 6: 800 7: 800 8: 800 
       Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
       Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
       Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
       Type: meltdown mitigation: PTI 
       Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
       Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
       Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
       Type: srbds mitigation: Microcode 
       Type: tsx_async_abort status: Not affected

I’ve got a similar issue when I boot my laptop unplugged. It also occur with 5.7.15. Nethertheless it seems to be related to the recent manjaro stable update (probably the 2020-08-16 one) as I didn’t notice it before.

This thread seems to talk about a similar problem: CPU slows down as soon laptop unplugged, stays slow even if plugged back in

Running 5.8.1-3 after todays update with the same problem sadly. Reverting back to 5.7 again.

Output of inxi -MCxxa --no-host running Kernel 5.8.1-3

Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <superuser/root required> 
       Mobo: ASUSTeK model: MAXIMUS VI EXTREME v: Rev 1.xx serial: <superuser/root required> UEFI: American Megatrends 
       v: 1603 date: 08/15/2014 
CPU:       Topology: Quad Core model: Intel Core i7-4770K bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 3C (60) 
       stepping: 3 microcode: 28 L2 cache: 8192 KiB 
       flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 56021 
       Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 799 4: 800 5: 801 6: 800 7: 800 8: 800 
       Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
       Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
       Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
       Type: meltdown mitigation: PTI 
       Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
       Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
       Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
       Type: srbds mitigation: Microcode 
       Type: tsx_async_abort status: Not affected

can you add pastebinit or wgestpaste
and boot on each kernel , and send

sudo journalctl -b0 | pastebinit 
or 
sudo journalctl -b0 | wgestpaste

and provides links ?

It seems the output was too large for pastebinit or wgetpaste but I managed to upload them manually.

Thank you very much for looking into this :slight_smile:

there is this
line 181 aug 23 11:53:36 cheetah kernel: Trampoline variant of Tasks RCU enabled.
–> i hope that microcode is updated too

line 188 Aug 23 11:53:36 cheetah kernel: ACPI: Core revision 20200528

in both case
Aug 23 11:53:36 cheetah kernel: core: PMU erratum BJ122, BV98, HSD29 worked around, HT is on
Aug 23 11:53:36 cheetah kernel: ENERGY_PERF_BIAS: Set to ‘normal’, was ‘performance’

may be this ( not getting values ? )
Aug 23 11:53:36 cheetah kernel: at24 0-0050: supply vcc not found, using dummy regulator
Aug 23 11:53:36 cheetah kernel: at24 0-0050: 256 byte spd EEPROM, read-only
Aug 23 11:53:36 cheetah kernel: at24 0-0051: supply vcc not found, using dummy regulator
Aug 23 11:53:36 cheetah kernel: at24 0-0051: 256 byte spd EEPROM, read-only
Aug 23 11:53:36 cheetah kernel: at24 0-0052: supply vcc not found, using dummy regulator
Aug 23 11:53:36 cheetah kernel: at24 0-0052: 256 byte spd EEPROM, read-only
Aug 23 11:53:36 cheetah kernel: at24 0-0053: supply vcc not found, using dummy regulator
Aug 23 11:53:36 cheetah kernel: at24 0-0053: 256 byte spd EEPROM, read-only

can you check

cpupower frequency-info

Under 5.7.15-1

   sudo cpupower frequency-info
   analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 800 MHz - 4.50 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 800 MHz and 4.50 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 4.18 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

Under 5.8.1-3

 sudo cpupower frequency-info        
analyzing CPU 0:
  driver: intel_cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 20.0 us
  hardware limits: 800 MHz - 4.50 GHz
  available cpufreq governors: powersave performance schedutil
  current policy: frequency should be within 800 MHz and 4.50 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 800 MHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

in think they have change driver in your case ( or you can only use intel_pstate )

in my case ( as skylake only pstate possible )

cpupower frequency-info 

analyse du CPU 0 :
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  limitation matérielle : 800 MHz - 4.20 GHz
  régulateurs disponibles : performance powersave
  tactique actuelle : la fréquence doit être comprise entre 800 MHz et 4.00 GHz.
                  Le régulateur "performance" est libre de choisir la vitesse
                  dans cette plage de fréquences.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 4.00 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

see this option on boot
from The kernel’s command-line parameters — The Linux Kernel documentation

intel_pstate=
value are active ,disable , passive , force , no_hwp , hwp_only ,support_acpi_ppc ,per_cpu_perf_limits

try with
hwp_only or per_cpu_perf_limits or active or force

I hope that I did that correctly (spaces after commas):

cat /proc/cmdline

     BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=8a41d3ad-2c5c-42e7-8107-ad2fe209698c rw acpi_enforce_resources=lax quiet apparmor=1 security=apparmor resume=UUID=a791209d-5546-42fb-91b8-858d27e8f926 udev.log_priority=3 intel_pstate=hwp_only, per_cpu_perf_limits, force       

Result is the same, stuck at 800mhz :worried:

try one value at time
you can pres Esc on Grub
(e) dit and add one value option for test then F10

try this value intel_pstate=active

2 Likes

You Sir, are a wizard! It worked and things are back to normal! :smiley:

Just passing intel_pstate=active did the trick.

Would you suggest I add the parameter to my grub configuration or will this change in a future kernel version? (I normally do not reboot all that often).

Thank you very much stephane for your help, I could not have figured this out on my own.

Cheers,
Beerfoo

yes you should add on your grub configuration for the moment ,
it easy to try just before launch boot on grub screen

your processor is using pstate before generation skylake , and do not active on hardware at start ,
because it will use “passive” by default , or in this case it a minima

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.