Keepassxc not launching. Bus error (core dumped)

  • keepassxc doesn’t work and sends the error Bus error (core dumped)
  • MultiMC and Persepolis send the same error.
    NOTE: keepasxc-cli works.

Everything was working when I was running an unsupported kernel linux513
This happened after updating my system using yay -Syu. And then updating the kernel to linux515.

I thought the problem was with the kernel so I tried using linux510 and linux513 but I got the same error.

My inxi output:

  Kernel: 5.15.49-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=45f6ee2f-bad8-474d-9148-ebcf4e4f6b22 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: i3 v: 4.20.1 info: i3bar vt: 7 dm: LightDM v: 1.30.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 5016A26 v: ThinkPad L520
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 5016A26 serial: <superuser required> BIOS: LENOVO
    v: 8GET34WW (1.11 ) date: 06/13/2011
  ID-1: BAT1 charge: 30.8 Wh (99.7%) condition: 30.9/47.5 Wh (65.1%)
    volts: 12.4 min: 10.8 model: SANYO 42T4763 type: Li-ion serial: <filter>
    status: not charging
  RAM: total: 3.68 GiB used: 1.31 GiB (35.6%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i3-2310M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 built: 2010-12 process: Intel 32nm family: 6 model-id: 0x2A (42)
    stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 986 high: 1274 min/max: 800/2100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 1075 3: 1274
    4: 798 bogomips: 16769
  Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est
    flexpriority flush_l1d fpu fxsr ht ibpb ibrs lahf_lm lm mca mce md_clear
    mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pebs pge pln pni popcnt pse pse36 pti pts rdtscp rep_good sep ssbd sse
    sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Lenovo driver: i915 v: kernel arch: Gen6 process: Intel 32nm
    built: 2011 ports: active: LVDS-1
    empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0116 class-ID: 0300
  Device-2: Cheng Uei Precision Industry (Foxlink) Integrated Camera
    type: USB driver: uvcvideo bus-ID: 2-1.4:3 chip-ID: 05c8:0317 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: modesetting
    alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: LVDS-1 model: Lenovo 0x40b1 built: 2010 res: 1600x900 hz: 60
    dpi: 118 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1600x900
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.49-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: no
  Device-1: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:0085 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp9s0 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 298.06 GiB used: 156.97 GiB (52.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9320328CS
    size: 298.06 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: SC1A scheme: MBR
  Optical-1: /dev/sr0 vendor: Optiarc model: DVD RW AD-7710H rev: 1.S0
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 298.06 GiB size: 292.32 GiB (98.07%)
    used: 156.97 GiB (53.7%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 45f6ee2f-bad8-474d-9148-ebcf4e4f6b22
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.4:3
    info: Cheng Uei Precision Industry (Foxlink) Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 200mA
    chip-ID: 05c8:0317 class-ID: 0e02
  System Temperatures: cpu: 53.0 C mobo: 0.0 C
  Fan Speeds (RPM): cpu: 734
  Processes: 168 Uptime: 12m wakeups: 1 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1
  Packages: 1483 pacman: 1465 lib: 416 flatpak: 12 snap: 6 Shell: Bash
  v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.19
  • So what can I do to get apps to work again?
    I don’t think the problem was with the kernel version.
  • Did it happen because I updated using yay?
  • Also what does the error mean and how can I prevent it?

Maybe reinstall. Just checked; my keepassxc (official repos) works fine on upgraded system running 5.15 LTS.

I tried sudo pacman -S keepassxc Got the same error
I tried sudo pacman -R keepassxc then I installed it again.
Still the same error.

Hi @RaspberryRealm,

I use it with kernels 5.4, 5.10, 5.15 and 5.19, and it works flawlessly. I suspect something else.

If you’ve got the database separate, which I recommend, try removing the configuration and then configuring it from scratch.

mv -v ~/.config/keepassxc ~/.config/keepassxc.bak

Note: this will backup any and all files in the config directory, you can remove the backup if all works afterwards.

Just to be thorough, reinstall it again:

pamac reinstall keepassxc --overwrite='*'

This will reinstall it using pamac and overwrite any conflicts.

If all goes well, and works afterward, you can remove the backup created earlier:

rm -fr ~/.config/keepassxc.bak

Hope this helps!

1 Like

Just to play it safe, use mv instead of rm to troubleshoot this. :pray:

mv -v ~/.config/keepassxc ~/.config/keepassxc.bak

I’m getting PTSD from users on this forum (and elsewhere) who permanently deleted their data without any recent backups. :woozy_face:


Good point. I’ll adjust my instructions from now. Thanks!


There are posts online about keepassxc crashing at start, seems to be related to qt libraries updates. Some people were able to fix it by:
sudo ldconfig
which updates the links/cache which the dynamic loader uses.

I just have run this myself (and it seems to speed up keepassxc loading) but please do your own research about that command.

I’m afraid that I’m still getting the same error.
Also keepasxc-cli works fine.

I learned this the hard way with my .bashrc file…

pamac reinstall qt5
pamac reinstall qt6
then reboot
And It works like a charm!
Also pamac is pretty nice thanks Mirdarthos.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.