Keep hearing annoying notification sound effect

I’m running Manjaro with Plasma on my laptop, and I keep hearing some notification sound at regular intervals, but have no idea which process might be playing it, or why.

The first time in any desktop session when I hear it, is right after entering the password, before the desktop is even visible.
I’ve been through the notification settings in Plasma, and the sound persists even if I turn audio notifications off completely, or set notification volume to zero. It also keeps going when I lock the desktop session but keep the laptop running, even after the screen goes dark.
This started about two to three weeks ago, but I can’t say when exactly or what changed at the time, because I had Plasma muted for a while, so I would not have noticed immediately when it started. It’s been persistent over the past few software updates.

I tried keeping the Plasma volume widget open to see which applications are playing sound, but nothing shows up when I hear the sound effect.
I’ve gone through the /user/share/sounds/ folder, and found that ./freedesktop/stereo/bell.oga seems to correspond closest to the sound I’m hearing, but it does sound a little distorted, so it might not be exactly that file being played.

At least when I set volume to zero in plasma (or mute the sound) does the sound also go away, and it does seem to follow the volume setting. It also always plays on the main audio device, even if some applications don’t always do this correctly.

Where else can I look to figure out what is going on, and of course: how can I get rid of this? As long as the laptop is not muted, this notification sound is overlaid with anything that plays, several times per minute.

Some info about the system:

Kernel: 5.10.141-1-MANJARO x86_64
Desktop: KDE Plasma v: 5.25.5

~ >>> inxi --audio                                                                                                                                                                                                 
  Device-1: Intel Comet Lake PCH-LP cAVS driver: sof-audio-pci
  Sound Server-1: ALSA v: k5.10.141-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.57 running: yes

of I’m not quite sure what kind of other information would be useful here (and where to find it – I’m not too familiar with where everything is in Manjaro), so please let me know if there’s something relevant missing.

Use this command to disable pc speaker

Or see KDE documentation for DE audio notifications
System Settings/Accessibility/Bell - KDE UserBase Wiki
System Settings/Application and System Notifications/System Bell - KDE UserBase Wiki

So, that turned off the noises, by means of disabling the PC speaker (or better: its substitute). But as far as I can tell, that means that whatever chain of events caused it to be triggered may well still be happening, and there is no way now that it can make noises, even when/if it should make a noise.

Given that it was silent for years, that would still indicate that something on the machine is having hiccup, wouldn’t it?
In other words: The symptom is cured (which is good because it was getting incredibly annoying), but I don’t think the cause is dealt with…

Is there a little Bell on your System Tray (right end of task bar). That is what the bleep is about, there is a notification message.

No, there were no notifications popping up, and there still aren’t. Also, most notifications from the tray did not make a sound, since I had turned off notification sounds before.

Since the bleeps were continuing even when the display was off, I suspect that the noises were coming from a “deeper” level. Back in the day, I’m used to having a PC with a hard-wired speaker beep at me, (that is: without using the soundcard), when I tried to autocomplete a non-existent command in the console, or kept holding down the delete key after the entire line was deleted, or that kind of thing. Those wouldn’t cause anything to pop up from the tray, either. If I’m interpreting the issue right (no idea if I do!), then something similar would have been happening, somewhere in the background, at regular intervals, and independent of my interactions with the laptop.

If you have the motherboard manual, it might clue you in what the low-level “internal speaker” beeps mean, if there’s a peculiar pattern.

(Nothing to do with your actual “audio” devices.)

Clarification: I am (that is: was) hearing the bleeps on my laptop, which does not have a physical old-school PC (piezo) speaker (I like to call them squeakers), but only regular built-in speakers which get their signal through the audio adapter.
My understanding is that most laptops emulate the old PC speaker by playing some sound through the audio adapter instead, and that I just prevented my laptop from doing this. That would be the equivalent of disconnecting the squeaker on an old PC – which does not change the fact that something on the laptop keeps trying to make those noises.

Wouldn’t the motherboard manual still explain this? Even if such low-level alerts are played through Windows or Linux audio-stack?

Since there are no associated events/alerts/notifications under KDE, it’s a deeper level, as you suggest.

It’s a laptop. I have no motherboard manual.

And even if I had, it would certainly not be able to tell me which piece of software was using the squeaker. Back in the days before onboard soundcards were a thing, any game you played would be using it to try and make noises.

Maybe overheating?

The original PC speakers in the 80s were moving coil or moving iron speakers. Manufacturers switched to using piezo speakers when users started buying SoundBlaster cards for better audio.
Disabling PC speaker in XP device manager to get rid of the annoying beeps was always one of the first post-install configuration changes on my systems

To continue troubleshooting beep alerts from PC to establish if they are due to system errors; user errors or just a warning, delete the blacklist option

sudo rm /etc/modprobe.d/nobeep.conf

If the laptop is from a well-known manufacturer it should be possible to find a manual online. But the manual would probably only show BIOS beep codes that are not disabled by the modprobe blacklist and not relevant to beep alerts after OS is booted

I had this problem and it was linked to battery status
Go to Activity Power Settings
Go to Advanced Power Settings
Go to Configure Notifications
Untick “Play a sound” for all conditions and Apply

Unfortunately, that can’t be it in my case. all audio notifications, including related to battery status, are off, with the single exception of the action linked to “critical battery status”, which is set to play a sound, show a message window with a warning, start a count own and then power down the machine.
(I think I would have noticed if that happened).

The bleeps are back again.
The nobeep.conf is exactly as I left it half a year ago, but the laptop is happily bleping all over the place again. Can’t watch a video or listen to music on the thing. It’s like the laptop has hiccup…
I’m keeping sound completely off for now but that’s not a long-term solution.