Some problems with fresh Manjaro XFCE install on 2nd gen Intel laptop

I’ve been holding off registering and posting here in the hopes I could stumble upon a solution to these problems, but it hasn’t happened yet, so here I am. Hi! My experience installing and using Manjaro XFCE on a spare laptop has been mostly good, but some features are/were incomplete out of the box. Sorry if I’m supposed to separate these issues into different threads; I couldn’t find a rule anywhere that said to do so, and it seems less spammy to keep everything in one thread. I’m separating problems with numbers. Note also that I took screenshots of everything but am unable to include them in my post due to restrictions on new users.

About this laptop:
Sony VAIO PCG-61A12L / VPCEG37FM (attractive looking, if a bit flexible and cheap)
Intel Core i5-2450M
Intel Integrated Graphics (1366x768…mmmm so goooood)
Intel Dual-Band Wireless-AC 7260HMW (my upgrade from Centrino Wireless-N + WiMax garbage chip)
It actually has a blu-ray drive too! That was a nice surprise.

1. Samba network folder

My Linksys router is running dd-wrt firmware and recently I plugged in a 64GB USB flash drive to use as network storage, as I have three PCs and a phone that sometimes need to share files—makes sense right? It’s something new I’m trying rather than running a flash drive back and forth and creating additional wear on ports. After some finicky setup (I have tried this before and failed) I got it formatted ext2 and working. My two Windows 10 installs, Linux Mint Cinnamon 20.3 install with Nemo file manager, and Android 10 phone can access it and read/write using samba (or whatever’s built-in). With these it was fairly simple to either let the OS find it on the network or manually enter the path and map the drive. Then it prompted for the user/pw credentials and voila it opened the folder.

Not so for Manjaro XFCE.

Thunar can show the folder, but does not open it. I can get as far as smb://dd-wrt/ which contains the folder LINKSYS but when I double-click to open or right click context menu open, it does nothing. No pop-up prompts for credentials, no error message, nothing. The bottom info bar in Thunar says "LINKSYS": mountable. This behavior is exactly the same when I use the router’s local IP as the samba path.

If I manually enter in the address bar smb://dd-wrt/LINKSYS/ I get an error pop-up about failing to mount Windows share.
If I manually enter in the address bar smb://LINKSYS/ it says connection refused.

In previous threads there was talk of creating a samba user/password as a possible solution to the other user’s problem, using sudo smbpasswd -a user but this changed nothing. To be clear, I am trying to access a network share as a client; I have no need of sharing a folder on this machine. The USB drive plugged into my router is a samba share done by the router. Therefore, other threads and solutions I found didn’t seem to apply to my specific problem.

2. Bluetooth missing

Last night I was listening to a stream and couldn’t really hear it over other background noise and thought “let’s try the bluetooth earbuds…” only to find there was no bluetooth icon on the lower right to try connecting to anything. Opened the “start menu” and searched bluetooth, two entries came up: “Bluetooth Adapters” and “Bluetooth Manager.” Clicking “Bluetooth Adapters” did nothing. “Bluetooth Manager” brought up a settings window in which no dropdown menu works. I can click Adapter, Device, View or Help and it highlights the text but nothing happens for a long time…until an error message appears saying:

Bluez daemon is not running, blueman-manager cannot continue.
This probably means that there were no Bluetooth adapters detected or Bluetooth daemon was not started.

Furthermore, if I go in System Settings there is an entry in the Other category for Bluetooth Adapters, and clicking this causes the mouse cursor to spin forever until I close the settings window.

This is quite surprising to me because the Intel AC 7260 is seemingly a very common and well-supported card. I know it has working bluetooth because I was just using it in a Windows machine before this. Do I really need to manually start a daemon every time I want to use bluetooth? That’s not the behavior in Mint, if I recall. It just works. How do I go about this? Do I need to download a driver package? I’m not sure where to begin.

3. Sound

Is it normal XFCE behavior to have most system sounds reduced to a motherboard (emulated) speaker beep? If I am using backspace when nothing is left, it beeps. When I bring up power options to shut down, it beeps. Stuff like that. The sound DOES work; I can watch youtube videos, listen to music, all that jazz. Is it XFCE’s design philosphy of minimalism to not have any pre-packaged system sounds or something? It’s jarring. I don’t know what to think. It’s like getting mixed messages of “sound driver is missing so sound doesn’t work” but also “sound is actually working lol.”

4. Brightness control (solved - this is feedback)

After fresh install, both the keyboard and software brightness controls didn’t work. The display was always at 100% brightness. I have encountered this error before on other Intel laptops/netbooks using Linux several years ago. The solution was…again…to edit /etc/X11/xorg.conf.d/20-intel.conf to include

Section "Device" Identifier "Intel Graphics" Driver "intel" Option "Backlight" "intel_backlight" EndSection
(from ArchLinux wiki page “Backlight”)

And I’m wondering, if this is so common that I’ve encountered it multiple times, why do I have to do this in the first place? Why not sense the Intel chip and graphics during install and pre-generate this code in the config file? This is the sort of stuff that turns people off Linux—it’s not so user friendly to have to scour random internet posts and try lines of code until it finally fixes something. Brightness control is pretty important on a laptop, due to power saving considerations. It’s gotta work.

Here’s hoping someone here knows the solution to at least one of these problems.

And not to be too negative, let me tell you a couple things I like so far about Manjaro XFCE!

a] The power manager settings window shows battery wear level and that is awesome. The report is simple and easy to understand. By way of comparison, Windows’ powercfg /batteryreport is overly long and can have seemingly conflicting information. With I couple clicks I found out this battery is at 45% of original capacity, oh no! So sad!

b] The GUI package manager has some of my favorite programs ready to install, like Brave browser and Veracrypt. Way more convenient than their other install methods. Me likey!

c] It’s pretty lightweight on system resources! I’d have to work hard to fill this 8GB RAM, unlike in Windows. It breathes new life into this old laptop. HD videos and streams play smoothly. I may need to convince a friend to let me try installing it on her anemic laptop of similar vintage but lesser processor. We put Windows 10 on that one and it…well, it’s a slow, choppy mess of an experience.

Use this command to blacklist audio driver pcspkr that creates error beep

sudo tee /etc/modprobe.d/nobeep.conf <<< 'blacklist pcspkr'

Disable PC speaker - ArchWiki

Problem is known… and there is fix. But it will take some time until it reaches the repo. In the meanwhile you can patch the plugin like here described: Thunar Shares Plugin 'net usershare' error 255 - #10 by DAC324

Not using bluetooth myself, but probably you need to enable the service:

sudo systemctl enable --now bluetooth.service

Now it should start automatically

That put an end to the excessive beeping. Thanks!


  1. Samba
    So it looks like the samba share plugin is totally borked? Whether making a share or connecting to a pre-existing one? Well, then I’m glad this laptop functions mostly as a video player and backup machine. I’ll wait for the fix to come downstream.

  2. Bluetooth
    Running that did not make a functional difference, whether I tried bluetooth right away or after a reboot. The same errors and hangs occur.

Not totally. This plugin is a GUI for the backend net usershare. There was a change in the code of the backend and the plugin was not updated, since upstream it is not maintained anymore, though it still just works, it just needs a little adjustment. Simple as that.

Sorry, no idea. Have look at this article: Bluetooth - ArchWiki Maybe there are some hints for you :wink: