KDE System Settings "Autostart" missing

This capability is now missing in KDE Plasma 5.23 + kernel 5.15.
Is there any quick way to recover autostart in Plasma?

KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.15.2-2-MANJARO (64-bit)
Graphics Platform: X11

Kernel has nothing to do with that, and it is still there.


Autostart is not there.

I do have Autostart regardless of kernel. How: enter preferences and and start typing in search window in upper left hand corner.

Then something is wrong with your system.

$ pacman -Qo /usr/share/kpackage/kcms/kcm_autostart

/usr/share/kpackage/kcms/kcm_autostart/ is owned by plasma-workspace 5.23.4-1

(yes it has nothing to do with kernel. system updates - partial or otherwise mismanaged - maybe)


If it was that easy I would not even mention that.

I’m probably suggesting the obvious, but have you tried reinstalling plasma-workspace to see if it corrects your problem? I am fully updated and like others here, Autostart is not missing.

According to

it looks like the kcm_autostart on duty for the Autorun section functionality, but somehow in your OS copy it is not indexed/enumerated by KDE settings.

  1. If the package re-installation (and reboot after it) will not help, try to Clean cache to resolve upgrade problems
    but do it purely:
    -) logout from all active user sessions to sddm (login) screen
    -) switch to TTY (Ctrl+Alt+F3) or Fx, where the x is a number from 3 to 6. Textual login screen should appeared
    -) enter those 3 commands from Arch wiki
    -) systemctl reboot to reboot PC.

  2. If not helped, show us additional info, please:

    ls -l -Rh  /usr/share/kpackage/kcms/kcm_autostart/
    This should not expose your user name as it is expected be `root` by default. My example with listed `Autostart` section in KDE Settings
    ls -l -Rh  /usr/share/kpackage/kcms/kcm_autostart/
    total 24K
    drwxr-xr-x 1 root root    4 Oct 24 18:52 contents
    -rw-r--r-- 1 root root 8.3K Nov 30 19:19 metadata.desktop
    -rw-r--r-- 1 root root 9.9K Nov 30 19:19 metadata.json
    total 0
    drwxr-xr-x 1 root root 16 Dec  1 20:02 ui
    total 8.0K
    -rw-r--r-- 1 root root 6.0K Nov 30 19:19 main.qml

    b) post textual variant (click “copy” btn) of software section:

    kinfocenter about-distro

    c) try to open the section directly:

    systemsettings5 autostart

Thanks for the hint.
The issue solved by:
pacman -Su --overwrite "*" plasma-workspace
(had to add overwrite as it complained reinstalling with failing to (re)write some related files).

I did full update (with reboot) right before I found Autostart missing.
Yes, reinstalling plasma-workspace helped.

Thanks, reinstalling plasma-workspace helped in this case.