KDE shortcuts stopping to work sometimes

Hi everybody
Manjaro with all last updates, kernel 6.7.12-1-MANJARO, KDE Plasma.

Last couple of days noticed that Alt shortcuts stopped working :frowning: E.g. Alt-F2, Alt-Space, Alt-tab - no reaction.
Logged out and back in - everything works.
After some time - the same ■■■■ again.
Strange is that Alt-Ctrl-F3 works.
In Konsole Alt- combinations for MC still are working, even Alt-Tab. which has in MC different meaning.
In Konsole, if I press Alt-Tab, it’s just printing “Q” in command string (instead of running Krunner).
It seems that all the rest is working.
Restart - everything is working again. Checking logs didn’t gave anything.
Any ideas will be highly appreciated.
Thank you beforehand.

Teimuraz Abashidze

I had some slight issues with shortcuts - some caused by running Easystroke, and others which cleared up (after upgrading to Wayland) by cleaning out my $USER-SH1T ™ so it is rather important to mention if you’re in a Wayland or X11 session…

It’s very likely a $PEBCAK issue.

I’d suggest making a new USER and testing out your theory with a new profile.

If clear, then move your .config to .configBORKED and log out/in again, test again…

Also be sure to check logs.

For your ‘information’ for a basic start, you can open your menu and type ‘info’ and then copy and paste it between some backticks like this:
Code Here
Then you see:

Operating System: Manjaro Linux 
KDE Plasma Version: 6.0.3
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.3
Kernel Version: 6.8.4-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 5600G with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Product Name: B550M Steel Legend

Then the clever members of the forum won’t complain so much :wink:


Operating System: Manjaro Linux
KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.12
Kernel Version: 6.7.12-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Xeon® CPU E3-1245 v3 @ 3.40GHz
Memory: 30.9 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics P4600/P4700
Manufacturer: Hewlett-Packard
Product Name: HP Z230 Tower Workstation

I never used Wayland
I have no clue what is Easystroke and probably had never used it
Logs didn’t show anything interesting.

The problem is that it doesn’t happen immediately, but after some time after restart or logout/login.

Actually I’ve restarted comp on Friday before leaving to home, it was working, and now when I came back on monday it did it again :frowning:

I’m using Anydesk to connect my comp from outside, I was using TeamViewer before but it’s not working now, so I switched to Anydesk. And it has some strange behaviour with keys, for example in Midnight Commnader some Alt- combinations are not working… May it be related?

Alt combinations are fragile - to use Alt+S in Konsole, for example, one must first disable toolbars etc.

Hi @teimuraz1962,

Most assuredly it might. However, it might not also. The only way to confirm this speculation/theory would be to uninstall as far as I’m aware. I have anydesk here as well, although I use it very rarely and only ever as a client. It worked well every time I’ve tried it.

To remove it:

pamac remove anydesk-bin

I don’t think any user config will be removed.

:bangbang: Tip :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

1 Like