KDE Plasma kickstart issue: loop message "Applications updated."

@gan 10 days old ok. Me just couple of hours old. I hope issue doesn’t creep up for me. As for you try running commands anyway as those packages are part of Manjaro KDE 20.2…

1 Like

Oh, man! I search for kservice-git with pacman and I have that package too.
I’m just a bit tired, this evening. Why I searched for it ten minutes ago and I couldn’t find it? :face_with_thermometer:

I will try your solution, then. Thanks! :blush:

@gan Just copy-paste commands in terminal why you looking for them in Pacman ?

I like pacman. You see, old school… the command line has always been fashinating for me. :crazy_face:

This worked for myself. Issue appeared after configuring and running snap to install a package. Also happened earlier today but unsure what the issue was that time. Sort of a bummer but thankful for the forums!

I reinstalled manjaro 20.2 KDE and face this issue. both application updated and add panel disappearing.

reinstall the non-git version and the mv command totally solved my problem. Thanks, man!

Your solution works! Thanks!

Just coming here to say i’m also experiencing this issue (new install since a couple days ago, with latest manjaro kde iso. installed using manjaro architect)

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.9.11-3-MANJARO
OS Type: 64-bit
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31,3 GiB of RAM
Graphics Processor: GeForce GTX 1080/PCIe/SSE2

Solution posted upwards a few posts ago

I just want to add that this solution did not work for my two systems (nvidia & intel)
… Now I will try to recreate a new profile.

9:05 PM For me, recreating the profile from scratch was the solution, steps taken:

I open a terminal Ctrl-Alt-F2 with my current user (If my home/user is “mre”):

$ cd /home/
# sudo mv ./mre ./mre.bak
# mkdir ./mre
# chown mre:mre ./mre


After reboot the PC, copy carefully all the folders and settings from the previous backup home on the new one. Things like:


And much more carefully copy the content (of what you can recognize) of the following:

Check during each copy that the disgusting bug is not activated.

If the bug is reactivated, then you can probably determine the cause of the problem. From what I see, the problem seems to be related to Bauh, flatpak or appimage. Since I didn’t copy anything from your folders wherever I saw references to these.

Note: not everything will work correctly; for example: remmina is asking me for the passwords to connect… if I haven’t forgotten them, everything is solved (for me).

This is not easy, it is not fast, but after lasting +1 month with this ugly glitch, investing 1 or 2 hours is worth it.

Finally reboot to see the bug gone for now, until the KDE developers trip us up :see_no_evil: .

And if any of the KDE developers read this (I don’t think so), hopefully it will serve as a background for what they might do during each major plasma and component upgrade: reset the KDE and component configuration.

I PREFER that the plasma/desktop configuration is reseted to suffer this bug that prevents the use of KDE.

This is my solution, now I need to perform it on the PC I use at work, hopefully I will only lose the decorations I installed without losing a day or 2 hours of work.

I hope it will be useful to those like me who don’t want to leave KDE and switch to the awful gnome versions.


1 Like

So does this have a bug ticket yet that we can go upvote? Cause it’s clearly something that the devs needs to fix, right?

First off I would say check the normal ‘plasma is wonky’ things:

(possibly in conjunction with the above tips like making sure not to use git packages … and afterwards clearing out the cache and such)

If you absolutely must create a new user … then I made a tool for such migrations (well really for in between installs/systems … but it works here)

1 Like

I reported the bug two weeks ago and it has been fixed two days ago, no need to upvote anything :slight_smile:

For those that don’t have the update yet, the “solution” to the problem is to remove ~/.config/mimeapps.list No other configuration needs to be removed. Or simply not use kservice-git until it gets updated with that patch


Perfect. That seemed to be the case, just needed verification.
Marking your post as the solve rather than other mixed/heavy-handed workarounds.

Relevant bug report (for future reference perhaps) that I found because mine was marked as duplicate (didn’t find this original one at first)
And it has indeed been marked as fixed.

Other relevant threads:

@cscs, I try the @Zamundaaa solution, and neither works for me: removing the mimeapps.list didn’t work. But, I see that I have installed this foliate-git app:
image :thinking:
If the error comes back, I will try to remove foliate-git first.

The solution you have marked is not the one that has worked for me in this post.

Of course recreating my home/user profile has helped me on several occasions with this bug in these last 2 or 3 years. Sometimes the fix is just delete some config folder-file for ¿bauh/flatpak? or delete /home/mre/.local/share/applications/badapplication.desktop. I’ll check your Transfuse script, maybe it saves me time the next time.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.