KDE Plasma Desktop Wallpaper Black

Every few restarts my KDE Plasma wallpaper comes up black. I have checked video driver settings, nothing has changed, I’ve tried rolling back kernel releases and moved forward to new ones but the problem remains. I’m not running any experimental kernels, either.

I have found a work around but its not a solution:

Has anyone else had this problem and found a lasting solution? If so any advice would be helpful.

Thanks.

1 Like

Clean the cache folder in your home directory.
rm -r ~/.cache/*
And see if that helps, reboot the system.

Thanks I’'ll give it a go…

Regrettably clearing the cache did not solve the problem. May report it as a bug.

1 Like

Same issue on dual-monitor setup.
Switched to a single monitor and new HDMI Cable and now the black screen occurs on login screen (no mouse cursor).
After entering my password the desktop appears normally.
It’s a bug from KDE, and sadly still not fixed.

I’ll see if there is somewhere to report it…its been around a while by looks of things…

It’s already reported in KDE support forums.

I get random black screens on login screen with SDDM login/KDE, even with only one monitor attached.
It’s because of SDDM/KDE loading faster than GPU driver, see here:

I’m using AMD GPU so i added amdgpu (only!) and now it seems fixed.
Maybe this fix helps fixing the dual-monitor black desktop screen issue too?

e.g. amdgpu needs to be written between brackets:

/etc/mkinitcpio.conf

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=(amdgpu)

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=()

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS=(base udev autodetect modconf block keyboard keymap consolefont filesystems fsck)

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"
#COMPRESSION="zstd"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

Interesting. I’m using NVIDIA.

I had the same problem, when booting the screen is black (the wallpaper is black), there is mouse cursor, and the panel… the only ‘solution’ is to go to:
system settings/ display and monitor/ compositor and uncheck enable on startup then click apply and voila no more black screens at boot… you then just enable the compositor with the following shortcut: alt + shift + f12

2 Likes

Hi. I have the same desktop problem. I have a laptop with Intel graphics and a second monitor. Has anyone come up with a solution to this problem? Thank you

i provided a possible solution in the post above

This worked for me, thank you very much! :smiley:

Seemed a little bit too easy of a workaround to be real, but worked like a charm.
@brahma why does this even works? What’s going on? :no_mouth:

its probably some bug in compositor, so we have to just wait till its fixed from the kde side… until then, just enable the compositor at startup with the shortcut …