KDE Partition Manager create a new partition but I can't write into it

what happen

I use KDE Partition Manager to create a new partition. However, I have no permission to write.

steps to reproduce

I want to make a new partition(called temp on nvme0n1p6) use KDE Partition Manager and so it is. It is created successfully and it can be mounted. But when I tried to create a new file on the new partition, the color of new is grey, which means it is disable.

Then I try konsole. The result show that I do not have the privileges. I guess it is the pwd of admin when launch the KDE Partition Manager. Then I turn my user type from admin into user. Delete the partition and recreate, then do the same ting and get the same result.

xx% pwd
xx% mkdir tmp
mkdir: cannot create directory 'tmp': Permission denied
xx% ls     
xx% sudo mkdir temp
[sudo] password for kearney: 
xx% ls
lost+found  temp


  • partitionmanager 21.08.2-1
  • kearnel 5.13.19-2

what I have done

search about solution

At first, I look into the The KDE Partition Manager Handbook but there is no answer( FAQ included). Then I tried to search KDE Partition Manager create new partition or this tittle on stackoverflow and stackexchange but got nothing.

Last month I resize the partition of manjaro from 110 to 120 GB accordind to Handbook on a LiveCD mode(cause the app can not edit the mounted partition, so I need to unmount it). And it work totally fine.

I think I can do the same thing on the LiveCD mode, but I want to find out if there is another way. And advise is appreciate :grinning:


You can change the permission of the partition (folder) using the root acoount or
change /etc/fstab.

The dir should be mkdir /temp
then give yourself permission with chown -R username.username /temp

It is very nice of you guys to reply. I do this to give myself privilege as you guys advise.

xx% ls -g
drwx------ 2 root 16384 10月 25 20:40 lost+found
drwxr-xr-x 2 root  4096 10月 25 22:12 temp
xx% sudo chmod o+w -R temp 
xx% ls -g                  
drwx------ 2 root 16384 10月 25 20:40 lost+found
drwxr-xrwx 2 root  4096 10月 25 22:12 temp
xx% pwd
xx% sudo chmod o+w -R /run/media/kearney/temp 
xx% ls -g                                    
drwx----w- 2 root 16384 10月 25 20:40 lost+found
drwxr-xrwx 2 root  4096 10月 25 22:12 temp

Now I can write anything to it. :heart: Thanks all the time.

The easiest way is to simply install kde-servicemenus-rootactions then once installed simply right click in the folder you want access to and under root actions give ownership to active user.

wow, that is a good thing. Its copy is installed in deeping by default. I think kde does not the same thing. Now it is just I do not know about it. :+1:t4:

1 Like

It’s something that the OS devs should always include by default.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.