KDE not mounting ISO anymore


since a few moment, KDE cannot mount any iso anymore.
when I right-click on an iso file, nothing more appears (no mounting option)
I’ve tried with 3rd party plugin “Mount/Unmount by pulsar-ai” same issue (nothing happens)
Even Ark cannot open .iso files anymore…

fuse2, fuseiso, kio-fuse, and open-fuse-iso is well installed on my system…

Can’t find any help on the French forum, hope I will find here =)

Best regards !

Hi @NeedaVirus,


If you username is true, then you’re using the wrong OS.

Anyway, I don’t have that functionality either, but it’s never bother me since I don’t use it. So I searched a bit. I came across this, perhaps it helps:

Specifically: How to open and mount an ISO file via KDE GUI.

Hope it helps!

Its also been mentione din a few threads on these forums .. this quote has a workaround if you need it;

Continuing the discussion from Context menu in Dolphin - Mount ISO and disk images is gone:


I’m kind of confused. You don’t mount ISO files, you mount drives. You burn an ISO to a drive, using the appropriate software, to make it boot-able, then run it upon boot. Maybe this is a language problem?

I’m on unstable, and after upgrading

shared-mime-info to 2.4-1,
and dolphin-plugins to 23.08.3-2,

It seems that contextual menu entry is finally back.

NB: you should close all Dolphin instances after upgrading.

1 Like

You can mount an ISO file. It’s called a loop mount IIRC.


1 Like

Learn something new, here is best explanation I found for it What is a Loop device in Linux?

Back to the original posters question, I downloaded an ISO (Manjaro Plasma) and right clicked on it and no mount option. Don’t know if it was previously available I can extract it tho.

Mounting an ISO file in KDE should be simple enough, assuming all required software is in place:

In Dolphin, right-click the ISO file, select ‘Open With’ and choose ‘Disk Image Mounter’. The ISO file should now appear listed in the Dolphin Places panel (F9), under ‘Devices’; click that entry to mount the ISO file (or right-click, mount/unmount).

All being well, no additional right-click actions are needed.

There is a problem with that:

Yes. If gnome-disk-utility (Disks) is in place, that works around and resolves the issue of actions with similar functionality no longer working.

There are also several actions available via the ‘Download New Services’ dialog; I can confirm the OP’s comment that they also fail (or, at least the four I tried). How long this condition has existed, I can’t say, as I typically use the method I already described (above).

But the packages are coming with fixes;


That’s some useful information he could have also added.

What do you mean? … its there, its posted. #5
I’m only restating it because it appears ignored. But I cannot understand why.

1 Like

So it is. I missed that, obviously.

Hello :wink:
First, thank you all ! So many respond and helping ! Thanks.

After reading a lot of links posted, it appears to be an actual bug on KDE/Dolphin.
I’m absolutely beginner and not a powerfull user, so … I think I will just wait a little…

Removing *.iso file pattern from application/vnd.efi.iso didn’t work for me.
And I don’t know how to downgrade any package with Konsole, and don’t feel safe with it… So I will just wait a little for next shared-mime-info and dolphin-plugins updrage in Manjaro Stable :wink:

But Thank you all !

PS : And My nickname is funny fusion from and old time when I was using something called ‘windows’ and an old CD compilation called ‘VIRUS’ I’ve liked a lot :wink:


Thats only half of the workaround.
You were supposed to add something too.

If you will not or cannot do that … leave it be, as the packages

will fix the issue when they are updated to those versions.

1 Like