KDE Global Shortcuts

Quoting my old post from the archived forum, editing a bit since apparently I cannot post links in this new forum:

I’m facing the issue described here (reddit url)

The solution of creating ~/.local/share/kglobalaccel does nothing for me.

I’m running Plasma 5.19.3 with Kernel 5.6.19-2 (64 bits).

I posted this on July and the issue is still there. I really miss my shortcuts :frowning_face: I used to use them all the time in my previous laptop.

EDIT: I should also mention that I tried with different kernels and they made no difference.


Have you seen this?

Global shortcuts should be there by default. Creating and empty file will not help tho. And you might need to look at ~/.config/kglobalshortcutsrc instead.

Did you considered to do a system update?


Your system is out-of-date. The current Plasma version in Manjaro Stable is 5.19.5, and kernel 5.6 is EOL.

In addition to the above, you’ve also missed the updates of a couple of essential components of the system for which manual intervention is needed. The first of that was GRUB ─ to patch it against the Boot Hole vulnerability ─ and the second one was an update to pambase.

1 Like

Yes, sorry, I copied the text from my old post and forgot to change that. I’m currently on 5.7.19-2 and it still does not work. I’m going to try what @bogdancovaciu suggested above and get back to you guys.

Thanks! This works, although I liked it better before. How can I get that “newer Plasma” described in the comment? I have tried updating plasma-desktop and khotkeys but they were already up-to-date.

That newer plasma is the KDE Plasma GIT version from unstable branch. To be honest is fine, but you must be quite patient with it and the fact that there are updates almost daily might not be what you like :slight_smile:
Anyway, it resembles what Plasma 5.20 will be in a couple of weeks, few days after 2020-10-13

Okay, I see. I will wait then. Thanks, have a good day!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.