Kde global menu does not work

kde’s global menu, system applications that directly display the global menu after opening, such as konsole, dolphin, but there is a very strange problem, there are many third-party programs, such as chrome, edge, vscode, eclipse, global menu is not displayed when it is opened, at this time, open a system application, and then close it, the global menu appears, such as this operation: open chrome, global menu is not displayed , Then click konsole, the menu of konsole is displayed at this time, and then turn off konsole, the menu of chrone will be displayed at this time

1 Like

Yes, this is a known upstream KDE bug, and it has been around for a while already. They’ll fix it eventually, but I guess it doesn’t sit very high on their priority list. . :wink:

Try this plasmoid : https://www.opendesktop.org/p/1274975 .

I’ve tried that ─ it’s available from the AUR ─ and on my machine, the result is even worse. It only shows a global menu when both it and the official global menu widget are on the panel, and then you get two global menus. If you remove the official global menu widget and only use the replacement, then the menu is shown inside the application window.

All in all, the bug in the official global menu widget is not that catastrophic. You only have to switch over to a running Qt-based application and back, and then it’ll work for all GTK applications that support it. Not all applications do ─ Pamac and TimeShift do not, for instance. And for Firefox you need to use one of the alternatives instead, as I’ve explained in this thread below. :arrow_down:

I’ve tried KDE 5.21 beta,it has the same bug

Yeah, the bug was introduced in Plasma 5.19.4, I think. It’s probably so low on their list of priorities that it may only get fixed for the official release of 5.21. :thinking:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Not on Manjaro, but for reference:

  • Code - OSS 1.53.0 works with the global menu with KDE Plasma 5.20.5 on FreeBSD 14.0-CURRENT.

Related comment (with screenshot) in the helloSystem repo: Make VSCode work with the global menu · Issue #51 · helloSystem/Menu · GitHub

Use the latest version from the repo GitHub - psifidotos/applet-window-appmenu: Plasma 5 applet in order to show the window appmenu

git clone git@github.com:psifidotos/applet-window-appmenu.git
cd applet-window-appmenu