KDE + Firefox from 93 to 94 = hashed images

Hello i upgraded from Firefox 93 to 94 on a Dell Latitude E6530 and i now have problems of images “hashed” as if it was appearing image by image though it was fluid before. The sound remains fluid. For now, I also tested it on a Dell Vostro 3550 with a similar confguration / same internet connection but still in Firefox 93 and the video display is fluid.

In both cases the computers are i5 + 16GB RAM + 500MB SSD under KDE Plasma latest stable release. and Open GL 3

Anyone having a similar problem ? Anything i can check ?

No problem here with OpenGL 2.0 on Wayland session.

@cscs any more info you would need ?

CPU: Dual Core Intel Core i5-3380M (-MT MCP-) speed/min/max: 1585/1200/3600 MHz
Kernel: 5.14.10-1-MANJARO x86_64 Up: 2h 53m Mem: 2450.5/15908.2 MiB (15.4%)
Storage: 465.76 GiB (3.2% used) Procs: 203 Shell: Zsh inxi: 3.3.08

lshw -C display
description: VGA compatible controller
produit: 3rd Gen Core processor Graphics Controller
fabriquant: Intel Corporation
identifiant matériel: 2
information bus: pci@0000:00:02.0
version: 09
bits: 64 bits
horloge: 33MHz
fonctionnalités: vga_controller bus_master cap_list
configuration: driver=i915 latency=0
ressources: irq:30 mémoire:f6400000-f67fffff mémoire:e0000000-efffffff portE/S:f000(taille=64) mémoire:c0000-dffff

glxinfo|egrep “OpenGL vendor|OpenGL renderer”
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 4000 (IVB GT2)

glxinfo | grep “OpenGL version”
OpenGL version string: 3.0 Mesa 21.2.3

Physically i have 2 screens connected

  • laptop 15" 1920x1080 60hz
  • external 22" Dell P2210 (VGA-1) 1680x1050

Knowing that the symptom is the same with no external screen plugged in.

@flux i had already read it before installing Firefox 94 … which makes me think that someything is having a problerm.

Otherwise what i will do is reinstall the latest Mnajaro ISO to check it as i suppose that a clean install may solve it …

“So give Firefox 94 a try. If anything goes wrong, please file a bug. You can also disable EGL and switch back to GLX. Go to about:config page and flip gfx.x11-egl.force-disabled preference and restart browser.”

1 Like

i changed my Manjaro settings to Xrender / direct / best fluidity in spite of open GL 2 or 3 that was planting problems of performance … and changed that way video is back working in Youtube.

I think that i am going to make a clean new install and see if the problem is persistant with open GL.


Tested Youtube + Firefox with a fresh ISO installations.
Firefox 93 works in Open GL2 and Open GL3
If i upgrade to Firefox 94

  • no more works correctly with Open GL3 (hashed videos)
  • Works fine with Open GL2
  • if i switch to open gl3 then when i come ack to open GL2 it keeps having hashed videos.

End of my tests. I let better skilled users test it … anyway better not move to open GL3 or it plants problems with Youtube and certainly things to setup in a better way than i did.

At the end the question is : what is the best setting ? Anyway Open GL2 gives a better video quality than xrender as for what i could test on my configuration.

OpenGL 2.0 remains the KDE default, so best stick with that unless you have specific reason not to.

Also note that XRender has been removed in Plasma 5.23 - which should be in Stable soon.

1 Like

I made some more tests today and using Wayland solves the Opengl3 video problem. Moreover video seems globally better with Wayland.

I’ll stick to Wayland + Opengl2.

Maybe the solution would also be to have Wayland installed by default in spite of having to do sudo pacman -S plasma-wayland-session then switching from X11 to Wayland on start screen ?

On my old Ivy Bridge, Firefox 94 was laggy and choppy during scrolling; by setting gfx.x11-egl.force-disabled to true, has fixed such slowness.