KDE Dolphin is very slow at directory navigation after last update to 21.08.1

Do you have an idea why Dophin is slow at directory navigation since last update to 21.08.1?
I have tried to search in manjaro forum and other internet but did not find anything in this direction.

Dolphin starts fast (most of the time).
Everything else is working normally: firefox, thunderbird, bash.
Then navigation (klick on subdirectory) takes about 8 seconds. This time is always >5 seconds.
This wait time is also with other KDE programs (f.e. gwenview) in file selection menus. So it may be a software layer under Dolphin.
Filesystems are EXT4 and BTRFS, both similar slow.
SSD or HD makes no difference.
ls and other commands on terminal (bash) are fast as ever, no problem.
htop does not show any CPU load in the waiting periods, and memory is not exhausted.

I have disabled baloo (file search), but that makes no difference.
Tried also several customizing in dolphin (f.e. no display of directory volume): no difference.
Linux kernel is 5.10.68-1-MANJARO. The version before (I think 4.9…) was the same. So kernel version seems not the reason.
I have some nfs4 exports, but no nfs mounts on this machine.

Thanks in advance

Do you see the same problem with a new/fresh user?
Also please read:

Hi freggel,
yes, it is the same slow navigation with a new user.
Even with the empty subdirectories that were created in homedirectory.
I created the new user with useradd -m -G vboxusers,wheel newuser

dolphin started with bash did not give any information to CLI.

inxi --admin --verbosity=7 --filter --no-host --width
results in (shortend):
  Kernel: 5.10.68-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: \\vmlinuz-5.10-x86_64 
  root=UUID=xxx rw rootflags=subvol=@ 
  rootfstype=btrfs initrd=\intel-ucode.img initrd=\initramfs-5.10-x86_64.img 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  RAM: total: 7.66 GiB used: 2.9 GiB (37.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 

Sorry, but inxi outputs so much specific data that I am rather reluctant to publish it completely.

I sometimes have the same issue when I use filepicker within WPS Office (to save or open a file).
But never with Dolphin or any other KDE native app.

Can’t say anything helpful, sorry, I’m scratching my head as well.

Do you see the problem when booting the latest iso from live usb?

It should also include KDE Gear 21.08

I tried with manjaro-kde-21.1.4-210927-linux513.iso
It has Dolphin 21.08.1.
Navigation in dolphin is in this live-USB no problem and works fast as expected.

This seems to point to a (configuration?) problem with your current installation.
Did you try to mount all mountpoints used by your current installation in /etc/fstab and/or systemd mount units with the same mount options when booting the live iso?

Possible there is a hardware issue, related to another mounted drive?

Maybe mount all stuff in the Live USB Environment or go the other direction and unmount the drives in your installed Environment, to get sure all drives are okay and to archive the default speed.

I commented out all not necessary entries in /etc/fstab except / and /home.
Then the speed of navigation in dolphin was very fast!
Then I reactivated the mounts one by one, with restarts of the system in between, until the speed was going bad again. With following two entries I could destroy the perfomance of dolphin simply by uncommenting them. No system restart not even any mount/umount action in between. Only editing of fstab did the difference:

LABEL=EXT_HD6 /srv/nfs/m/h6 ext4 noauto,users,noatime,nodev,nosuid,noexec 0 0
LABEL=EXT_HD7 /srv/nfs/m/h7 btrfs noauto,users,noatime,nodev,nosuid,noexec,compress=lzo,subvol=@ 0 0

I do not see anything wrong with those entries. AFAIK noauto entries should not have any negative effect, at lease as long as they are not used.

BTW: I have a lot of noauto entries in fstab for all sorts of external USB sticks or SD cards or external HDs, in order to have them always on the same subfolder.
Most of my noauto entries were left commented, so the difference of above entry enabling was not that big as with all noauto entries enabled, but it was about a second delay.

1 Like

Interesting find!
This bug report seems to fit your description of the problem:
The last comment reported

things are worse since KDE Gear 21.08. Every process in need to list files is very very slow (ls in Konsole, Gwenview, Okular, …), Dolphin window is freezed

“This bug report seems to fit your description of the problem”

not exactly.
With bash commands (ls) and for example firefox I have no problems. Only KDE is reading /etc/fstab and makes problems out of it. Only difference was content of fstab, no change in mounts or other things.

Should I report this problem to bugs-kde-org?
Or do you have a communication channel to KDE developers that would be more efficiant?

1 Like

Please do.

No. Even if I had other “communcation channels”: an official bug report is the best way forward as other users could find it and possibly contribute (information) if they experience the same (mis-)behaviour.

Bug Report at KDE bugs (id=443370): 443370 – KDE / Dolphin stumbles over noauto entry in fstab: bad performance in navigation
(What is the trick to insert a link here?)

Thanks for your support!
It helped to track the error down to its reason! Now I have both

  • hope for an solution from KDE developer, and
  • a way to avoid the problem (comment out all noauto entries in fstab)
1 Like

Thank you for opening that bug report.
I’ve edited your post to include the link.

Posting links is allowed when a user reaches a higher trust level (discourse trust levels):

1 Like