KDE Crashes leads to black screen

Hello,
English is not my first language, so excuse me, please :slight_smile:

I installed Manjaro on a new Desktop PC a few days ago,
made some changes in the System Settings app and installed some software with pacman (including updates).
An hour ago i assume KDE crashed, for like the third time since Manjaro installation.
The effect is a black screen except that the previously opened applications seemed to still work for some seconds until they also crash or “go black”.
What i did today was just watching YouTube videos in Firefox.
Last Time i think it happened when doing the same, but I also used Android Studio on that day.
I always had a shell opened when that happened, so when i noticed the black screen around it i wondered, noticed that the Task Manager Panel was gone as well and tried to reboot.
The answer i got from the reboot command was “no permission” which was strange because it is configured to be allowed by my user, so with sudo something like: “can’t talk to initd” and “only logind available”.
Then the shell also crashed, or at least there was no visual output anymore.
I did not know what to do since it seemed like KDE somehow returned to the login daemon but gave no visual or textual input option. The hard shutdown it had to be after waiting about a minute or maybe 5 on one of the earlier crashes.

To my Configuration:

inxi -F                                                                                                                                                                                                                      ✔ 
System:
  Host: ManjaroDesktop Kernel: 5.15.28-1-MANJARO x86_64 bits: 64
    Desktop: KDE Plasma 5.24.3 Distro: Manjaro Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: B350 GAMING PRO CARBON (MS-7B00)
    v: 1.0 serial: <superuser required> UEFI: American Megatrends v: 1.60
    date: 09/20/2017
CPU:
  Info: 8-core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1648 min/max: 1550/3000 cores: 1: 1279 2: 2404 3: 1334
    4: 1325 5: 1698 6: 1298 7: 2148 8: 2254 9: 2327 10: 2274 11: 1369 12: 1339
    13: 1349 14: 1281 15: 1280 16: 1413
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    driver: amdgpu v: kernel
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu,ati
    unloaded: modesetting gpu: amdgpu resolution: 1: 1920x1080 2: 1920x1080
  OpenGL: renderer: AMD Radeon RX 580 Series (POLARIS10 DRM 3.42.0
    5.15.28-1-MANJARO LLVM 13.0.1)
    v: 4.6 Mesa 21.3.7
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    driver: snd_hda_intel
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
  Device-3: Asahi Kasei Microsystems AK5370 I/F A/D Converter type: USB
    driver: snd-usb-audio
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel I211 Gigabit Network driver: igb
  IF: enp30s0 state: down mac: 30:9c:23:61:7d:e3
  Device-2: Realtek RTL8192EE PCIe Wireless Network Adapter
    driver: rtl8192ee
  IF: wlp35s0 state: up mac: i guess you dont need it :)
Drives:
  Local Storage: total: 232.89 GiB used: 49.48 GiB (21.2%)
  ID-1: /dev/sda vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB
Partition:
  ID-1: / size: 227.88 GiB used: 49.48 GiB (21.7%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/sda1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 48.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 722
Info:
  Processes: 342 Uptime: 1h 19m Memory: 15.63 GiB used: 2.67 GiB (17.1%)
  Shell: Zsh inxi: 3.3.13

As you see in the CPU section i have simultaneous multi threading enabled, my best guess would be to turn it off, just not having a better idea.

So if you know about this kind of problem, let me know, please. I saw how to restart kde here and did that once when only my left Display got black (yesterday or so) which helped.
But i did not try to restart KDE instead of rebooting for this problem today, just because i did not remember how the command goes.
Other Topics in our Forum seem to only have black screens right when booting and i found nothing that also had this strange back to logind thing.

I looked through the journalctl logs of at least two of these crashes but found nothing that i could interpret so maybe you know to interpret some :slight_smile:

the Repository is public and there are 3 files, crash_logs is only kernel output, and the one with android is from another day.
Time of crash today around 17:45

As I said i have the AMD SMT turned on and i use kvm or better speaking libvirtd to emulate an android device in Android-Studio. I can imagine that all this is connected, so please tell me if you know further commands to check what might be set wrong.

When i run pacman -Dkk it actually gives output but i saw online that this does not have to be a problem but i now think i probably get those packages…

pacman -Dkk                                                                                                                                                                                                                1 ✘ 
error: missing 'rt3562sta-common' dependency for 'linux414-rt3562sta'
error: missing 'rt3562sta-common' dependency for 'linux49-rt3562sta'
error: missing 'update-notifier' dependency for 'limepanel'
error: missing 'manjaro-browser-settings-native' dependency for 'manjaro-bspwm-mate-settings'
error: missing 'breath2-icon-themes' dependency for 'manjaro-kde-tx-settings'

Edit:
It also happens under X11, i tried to write the message about logind to a file but it said “read-only filesystem”, then i had to hard shutdown again.
I could not find a reason why KDE crashes or what causes this logout with no screen, nor do i have an idea what else to try.

Just a little extra note: I used xrandr to adjust my screens

#!/bin/sh
# Xsetup - run as root before the login dialog appears

xrandr --output DVI-D-0 --auto
xrandr --output HDMI-A-0 --auto --right-of DVI-D-0 --primary

I wonder so much because it’s a pretty fresh install, what did i do wrong, what might be connected to such crashes?
One thing that might be caused by the same miss-configuration is that my yakuake just does not want to remember to open only on screen 1, it always sets back to screen 2 after boot, and only the “follow the mouse option”, the default option, is not changed after boot.
I saw more than one topic about desktop-setting losses, so maybe that’s even another problem.

Thanks everybody for your time.

Plasma Wayland is unstable, switch to X11.
If you want Wayland, should use p.e. Gnome

1 Like

i think wayland was just set as default, i will try that

Really? that’s should be new, idk.
Anyway, don’t trust me so much, wait for better answers.

do you actually know where the gui setting is for switching to x11, i know for sure that i saw that option but cant find it anymore,
this solution does not help, i dont see any “advanced tap”

and yes i would have done that in sleepwalking mode if its not the default

It should be on login screen (SSDM)

thanks @VioletF but i now only found the option to login automatically but that is not actually what i want, that would skip the password


I meant, when you restart or log off, in the screen you write the password, it should be there, a menu to choose it.

2 Likes

i guess that’s it, on my laptop i run x11 for a few years now and it wasn’t that bad at least

@Bluntjaro See if this helps:

1 Like

I had to take away the solution marking, sorry ^^

it happened again, now with x11, but it was a bit diffrent:
i had no time to notice, everything got black and the monitors said “no signal”, which did not happen under wayland…

First, thank you for the hint.
I just wanted to say that i did not change the sddm.conf, i could not find any setting that makes no sense to me and since it should be the default - only not if the System Settings App changed it - i don’t excpect to make anything better by editing it.

cat /etc/sddm.conf                                                                                                                                                                                                           ✔ 
[General]
InputMethod=
Numlock=none

[Theme]
CursorTheme=breeze_cursors
DisableAvatarsThreshold=7
EnableAvatars=true
FacesDir=/usr/share/sddm/faces
ThemeDir=/usr/share/sddm/themes

[Users]
DefaultPath=/usr/local/sbin:/usr/local/bin:/usr/bin
HideShells=
HideUsers=
RememberLastSession=true
RememberLastUser=true
ReuseSession=false

[Wayland]
EnableHiDPI=false
SessionCommand=/usr/share/sddm/scripts/wayland-session
SessionDir=/usr/share/wayland-sessions
SessionLogFile=.local/share/sddm/wayland-session.log

[X11]
DisplayCommand=/usr/share/sddm/scripts/Xsetup
DisplayStopCommand=/usr/share/sddm/scripts/Xstop
EnableHiDPI=false
MinimumVT=1
ServerArguments=-nolisten tcp
ServerPath=/usr/bin/X
SessionCommand=/usr/share/sddm/scripts/Xsession
SessionDir=/usr/share/xsessions
SessionLogFile=.local/share/sddm/xorg-session.log
UserAuthFile=.Xauthority
XauthPath=/usr/bin/xauth
XephyrPath=/usr/bin/Xephyr

I removed “matray” from auto start and added a 10-monitor.conf file. i guess the problem was matray, it was preinstalled :thinking:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.