Just switched to Manjaro but the sound quality is awful

Hi all,

I’ve just installed Manjaro on a spare laptop that was previously running Windows 10 (Thinkpad X240) - the sound quality on it is absolutely disastrous compared to Windows though - has anyone had any success in fixing it?

Many thanks in advance :slight_smile:

share ouput of inxi -A

Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes

follow this guide - Enable High Quality Audio on Linux | by Gamunu Balagalla | Medium


Thank you!!! That’s much better! :smiley:
Do you know why the distro doesn’t come with those settings already changed if changing it is as easy as that?

Well, the author of the interesting article linked above explains it as follows:

It happens to be that distribution maintainers of Ubuntu, Arch like distros have configured the default configuration of sound, graphics and fonts to work with all the computers that you can find on the market, or for at least work with most of them.

According to this, the default settings seem to be something like a golden compromise that is supposed to fit on as many as possible computers. Sometimes, however, they do not fit.

1 Like

Oh ok, I read that but I’m guessing what has happened is @ishaan2479 must have given me a specific guide to work with my specs? Maybe there could be a repository somewhere to help people get these problems fixed depending on their distro/hardware setup

PulseAudio is configured for CD quality audio so it is backwards-compatible with older audio devices
But most modern hardware will support DVD/HD audio and will benefit from turning a few settings up

I do not consider the article linked from post#4 is as good as the information on this forum
(I can’t copy/paste from that page easily and don’t want to post about it on twitter instead)

It is better to create a custom user configuration in home folder ~/.config/pulse/daemon.conf
instead of editing system default configuration

These settings are good for improving audio quality

resample-method = soxr-vhq
default-sample-format = float32le
default-sample-rate = 48000
alternate-sample-rate = 44100

The soxr resampler has the best audio quality but some users might prefer the speex resampler for lower latency or less load on CPU and RAM

resample-method = speex-float-5

Most of the other settings listed in the article are no different to default settings and are not necessary
for improving audio quality

This command will show the active configuration settings

pulseaudio --dump-conf

Manjaro users should disregard suggestion to create ALSA configuration file /etc/asound.conf
The configuration suggested is using the resampling plugin plug and not a direct hw connection as alleged
Author is probably like most Linux users and does not know much about ALSA configuration,
because most people don’t need to know about ALSA.
Additional sound servers running above ALSA are preferred for additional audio functions

ALSA is configured on Manjaro by package pulseaudio-alsa (or pipepwire-alsa)
Most users can set their audio levels in ALSA one time and ALSA will Keep on Chooglin


When I try that I’m told 44100 is not a valid sample rate.

1 Like

That’s because there an extra 0, it should be 44100. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.