Just reset my laptop and I've lost plasma?

So i boot into a blank screen as of today? Please help.

I tried switching to tty2 and running startx. I could only take a photo of the results as i cant copy anything.

Just to get your startx working:
startkde has long been replaced by startplasma-x11

As to the original problem: check journal for errors and check sddm.service (display manager) which is responsible for starting up x11.

1 Like

well iv tried executing startplasma-x11 in my console and tty2

i get this in my normal console (tty1)

❰greg❙~❱✘≻ startplasma-x11
Warning: Unable to load any usable ISO8859 font
“xmessage” ("-geometry", “500x100”, “Plasma seems to be already running on this display.\n”) exited with code 11
Plasma seems to be already running on this display.

and on tty2
$DISPLAY is not set or cannont connect to Xserver

I have run cp /etc/skel/.xinitrc ~/.xinitrc , it did change my startkde to startplasma-x11. I have rebooted but it still fails.

Not sure how to reset my sddm back to default without a GUI?

i checked journalctl -b | grep -i ‘sddm.service’ but there is nothing there.

tried “startx” in my console

❰greg❙~❱:heavy_check_mark:≻ journalctl -b | grep -i ‘sddm.service’
❰greg❙~❱✘≻ startx

/usr/lib/Xorg.wrap: Only console users are allowed to run the X server
^Cxinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: unexpected signal 2
Couldn’t get a file descriptor referring to the console.
❰greg❙~❱✘≻

in tty2

It kinda loaded something but just a blank/black screen with a mouse cursor :frowning:

I have managed to change my sddm back to “breath” but it still fails to show plasma when rebooted.

@freggel.doe
ah thank you for the link, as described on that link the problem is event calendar. I have removed it and we are back up and running but i use event calendar a whole load, so what do i use now?

1 Like

In such cases it’s better to check for all errors since booting up:

$ journalctl -b -p err

and if looking at a special service:

$ systemctl status sddm.service

Ah, nice. Glad you solved it.

Probably waiting for a fix/workaround is enough as the problem seems to be “universal” (as in: hitting all installations atm). One never knows how long that might take though :man_shrugging:

1 Like

So it seems the dev of event calendar has already fixed the problem. Black Screen on Login / Crash on Arch/Manjaro (Qt 5.15.1) (EventCalendar v68 and below) · Issue #154 · Zren/plasma-applet-eventcalendar · GitHub

So the problem was that there was a conflict between a widget installed by the “normal” widget install method (panel context, add widget, etc) and/or the main package manager method (yay -S plasma5-applets-eventcalendar). It seems that if you installed it via the “panel add widget” then it was never updated, which leaves me wondering, do widgets / sddm’s / icon packs etc, those kinda of installers get updated at all?

1 Like