Just installed XFCE 20.0.3, can not login after update

Hey there!

While searching for the topic in Google, I came across the manjaro forum links however, those posts seem to be lost or deleted.

The user/pwd info is correct, the error message says ‘Failed to Start Session’

Would anyone please help?

Regards
M

It would seem your user profile is borked somehow.
What else did you do besides update? (and how did you do that?)

I’ve found that removing some of the .x/.X files has helped me on other distros with issues like these. Instead of removing them, move them to a different directory or filename just in case. You’ll have to do this in a TTY unless another session works.

For example, maybe try doing this with .xinitrc and see if it helps.

Hope this can help!

It really could be any number of dozens of dotfiles in the home directory :grimacing:

1 Like

Very true! I had this issue on Ubuntu after messing with Unity almost two years ago… While that says it all, Lightdm really doesn’t give much useful info to troubleshoot with.

have you checked for

sudo systemctl status lightdm.service

Thank you all for the kind responses. I made a fresh install of Manjaro and that solved my issues. This time I updated via terminal rather than the gui update, thinking maybe I’ve mis-clicked a dependency etc…

you should have tell us that you have got error with gui update ,
that reveals ends update if drivers videos stopped

  • you could also boot on USB iso and go in chroot for ends updates
  • or open a TTY ( Ctrl + Alt + F2 to F7 ) to ends updates