Just installed Manjaro and no sound at all

I just installed Manjaro (XFCE) and I am already encountering audio problems. I went to go watch a video on YouTube to finish the tutorial on Mutahar’s “Poor-Shamed” PC, but there was no sound at all. In the bottom right my volume bar is at about halfway. I went to audio mixer and it let me to ‘pavucontrol’, and in that I found that the video was showing as playing audio in the playback section but I still could not hear it. I go to the output and input section and they are attached to a “dummy” and when I select to show only hardware devices there are none. I do not know why Manjaro is not detecting my internal speakers or microphone and if anyone knew how to help that would be great.

-Edit: I also tried plugging in a headset into the audio jack and that also failed.

Please try installing sof-firmware. Also post the output of inxi -Fazy, and run pa-info | curl -T - https://aptget.xyz/pa-info.out and post the link you get.

I cannot figure out how to install sof-firmware, but I did get the 2 outputs of the commands but whenever I try to post this it tells me I cannot have links in my text, and the links are kinda part of the log. Gonna post it with the things it thinks are links deleted anyway.

Output from inxi -Fazy:
System:
Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64
root=UUID=5615ae1a-7538-454b-bba0-4c7866b45a62 rw quiet apparmor=1
security=apparmor resume=UUID=2bddba19-579a-4125-afac-2dd32ca4edbf
udev.log_priority=3
Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:
Type: Laptop System: ASUSTeK product: TUF Gaming FX505GT_FX505GT v: 1.0
serial:
Mobo: ASUSTeK model: FX505GT v: 1.0 serial:
UEFI: American Megatrends v: FX505GT.307 date: 06/24/2020
Battery:
ID-1: BAT0 charge: 39.9 Wh condition: 39.9/48.1 Wh (83%) volts: 12.7/11.7
model: Simplo SDI ICR18650 type: Li-ion serial: status: Full
cycles: 41
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
serial: charge: 55% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP
arch: Kaby Lake family: 6 model-id: 9E (158) stepping: D (13) microcode: D6
L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 38408
Speed: 1911 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 2565 2: 3655
3: 2146 4: 1683 5: 1776 6: 2818 7: 2536 8: 3599
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:3e9b
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK
driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1f91
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus ID: 1-11:3 chip ID: 13d3:56a2 serial:
Display: x11 server: X.Ogr 1.20.9 driver: intel,modesetting,nouveau
alternate: fbdev,nv,vesa display ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5")
diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.8
direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: sof-audio-pci
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3
chip ID: 8086:a348
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:10fa
Sound Server: ALSA v: k5.8.11-1-MANJARO
Network:
Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel
port: 5000 bus ID: 00:14.3 chip ID: 8086:a370
IF: wlo1 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 02:00.0
chip ID: 10ec:8168
IF: enp2s0 state: down mac:
Drives:
Local Storage: total: 931.51 GiB used: 6.38 GiB (0.7%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB
block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 5400 rpm serial: rev: SDM1 scheme: GPT
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 5060 bus ID: 00:17.0 chip ID: 8086.282a rev: 10
Partition:
ID-1: / raw size: 896.87 GiB size: 881.80 GiB (98.32%) used: 6.38 GiB (0.7%)
fs: ext4 dev: /dev/sda2
Swap:
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 34.34 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3
Sensors:
System Temperatures: cpu: 52.0 C mobo: 27.8 C gpu: nouveau temp: 42 C
Fan Speeds (RPM): cpu: 2700
Info:
Processes: 248 Uptime: 20m Memory: 31.22 GiB used: 1.39 GiB (4.4%)
Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1056 lib: 311
flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05

Output from pa-info | curl -T - https://aptget.xyz/pa-info.out:
dmesg: read kernel buffer failed: Operation not permitted
ttp://aptget.xyz/bAVVi/pa-info.out

sudo pacman -Syu sof-firmware

and then reboot.

Please also run sudo dmesg | egrep '(snd|sound|sof)' after rebooting and post the output.

1 Like

Output from `sudo dmesg | egrep ‘(snd|sound|sof)’:

[ 0.992088] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[ 0.992098] software IO TLB: mapped [mem 0x70d34000-0x74d34000] (64MB)
[ 9.759645] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[ 9.759649] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[ 9.759857] snd_hda_intel 0000:01:00.1: Disabling MSI
[ 9.759863] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[ 9.854499] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input18
[ 9.854568] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input19
[ 9.854626] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input20
[ 9.854693] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input21
[ 10.541936] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[ 10.541938] snd_soc_skl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[ 11.711962] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[ 11.711967] sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[ 11.712206] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
[ 11.712333] sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 11.718972] sof-audio-pci 0000:00:1f.3: use msi interrupt mode
[ 11.784333] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[ 11.784335] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[ 11.784341] sof-audio-pci 0000:00:1f.3: DMICs detected in NHLT tables: 4
[ 11.988132] snd_hda_intel 0000:01:00.1: bound 0000:01:00.0 (ops nv50_audio_component_bind_ops [nouveau])
[ 12.582577] sof-audio-pci 0000:00:1f.3: Firmware info: version 1:5:1-88707
[ 12.582584] sof-audio-pci 0000:00:1f.3: Firmware: ABI 3:16:0 Kernel ABI 3:16:0
[ 12.582988] sof-audio-pci 0000:00:1f.3: warning: unknown ext header type 3 size 0x1c
[ 12.583010] sof-audio-pci 0000:00:1f.3: warning: unknown ext header type 4 size 0x10
[ 12.678545] sof-audio-pci 0000:00:1f.3: Topology: ABI 3:16:0 Kernel ABI 3:16:0
[ 12.678559] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp3 Tx not handled
[ 12.680151] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec0_in not handled
[ 12.680159] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp2 Tx not handled
[ 12.681682] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec1_in not handled
[ 12.681689] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp1 Tx not handled
[ 12.683057] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec0_out not handled
[ 12.683066] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Analog CPU Playback not handled
[ 12.684626] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec1_out not handled
[ 12.684632] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Digital CPU Playback not handled
[ 12.684637] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec2_in not handled
[ 12.684641] sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Alt Analog CPU Playback not handled
[ 12.684646] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec2_out not handled
[ 12.684650] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Analog CPU Capture not handled
[ 12.685831] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp1_out not handled
[ 12.685837] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Digital CPU Capture not handled
[ 12.686937] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp2_out not handled
[ 12.686944] sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Alt Analog CPU Capture not handled
[ 12.688031] sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp3_out not handled
[ 12.698596] sof-audio-pci 0000:00:1f.3: ASoC: Parent card not yet available, widget card binding deferred
[ 12.717681] snd_hda_codec_realtek ehdaudio0D0: autoconfig for ALC233: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 12.717687] snd_hda_codec_realtek ehdaudio0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 12.717690] snd_hda_codec_realtek ehdaudio0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 12.717692] snd_hda_codec_realtek ehdaudio0D0: mono: mono_out=0x0
[ 12.717694] snd_hda_codec_realtek ehdaudio0D0: inputs:
[ 12.717697] snd_hda_codec_realtek ehdaudio0D0: Mic=0x12
[ 12.981096] snd_hda_codec_realtek ehdaudio0D0: ASoC: sink widget AIF1TX overwritten
[ 12.981105] snd_hda_codec_realtek ehdaudio0D0: ASoC: source widget AIF1RX overwritten
[ 12.981197] skl_hda_dsp_generic skl_hda_dsp_generic: snd-soc-dummy-dai <-> DMIC 6 mapping ok
[ 12.981207] skl_hda_dsp_generic skl_hda_dsp_generic: snd-soc-dummy-dai <-> DMIC16kHz 7 mapping ok
[ 12.981223] skl_hda_dsp_generic skl_hda_dsp_generic: snd-soc-dummy-dai <-> HDA Analog 0 mapping ok
[ 12.981236] skl_hda_dsp_generic skl_hda_dsp_generic: snd-soc-dummy-dai <-> HDA Digital 1 mapping ok
[ 12.981246] skl_hda_dsp_generic skl_hda_dsp_generic: snd-soc-dummy-dai <-> HDMI1 3 mapping ok
[ 12.981256] skl_hda_dsp_generic skl_hda_dsp_generic: snd-soc-dummy-dai <-> HDMI2 4 mapping ok
[ 12.981266] skl_hda_dsp_generic skl_hda_dsp_generic: snd-soc-dummy-dai <-> HDMI3 5 mapping ok
[ 12.996356] input: sof-hda-dsp Front Headphone as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card1/input27
[ 12.996487] input: sof-hda-dsp HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card1/input28
[ 12.996597] input: sof-hda-dsp HDMI/DP,pcm=4 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card1/input29
[ 12.996707] input: sof-hda-dsp HDMI/DP,pcm=5 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card1/input30

Anything else I have to do?

My friend says you messed up my audio up more is this true?

Howdy, can you please try to sudo pamac install pavucontrol please?

I did the command but I already had it pre-installed

Can you enter amixer in the terminal and see if the master volume is not muted, please?

The master is at 0 currently
Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Mono:
Front Left: Playback 65536 [100%] [on]
Front Right: Playback 65536 [100%] [on]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 65536 [100%] [on]
Front Right: Capture 65536 [100%] [on]

how do I unmute it?

To the bottom center, above master, is it mm or 00 ?

I dont have the sof-firmware anymore because Im following through a gpu hijack thing for a vm and it reset it back to having no audio outputs or inputs. Tried redownloading it again and now its still not showing up so I screwed something and Im trying to figure out what im doing wrong this time, also it was muted I unmuted it via alsamixer but now sof is not showing up there at all

Okay, can you hit f6 in alsamixer and choose the right sound card?

the only options are default and HDA NVidia

Hm, enter this sudo echo "options snd-hda-intel dmic_detect=0" | sudo tee -a /etc/modprobe.d/alsa-base.conf in the terminal, followed by sudo echo "blacklist snd_soc_skl" | sudo tee -a /etc/modprobe.d/blacklist.conf , then restart.

My friend says you messed up my audio up more is this true?

your audio was already messed up
According to ASUS website specifications, FX505GT has

Built-in 2 W Stereo Speakers with Array Microphone

The Internal digital array microphone (DMIC) requires package sof-firmware to get the correct driver

and probably needs pulseaudio-git from AUR to get the internal audio fully supported

HP Envy - Sound does not work in Manjaro 20.1 PLASMA

kernel 5.8 together with pulseaudio-git (v13.99) made it - sound and microfone work now

I had first to remove libao, fluidsynth, lib32-fluidsynth and manjaro-pulse
after that I could install pulseaudio-git
having installed pulseaudio-git I added libao, fluidsynth, lib32-fluidsynth and manjaro-pulse


also suggest you consider updating system to latest firmware
FX505GT BIOS & FIRMWARE | ASUS Global

1 Like

That option is ignored by newer kernels with the following warning:

dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead

1 Like

i’ve this issue one time and, after sleeping my pc and opening back the sound comes back, that was confusing :confused: