Japanese Input Method Does Not Work

Hello. I’ve been trying to get a Japanese Input Method to work but none of the threads or posts I’ve read seem to work. To be specific, I am looking for a layout that when I type “hi”, it switches to ひ.

KDE 5.21.4

These are the relevant (I think…) packages I installed.

fcitx-configtool 0.4.10-4
fcitx-mozc 2.26.4220.102.g1882e33-1
fcitx-qt5 1.2.6-1
kcm-fcitx 0.5.6-1
otf-ipafont 003.03-8

Now I have “Input Method” in my system tray. However, it is stuck on my default: Keyboard - English (US) - English (intl., with AltGr dead keys).

If I try to change to anything else like Mozc or Keyboard - Japanese, nothing happens, it stays on my default layout. If I click “Restart”, it will switch to Mozc for a moment (before switching back), but it doesn’t seem to type Japanese characters.

Changes in Manjaro → Keyboard Settings don’t seem to have any effect.

Adding a Japanese layout in Hardware → Input Devices → Keyboard doesn’t seem to have an effect either. The preview for the regular Japanese layout looks like this which I don’t think is correct.

I have the ja_JP.UTF-8 locale installed.

I would greatly appreciate the help.

Did you go through https://wiki.archlinux.org/index.php/Fcitx?
Also check https://archived.forum.manjaro.org/t/japanese-input/94580/4.

Some time ago I installed ibus with hangul for a friend, but I don’t use either. My expertise ends with the ibus icon showing that the keyboard input method was switched. Searches hint that ibus is an alternative to fcitx (https://wiki.archlinux.org/index.php/IBus) - you may try that also.

I uninstalled and reinstalled everything and it began to work. I am still not sure what the problem was.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.