Japanese IME enablement

Install ibus and ibus-mozc i think, gnome integrates with them, you should after be able to select language in the settings app, i cannot verify now, (I now ise KDE) but if it doesn’t work i can spin up a VM and figure it out.

but you should only need to install those two packages and it should work

EDIT: you will need to install it from the AUR IBus - ArchWiki

You can use Ibus-anthy or ibus-kkc however Ibus-mozc for me is easily the best experience out of box, Anthy is effectively dead and kkc is just kana string to kana-kanji string

As for installing fonts I reccomend you install
otf-ipafont - likely will be the main font you want to use
ttf-hanazono - a good quality font for backup
ttf-sazami - outdated but some old programs work best with it, likely wont use but good to have anyway
Some other fonts are listed here Localization/Japanese - ArchWiki but the ones I listed will cover you in most cases

Its a shame that mozc ibus is not in the main repository in manjaro or arch in general, despite it being pretty much the best experience (Both KDE, and Gnome have native integration for it and nothing else making it pretty much the defacto “easiest use” setup

EDIT2: KDE DOES have native fctix integration too with kcm-fcitx package, and does work better than Ibus, as Ibus just works within kimpanel

Hello everybody!

Having the issue with Japanese input as well. Having been reading around I get that Japanese input is not on the top of the priority list due to having a small user base in Manjaro community.

Still, I really love Manjaro, but need to get Japanese context aware input working. Used mozc on fcitx in Linux Mint were it worked almost like IME in Windows.

Can you help me please to get it work?

Thanks ahead

皆さん、こんばんは! Got the issue solved

In Manjaro 21.0 Gnome, it is enough to install an AUR package ibus-mozc-ut (the most currently modified).
These are the contents of my ~/.xprofile:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
ibus-daemon -drx

Then choose “Region & Language” under the Settings and select “Japanese (Mozc)” as an Input Source. Then log out and log in.

@birdyjapan I hope you’ll get it solved. :slight_smile:

Build of the package ibus-mozc-ut took time around 20 min. In addition to that, it might be possible that I already installed some Japanese fonts when I was trying to get fcitx working in Manjaro.

1 Like

I personally recommend fcitx5 over ibus. Works better from my experience. But! If it works for you, that’s great.

It was good for me on Linux Mint. Couldn’t get it work here, but it seems ibus is integrated already. I also read somewhere that ibus is integrated better into Gnome than fcitx. My issue might be that I wasn’t very version aware when I tried to install fcitx.

Does setting up fcitx5 work the same way as I described for ibus?

I just had Japanese input interupting input while typing kanji while commenting on Instagram Stories.

Well for fcitx5, you’d sudo pacman fcitx5 fcitx5-mozc fcitx5-qt fcitx5-gtk and then instead of:

It would be:

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

I forgot that GNOME has ibus integrated. I don’t personally use GNOME so I don’t know if ibus works better or not on GNOME

1 Like

I’ll see some time, maybe today, if I can set up fcitx5. My issue with it was, that in the configtool I was unable to select any languages. No input methods either. They just weren’t there.

It might be a noob issue, but If I manage to get past that and get fcitx5 working as well (not at the same time, since it might cause issues, I guess), it would be amazing for newcomers to refer to this post in the future.

Realmain, do you have any ideas, why that not having any languages in the configtool setup menu is happening?

I do not as I never heard of configtool. Never had to use that for language stuff.

You don’t use fcitx for language?
I actually meant the GUI for config called fcitx-configtool. Actually it didn’t occur to me that manjaro might already have a GUI which works with fcitx - that might be the issue :smiley:

That fcitx-configtool is a default GUI for fcitx in Linux Mint which works alright with the panel. I actually didn’t know it was a separate package before Manjaro, since Mint has a GUI for IM setup for all possible languages built in and where it guides you through fcitx install ( akin - push that button to downlaod and install the packages, then log out and log in, set up the configure tool on the panel) :smiley: All the command line part is just hidden away.

Ohhhh that’s what you meant. I forgot that I did use GUI. But for this one it’s fcitx5-configtool. I never had issues with it personally on Manjaro Openbox, KDE, or LXQt.

I really only used it once to select language (English, Vietnamese, Japanese), and never touched it again, since I use a hotkey to change languages.

You can also manually edit the file at ~/.config/fcitx5 instead (a lot more work though imo)


1 Like

Yeah. I tried to combine fcitx packages with fcitx5. That might have been my undoing. I have some small issues with ibus right now, which I didn’t have with fcitx in Linux Mint.

I’d mark it solved if I were the OP. Now when we have “everything” here. I probably will need to test it on my Gnome install I am currently running though, to be sure.

fcitx5 is much easier to set up than ibus. Just tried it out. In addition to what you said in that post, fcitx5-config-tool is also necessary for configuration.

To sum it up - it is actually really easy (with your guide) and fast to set up fcitx and everything is in Manjaro repositories! Config-tool has more options and it is more particular in terms of keyboard shortcuts and usabilty set up.

Good we have instructions for ibus and fcitx5 out, so newcomers could refer this thread.

  • One remark: it is probably a Gnome thing - the integrated Language settings toolbar menu is for ibus. fcitx5 creates a separate keyboard icon on the top bar for choosing input methods manually.

Sorry to excavate this thread but I am currently facing a rather similar issue…
I am using KDE desktop and so far had nothing but trouble with fcitx mozc since it strangely refuses to work anywhere except for firefox… so I can write ひらがな カタカナ 漢字 without any issues here, but once I switch to any other application it just refuses to activate.
I tried switching from fcitx to fcitx5… but that also did not fix the issue. Since I am also living in Japan, being able to input Japanese text is kinda essential…
I think I have tried everything suggested in this and the other thread without any results
(I hope I haven’t overlooked anything?)
Any ideas?
Thank you in advance!

edit: found this japanese person who seemed to have had a very similar issue:

only with Mint and the flatpak version of office.
he resolved the issue using

flatpak --user override --talk-name=org.fcitx.Fcitx --talk-name=org.freedesktop.portal.Fcitx org.libreoffice.LibreOffice

But that’s not going to help me in my case… but it may help you, help me? :slight_smile:

edit2: so I reset my setup back to fcitx from fcitx5 with timeshift… and now it suddenly just works… what? Not sure if this is just a lucky fluke of it’s permanent but… I guess issue solved (for now)


Could have been some package issue. Most probably based on my newbie experience, this “suddenly just works” situation happens, because OS starts reading modified config files or .xprofile after you log in again or do a restart (more fool proof).

I had this “doesn’t work - Oh! It now works” moment, literally, with both when setting up Japanese-Mozc with IBUS and with FCITX5 (coming from Linux Mint wasn’t aware that Fcitx5 exists, the GUI is much easier to understand in FCITX5). My “magic” was based on 2 factors: correct .xprofile contents and reboot after changing .xprofile.

Wrote here “reboot”, but I guess it was enough of log out - log in for fcitx5.

If that issue is based on that (most probably). You won’t encounter it again, unless you decide to start changing up the input method part in .xprofile, which I don’t think anybody would, since it sits unchanged from the day I configured it for myself as described above. :slight_smile:

Edit: under .xprofileI mean a hidden file in your home folder - i.e ~/.xprofile.

I’ve been using fcitx without issue for a while, but ran into the blackscreen after log in bug after I used SUPER+SPACE, which brings up the Gnome language selector, while fcitx didn’t want to activate.

Had to remove fcitx to get my desktop working again. Trying ibus-mozc, since I would prefer a more integrated solution.

1 Like

How did it go @shizus_req ?

In Manjaro 21.1 gnome40 there is a module to install in software GUI (pamac) called Fcitx5-mozc (2.26)

Is it enough to install that & then be able to add Japanese input source in settings>keyboard ?

I have a Japanese laptop, I live in Japan.
In Ubuntu21.4 it was simple to add mozc input, but not looking quite so easy from the above messages, im having difficulty as a beginner to follow whats required.

You should read this:


I personally have these installed:

  • fcitx5
  • fcitx5-qt
  • fcitx5-gtk
  • fcitx5-configtool
  • fcitx5-mozc (Japanese)
  • fcitx5-unikey (Vietnamese)
1 Like

I used Ibus for a while, but had issues with Firejail (which sandboxes applications and filters dbus access). I removed Ibus and switched to fcitx5 with the following packages:

  • manjaro-asian-input-support-fcitx5
  • fcitx5
  • fcitx5-gtk
  • fcitx5-qt
  • fcitx5-mozc
  • fcitx5-configtool
1 Like