Jack2 and pipewire-jack conflict

Hi there,

I want to update my system but I am gettings this error:

conflicting dependencies:
- jack2 and pipewire-jack are in conflict

I have to use pipewire so how can this be resolved?

1 Like

Uninstall jack2 first and then install pipewire-jack instead. This has already been addressed elsewhere on the forum.


So the solution was to reinstall pipewire-jack

sudo pacman -S pipewire-jack
1 Like

I tried that but I’m getting this.

❯ sudo pacman -S pipewire-jack
resolving dependencies...
looking for conflicting packages...
:: pipewire-jack and jack2 are in conflict (jack). Remove jack2? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing jack2 breaks dependency 'jack2=1.9.19' required by lib32-jack2

and if I’m removing jack2 manually, there are 174 packages dependent on it.

Is it fine, if I ignore this package upgrade pipewire-jack??

If you have that many JACK packages that require jack2 you should uninstall pipewire-jack to allow updates for other packages. When the other packages are updated it will be easier to see the dependency packages to be removed if pipewire-jack is installed to replace jack2

:: removing jack2 breaks dependency 'jack2=1.9.19' required by lib32-jack2

I encountered this as well. This is happening because our systems were using pipewire-jack, but not lib32-pipewire, and the lib32-jack dependency was being fulfilled by the package lib32-jack2.

Install lib32-pipewire-jack and lib32-pipewire first, which should prompt to replace lib32-jack2. This should proceed without issue; if it complains that jack2-dbus depends on it, just remove jack2-dbus.

After that, just install pipewire-jack. This will prompt to replace jack2, which should now work.

sudo pacman -R lib32-pipewire lib32-pipewire-jack # replace lib32-jack2
sudo pacman -S pipewire-jack # replace jack2

This should help,

1 Like

See also:

Archlinux committed changes for lib32-pipewire-jack to replace lib32-jack2 21 days ago

but a further commit was needed to remove lib32-jack2 from the list of Provides packages

Update to stable branch 2022-02-05 included lib32-pipewire-jack v1:0.3.45-1 with the changes

My solution:

# Temporarily remove pipewire-jack
sudo pacman -Rs pipewire-jack

# Complete the upgrade
sudo pacman -Syyu

# Now re-install pipewire-jack (also lib32-pipewire-jack to resolve the lub32-jack2 dependencies)
sudo pacman -S pipewire-jack lib32-pipewire-jack
# y to prompts to replace jack2 & lib32-jack2

I removed the lib32-pipewire-jack and pipewire-jack packages, then updated using pamac update, then tried to remove jack2 and jack-dbus using pamac remove jack2-dbus jack2, and received this error

- removing jack2 breaks dependency 'libjack.so=0-64' required by ardour
- removing jack2-dbus breaks dependency 'jack2-dbus' required by cadence
- removing jack2 breaks dependency 'jack' required by ffmpeg

I haven’t had this before, I can remove cadence, but I can’t remove any of the other packages.
Please help

I just used pacman instead of pamac lol

If you’ve got things that rely on lib32-jack2, try this:

First, check all dependncies are satisifed (fix any that aren’t):

sudo pacman -Dk

Allow a seamless swap of lib32-pipewire-jack;

sudo pacman -Syu --assume-installed lib32-pipewire-jack lib32-pipewire-jack

Check (again) all dependencies are installed:

sudo pacman -Dk

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.