Iwlwifi not working in manjaro-kde-221115-linux519

Hello Manjaro Community!

First time Manjaro user here. Great distro!

I am having an issue with my WIFI nic not being detected for some reason.

Here is my hardware profile:
Intel NUC 13 Extreme
The WIFI card is stated to be Intel Wi-Fi 6E AX1690i

This is what lspci -v says:

00:14.3 Network controller: Intel Corporation Alder Lake-S PCH CNVi WiFi (rev 11)
        Subsystem: Rivet Networks Device 1692
        Flags: fast devsel, IRQ 18, IOMMU group 7
        Memory at 685c124000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel modules: iwlwifi

When booting, this is what journalctl -b | grep "kernel: iwlwifi" says:

kernel: iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
kernel: iwlwifi: No config found for PCI dev 7af0/1692, rev=0x430, rfid=0x3010d000
kernel: iwlwifi: probe of 0000:00:14.3 failed with error -22

Running sudo modprobe iwlwifi yields no outputā€¦

From searching this is supposedly the AX411 Linux driver? This should have been merged into 5.14 but it does not work in 5.19 for meā€¦ I tried numerous attempts into copying the entire firmware binaries into /lib/firmware from linux-firmware repoā€“but nothing has worked yetā€¦

Any help would be appreciated. Thanks!

Hello @c0d1n61at3 :wink:

Error 22 reveals:

$ LANG=C errno 22                   
EINVAL 22 Invalid argument

Probably the option ā€œfastbootā€ or ā€œpartial initializationā€ (or however it is called) in your BIOS/UEFI is causing this.

Here is a similar issue:

Greetings @megavolt and happy holidays.

I did make sure that fastboot was disabled in my BIOS. Also, I did happen to try the Manjaro 22 6.0 kernel stable release-review as well but got the same result with my WIFI card not being detected and iwlwifi not loading. Other searches indicated that 5.17 kernel worked for some, but if that was the case, it should work for me with 5.19. It might be a BIOS setting or a combination of settings, but I do not know which one(s). This is not a dual-boot machine eitherā€“strictly Manjaro all the way.

Gonna add more command line candy if it helps anyā€¦
inxi -N yields the following:

Network:
  Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: N/A
  Device-2: Aquantia driver: atlantic
  Device-3: Intel Ethernet I226-V driver: igc

WIFI driver is clearly missingā€¦

I looked for iwlwifi-next but I could not locate the package, e.g. pacman -Ss iwlwifi-next yields nothing. I checked in the AUR, and it still does not build. Last comment was 02/2022 stating it still does not build 2.5 years later after general availability in the AUR.

Very strangeā€¦

Just an update for those experiencing the same or similar issue.

I have tried the following kernels:
linux519 (EOL) do not use
linux515
linux60
and none of them to worked for me.

I also tried to adjust BIOS settings but did not get anywhere with that either. Fastboot is not enabled for me but that did not make a difference unfortunatelyā€¦

Last updateā€¦

No other choice but to code dive the kernel given the error in the boot log.

This eventually led to code in: drivers/net/wireless/intel/iwlwifi/pcie/drv.c.

I added some code lines that matched my WIFI card, e.g. AX1690i:

IWL_DEV_INFO(0x7AF0, 0x1691, iwlax411_2ax_cfg_so_gf4_a0, iwl_ax411_killer_1690s_name),
IWL_DEV_INFO(0x7AF0, 0x1692, iwlax411_2ax_cfg_so_gf4_a0, iwl_ax411_killer_1690i_name),

this should be line 673. I added AX1690s just for gigglesā€¦

I am using linux60 to build a custom kernel and modules.

From the boot logs my WIFI card dev and subdev are 0x7AF0 and 0x1692 and that seems to be the main issue.

Installed custom kernelā€“and all works fine now. I am guessing this hardware is too new? Some Intel driver maintainer needs to make sure this makes it into upstreamā€¦

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.