It is possible to use 2560x1080 resolution on Linux using ATI Radeon?

Hi guys, I’m new to Linux.
I’m really enjoying Manjaro XFCE, life has changed completely.

Question

What should I do to make the 2560x1080 resolution option appear on display settings in Manjaro XFCE Minimal?

In addition to the updates on Pamac after installing Manjaro do I need to do anything else? Do I need to install anything that doesn’t come with Manjaro? If so, how do I do this?

Setup

  • LG Ultrawide 25 monitor (I use only the monitor screen)
  • ASUS N53ta Laptop - ATI Radeon® HD 6720G2 Graphics with 2GB DDR3 VRAM

Approaches I’ve tried and failed

  • Setting a new mode via xrandr
  • I tried to look for a driver on the AMD website but found nothing that appears to be compatible.
  • I tried to change the Kernel version to 4.19 and boot but it didn’t change anything.

Context

I used to plug the monitor into the laptop (hdmi) and in Windows 10 it automatically displayed the desired resolution 2560x1080 (21: 9)

After installing the Manjaro XFCE Minimal when I plug in the monitor, the highest resolution that appears to me is 1920x1080

System information

System:
  Kernel: 4.19.141-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 
  root=UUID=0656753a-2c28-42e2-bcd0-0353336aa290 rw quiet udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: N53Ta v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: N53Ta v: 1.0 serial: <filter> UEFI: American Megatrends 
  v: N53Ta.209 date: 12/10/2011 
Battery:
  ID-1: BAT0 charge: 26.8 Wh condition: 40.8/48.4 Wh (84%) volts: 11.0/11.1 
  model: ASUSTek M50--24 type: Li-ion serial: N/A status: Discharging 
CPU:
  Topology: Quad Core model: AMD A6-3420M APU with Radeon HD Graphics bits: 64 
  type: MCP arch: Fusion family: 12 (18) model-id: 1 stepping: N/A 
  microcode: 3000027 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 11979 
  Speed: 799 MHz min/max: 800/1500 MHz boost: enabled Core speeds (MHz): 
  1: 802 2: 803 3: 804 4: 804 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Sumo [Radeon HD 6520G] vendor: ASUSTeK driver: radeon 
  v: kernel bus ID: 00:01.0 chip ID: 1002:9647 
  Device-2: AMD Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] 
  vendor: ASUSTeK driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6741 
  Device-3: Alcor Micro ASUS USB2.0 WebCam type: USB driver: uvcvideo 
  bus ID: 4-2:2 chip ID: 058f:a004 
  Display: x11 server: X.Org 1.20.8 driver: ati,radeon unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") 
  s-diag: 583mm (23") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 72 size: 673x284mm (26.5x11.2") 
  diag: 730mm (28.8") 
  OpenGL: renderer: AMD SUMO (DRM 2.50.0 / 4.19.141-2-MANJARO LLVM 10.0.1) 
  v: 3.3 Mesa 20.1.6 compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: AMD BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G series] driver: snd_hda_intel v: kernel bus ID: 00:01.1 chip ID: 1002:1714 
  Device-2: AMD FCH Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1022:780d 
  Sound Server: ALSA v: k4.19.141-2-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: AzureWave 
  driver: ath9k v: kernel port: e000 bus ID: 02:00.0 chip ID: 168c:0032 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: ASUSTeK 
  driver: atl1c v: 1.0.1.1-NAPI port: d000 bus ID: 03:00.0 chip ID: 1969:1083 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 6.38 GiB (1.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST9500325AS size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
Partition:
  ID-1: / raw size: 465.46 GiB size: 457.16 GiB (98.22%) used: 6.38 GiB (1.4%) 
  fs: ext4 dev: /dev/sda2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 41.6 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: radeon temp: 36 C device: radeon temp: 41 C 
Info:
  Processes: 163 Uptime: 2h 07m Memory: 3.34 GiB used: 888.9 MiB (26.0%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 905 lib: 274 
  Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05

What do you need? Whats missing?

Dont do that. Besides this being a generally bad idea for handling any software in linux (we use repositories and packages and such … and they usually are tied to things like system libraries)… manjaro also has MSM/mhwd to handle these things. Dont deviate from that unless you have a good reason and know what you are doing.

Please see this:

Thanks for your answer!

I want to use 2560 x 1080 resolution on my monitor, but it does not appear in the display configuration menu. I’ve tried the approaches mentioned above but nothing has worked.

Sorry. I edited the first post.

Hm.
I notice the 2 video cards… which is interesting … but I’m not entirely sure its down to your gpu(s) and/or drivers.

When you said

I guess that means you’ve done this:
https://wiki.archlinux.org/index.php/Xrandr#Adding_undetected_resolutions
?

Thanks for answering.

Yes. That’s exactly what I tried to do.
But when I apply the new mode, the monitor screen goes black.

I don’t know if it is related, but one of the LEDs on my notebook’s panel is continuos in blue color, which means it is only using the integrated GPU. And not the dedicated one.

Wouldn’t using the dedicated card have anything to do with this issue?

I installed Manjaro XFCE and updated everything on Pamac.

In hardware configurations, “video-linux” is installed and active, despite showing “video-modesetting” and “video-vesa” (not installed)

Should I install any more drivers? Where can I get it? How to install?

Hello guys

I still haven’t been able to make the 2560 x 1080 resolution work on Manjaro XFCE.

As I said above all the drivers seem to be installed and updated.

I’ve tried to add and apply via xrandr but it doesn’t work. When I apply the new mode, the LG 25 monitor screen loses its signal.

Could you help me try to resolve this issue? Or indicate an article about it?

Maybe take a look through this thread…

The answer there was basically some sort of bad configuration/driver … after a reinstall and such it worked.

Note - Towards the end is a script, but it was made for KDE (using kscreen-doctor).

Same issue here. Just got a LG 29 … after trying the xrandr method, screen goes black. I can discard the HDMI cable or graphics card because booting with Win10 the screen works perfectly. I believe the issue is more related to the linux driver.

Hello @ashtrax3000 and @u3681 :wave:

It is a bit confusing. So you have 2 AMD GPUs. One is the APU and one is dedicated.

I assume this is the APU:

and this is the dGPU:

Which GPU is responsible for the HDMI-Output?

Please could you post this output:

xrandr && xrandr --listproviders && xrandr --listmonitors

How did you add the resolution exactly? I would run:

$ cvt -r -v 2560 1080
Warning: Aspect Ratio is not CVT standard.
# 2560x1080 59.98 Hz (CVT) hsync: 66.64 kHz; pclk: 181.25 MHz
Modeline "2560x1080R"  181.25  2560 2608 2640 2720  1080 1083 1093 1111 +hsync -vsync

The Ratio is not a standard one, but some displays can work with that. Then

xrandr --newmode "2560x1080R"  181.25  2560 2608 2640 2720  1080 1083 1093 1111 +hsync -vsync

and

xrandr --addmode HDMI-0 2560x1080R

Then you could use the new resolution.

Hi @megavolt. Thanks for replying and taking your time to help us.

In my case, I only have one AMD GPU (AMD Radeon HD 6450) and an LG UltraWide 29’’ [29WK50S-P]

The output for

xrandr --listproviders && xrandr --listmonitors

is as follows:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 798mm x 334mm
1920x1080 60.00* 50.00 59.94
1680x1050 59.88
1600x900 60.00
1280x1024 75.02 60.02
1280x800 59.91
1152x864 75.00
1280x720 60.00 50.00 59.94
1024x768 75.03 60.00
832x624 74.55
800x600 75.00 60.32
720x576 50.00
720x480 60.00 59.94
640x480 75.00 60.00 59.94
2560x1080R 59.98
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
Providers: number : 1
Provider 0: id: 0x56 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 3 associated providers: 0 name:CAICOS @ pci:0000:01:00.0
Monitors: 1
0: +*HDMI-0 1920/798x1080/334+0+0 HDMI-0

I tried

$ cvt 2560 1080
$ xrandr --newmode “2560x1080_60.00” … more values
$ xrandr --addmode HDMI-0 2560x1080_60.00

After this step the screen blinks once and the resolution option for 2560 x 1080 (21:9) appears in the Display Settings. I select this new option and after applying it the screen goes black. Same result as using xrandr --output HDMI-0 --mode 2560x1080_60.00 and/or after trying your suggested solution

cvt -r -v 2560 1080

As stated before, the monitor’s native resolution 2560x1080 is shown and works flawless in Win10, but when it boots in Manjaro or Ubuntu it only shows 1920x1080 as the max resolution.

One easy solution I could think of is to get a new graphic card that supports 21:9 with Manjaro and get over with it but I won’t do that. No pain, no gain.

@ashtrax3000 I guess there are problems with these non-standard screens and you are not the only one. But in general it should work. Mostly you have to set lower refresh rate than 60. According to this post:


It works with 44-45hz. Keep sure you have really a HDMI cable of version 1.4a (or higher) or use a display port (recommend for ultra widescreens on linux). And it takes time for syncing depending on your gpu.

Btw linux in common is very strict to open standards and follow them, but some products follow them a bit more lazy. And provide individual specifications only to Microsoft Windows.

Here is a tutorial that should work also on Manjaro: Ultrawide monitor on Linux

@megavolt Thanks. I also took a look at that article. I tried values in the of range of 40-45hz and it only worked with 42-44hz. However, there is a consistent lag so I can assume that the linux driver (mesa) for this specific graphics card doesn’t support 2560x1080 at 60 hz.

Once again, thanks a lot !! Time to move on.

P.S. Any suggestion for a different graphics card that has confirmed support for 2560x1080 at 60 hz in Linux ? Nothing fancy, I’m not into gaming.

UPDATE:

Finally, I was able to get it to work. The answer was in this post:

askubuntu_com/questions/836448/2560x1440-resolution-on-16-04-and-ati-amd-radeon-hd4670-card/892091#892091

Bsically, the trick is to set the modeline using umc and not cvt nor gtf

in my case:

umc 2560 1080 54 --rbt
2560x1080x53.92 @ 59.743kHz
Modeline “2560x1080x53.92” 162.500000 2560 2608 2640 2720 1080 1083 1087 1108 +HSync -VSync

why 54 ?

According to this article: hwiki_archlinux_org/index.php/ATI#QHD_.2F_UHD_.2F_4k_support_over_HDMI_for_older_Radeon_cards

Older cards have their pixel clock limited to 165MHz for HDMI.

So the first number after Modeline “2560x1080x53.92” can’t be over 165 otherwise you get a black screen. An alternative, as described in the article, is to re compile the kernel and modify the radeon.hdmimhz parameter as posted in this other elstel_org/software/hunt-for-4K-UHD-2160p.html.en

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.