Issues with PipeWire and Bluetooth

For the past day or so since the last system update, I’ve experienced some very annoying issues in regards to PipeWire and my bluetooth headset.
When I play audio from one source and then start playing another one, the second one only comes out of one audio channel (either the left or the right). And sometimes when I connect the headphones, they just play out of one channel. And sometimes when I start playing a second audio source, all the audio mutes until I close the second audio source. And sometimes, I have to go into pavucontrol and set them as the default audio output manually. I’ve been fiddling with this for hours trying to find a working solution. But seeing as this happened after the system update, I am almost 100% sure this is a bug.
I even tried reverting back to PulseAudio, but I’m not going down that dependency hell.
Anyway. As you can tell, the things that happen are very inconsistent and at random. There’s no telling what will happen next.
And in case you wonder, I’ve already tried reinstalling all the bluetooth related packages as well as PipeWire, just in case it was something caused by me. Hence why I’m almost certain this cannot by anything other than a bug.
I’ve seen other recent posts on here related to PipeWire and bluetooth. So this might be related.
I hope that somebody out there will be able to help me solve this. And hopefully this bug can be resolved soon. Thanks in advance.

I have no solution for this, but for me, when using Bluetooth devices, whenever I start playing a sound, the first few seconds are broken/scrambled/muted, then the rest is fine. So every music or video file shows this issue.
Since this is a minor annoyance, I just ignore it, but it would be fine if Bluetooth was more reliable on Linux.

On one hand, you can choose better codecs for Bluetooth (in Plasma), for better sound quality (not possible to set on Windows, at least not by default), on other hand, I still have impression that Bluetooth sound is just way better on Windows. Just compare the sound connecting a cable and then Bluetooth. A HUGE IMPROVEMENT! On Windows, you also can hear the difference, but is not so drastic one.

Maybe there are some Bluetooth settings that can be changed to improve that? I don’t know.

I have almost same problem with, in my case, audio interface after the update. I downgraded pipewire, pipewire-jack, pipewire-alsa, pipewire-pulse and libpipewire with AUR downgrade, but the problem has still persisted.

Latest stable branch updates included pipewire v1:0.3.73 but there is another bugfix release in the pipeline

metapackage manjaro-pulse does not work for reverting to PulseAudio and requests to consider fixing issue has been rejected

But these commands can revert to PulseAudio without dependency issues

pamac remove manjaro-pipewire; pamac install pulseaudio

and select pulseaudio-bluetooth from list of optional dependencies

Thank you @nikgnomic
Removing manjaro-pipewire may have solved the problem. It then proceeded to upgrade a whole bunch of PipeWire related packages. And I believe the issue has been fixed.
So I’m gonna see if it works today. And if I run into similar issues, I’ll revert back to Pulse.

@michaldybczak Thanks, but I’ve already tried changing the codecs.
It did nothing. But I believe the latest Pipewire upgrade might have solved the issues.