Issues with multi monitor support on Plasma

This update is a total disaster! It broke multimonitor support on KDE. I tested on few monitors at work and none of them is working, although those are different models from different companies. Besides, it looks like a software problem.

When plugging a monitor system detects it initially, but instead using a known configuration, it asks about what to do as if it was a first plug in. After choosing the option (extend left/right/duplicate) there is no second monitor. As if it was enough to trigger the ask, but not enough to show the second monitor in settings. There is no picture output obviously.

It doesn’t matter if I use X11 or Wayland.

EDIT: I noticed, there is no optimus-manger icon, so I’m compiling it again. This may be a driver setup issue.
EDIT 2: Removing optimus-manager didn’t help. Still, this is something wrong with drivers obviously, because it doesn’t work in any driver configuration.
EDIT 3: Switching to various kernels doesn’t help. Need to roll back the update after I get home. I see no quick fix for this.
EDIT 4: I updated from testing branch. Maybe there is some bug on that brunch. Trying to update unstable in hope it will fix the issue… which is always a game of chances… :wink:
EDIT 5: Update to latest unstable didn’t help. It even doesn’t ask when plugging another monitor. Err, scratch that! After few reboots, monitors start working, at least on X11…On Wayland it doesn’t work, so this is a regression.

I also noticed other regressions in Plasma.

This is for me the worst update for 2 years. Many regressions in Wayland and Plasma. I rolled back my backup, and I’m switching to stable.

Your wild flailing about doesn’t help anyone help you. I moved your posts from Unstable Updates, then you mention a non-existent Testing Updates on 25 Nov, now you’re…

I guess we’re done here then? I’m rather confused…

Such as?

I was on testing and yet there was no proper annoucment topic for this testing update. I noticed, that the updates were mentioned on unstable topic, so I posted there. I just assumed it covered both updates for some reason.

Those issues are important to be solved quickly, and no one was commenting or offering any support. I just couldn’t wait. I were posting what was I doing, but also was open to suggestions, which never came.

When I got back home from work, I couldn’t wait any longer and just rolled back. If others have the same problem and some solution shows up, I may switch back to testing and do the update again. Till then, I had to move to stable, given the fact that I use laptop at work every day.

I know that running testing branch is not the best idea for work, but I’m doing it for many years now and breaking updates show up very rare, once a year or rarer. Even when it comes like now, I’m ready to roll back, so I’m covered.

So no, we are not done, or at least, I hope that there will be some positive development. I cannot avoid the update infinitely. Maybe it’s just Nvidia messing up Wayland protocols on Plasma and in next weeks it will be fixed? I don’t know, but I don’t have enough time to troubleshoot it.

Lack of startup sound. It gets broken every few Plasma release regularly :frowning:
For many this may be a minor issue, for me, it is important, because my laptop has a dedicated sound card and there are no proper Linux drivers for it. Intel drivers, that are in use, are doing a poor job, and sometimes after the boot, there is no sound. The ONLY solution I found was to do a hard reset (or boot into Windows), because the issue persists the usual reboots. Startup sound, as nice as it is, notifies me right from the bat that the sound is working OK.
I am tired of it being gone on average every third Plasma release :frowning: . This is the first time that such regression showed up, not on a first release, but on the final version of Plasma that should in theory be well worked on. This cannot be explained with Nvidia, so… it may mean I must wait for the Plasma 6 release, which isn’t a good idea for a work laptop. I probably will update, see if it works well enough, and if not, roll back to wait for 6.0.1 or later release on stable branch, which I assume will get only the later version, not the initial one.

What testing update? The last one was 22 November. There has not been any kind of update snap since then. Occasionally security updates or binary packages are pushed in between, however there really hasn’t been much of anything in the last few days.

Which updates?

I noticed updates this Saturday 25.11.2023 and this was exactly what described in unstable topic.

I was sure I was on testing branch, but there is a possibility I forgot to switch from unstable. I would swear that the update showed up this Saturday and the previous update was two weeks before. I just noticed that testing updates usually happen around the weekend, once a week or once two weeks. Unstable updates show up in small portions every few days, or at least that was the schedule in the past.
So either you started scheduling unstable updates like testing ones from the past and I really forgot to switch back to testing, or I have some hallucinations…

Let me check history logs: Before the update from this Saturday, the previous update was installed on my system on 14.11.2023, which probably showed a few days before (on a weekend 11-12.11.2023).

Again, such a schedule looks like a typical testing branch to me, and I wasn’t switching branches recently. Like I said, I just noticed updates this weekend.

I checked the announcement for 22.11.2023 update and there weren’t Plasma updates. Hmm… Maybe I was on unstable, but those are scheduled so rare nowadays? Like I said in the first post, when trying to solve the issue, I switched to unstable and got immediately some small update. So either this is a coincidence, and it showed up minutes before, and I just refreshed unstable setting, or I was on testing. Puzzling.

Anyway, that is off-topic anyway. The update had nvidia and Plasma updates, along with Firefox and so on. It broke permanently optimus-manager, which strongly suggests issues with Nividia. I would have blamed optimus-manager for being abandoned, but getting rid of it and cleaning the X11 setting didn’t change anything, and optimus-manager didn’t affect Wayland anyway.

Look, aside using multimonitors for work, I also had a meeting today, where I had to plug in to the projector. Luckily, I was able to restore the X11 support till then. Because multimonitor support never broke for me for years, this was unexpected. I should have known better and not to update on Sunday evening… :wink: .

@Yochanan and @ydar, I found out the reson of my multimonitor issue and that is because of my setup.

In short, the update disabled optimus-manager completely and without it, I had no proper graphic configs, hence the issue with multimonitors. So this was not a Plasma problem and not Nvidia driver problems, because I’m currently running 545.29 and it all works, as long as optimus-manager works.

Basically to solve this, I need to remove optimus-manager and restore the hybrid graphic configs, which isn’t that obvious, as it turns out.

I will create a new support topic for this, because I need some help with this, but this issue here is solved.

This is for other random people finding this thread as much as yourself…

optimus-manager is hacky. It requires extra unsupported options be set, such as to SDDM, or to replace GDM entirely with another version, it also automatically deletes mhwd files … and so on.

And thats not even getting to its actual performance.

If you really need (most dont - judging by posts here a not insignificant number of users erroneously believe one of these utilities is required for hybrid graphics to work) a switcher program similar to it I might suggest these as better options:

I remind, that 4 years ago, there were no such options, aside optimus-manager. Nowadays, hybrid setup is enough for modern dGPUs. For older ones, like mine, intel session uses far less energy than hybrid one, so this was still a valid option. In fact, this works still fine as long as optimus-manager works. However, it looks like its life is coming to an end. Besides, most people are no longer aware or using optimus-manager, because older GPUs become less and less abundant and newer options are more convenient, while hybrid session works fine for most people.

Mine case is a very rare one, because my OS install is over 8 years old. I lived through bumblebee to optimus-manager, and now I am planning to move away from it to hybrid setup (which is still suboptimal energy wise, but capable of doing anything).

Warning against optimus-manager is at this point like beating of a dead horse…

There were … optimus-switch … I dont remember all the intricacies … but I dont think optimus-manager has regressed.

It kinda doesnt matter whatever your reasons were in the past … if there are better options now … right ?


And certainly its worth noting all the extra steps it takes silently to pollute your system … because it could be a source of errors … or something to keep in mind if you are trying to switch.
(a good resource might be looking at all the extra ‘steps’ listed at its github page)

Yeah, there was optimus switch, but it was inconvenient compared to optimus-manager IMO. Both solutions were not ideal and hacky, but still way better than old bumblebee, which was even more hacky.

I was happy with optimus-manager, because it worked perfectly. Once installed, it served me 4 years without fail. However, all good things come to an end :wink: .

Anyway, if one would set optimus-manager now and remove it, there would be no problem, as long all actions would be reversed. In my case, it just took too much time, too many things has changed, and config backups were mysteriously misplaced. This makes the transition harder but not impossible.

If there will be no support, my plan is to remove optimus-manager, remove my current graphics setup and auto install proprietary nvidia hybrid setup again. This should restore configs. If not, I can still restore backup and figure out a new plan.

This might be roughly workable (maybe use --force).
I think this should take care of mhwd files optimus-manager deleted.

The other bits probably need manual intervention though;

But going through to copy some of these I did find this, which may be useful before the uninstall:

But I dont know how much it cleans up or how well :wink:

I believe that optimus-manager --cleanup simply removes /etc/X11/xorg.conf.d/10-optimus-manager.conf, which is removed anyway, by removing optimus-manager. I did that, but it’s not enough, as initial optimus-manager setup required manual intervention.

I use Plasma, so don’t have gdm, but sddm. It changed in all those years and I use the default config, as the parts that were troublesome to optimus-manager doesn’t exist anymore. So your info is obsolete.

Yes, this file is gone after removing optimus-manager.

I do have /etc/X11/xorg.conf backup, but after the years of driver changes, I’m not sure if it’s correct at this moment. I tried restoring it and the graphical system didn’t start. It also has references to modesetting, which I believe to be obsolete. It may have worked in the past and with optimus-manager, but may cause issues now.

I hope that re-installing hybrid setup through MHWD, it re-creates this config. I will use --force option as suggested.

I don’t have it and as above, I hope that MHWD will be able to restore it.

Additionally, /etc/X11/mhwd.d/ is completely empty. In the past, there was some config there, but I’m not sure if it’s valid now. MHWD changed few times in 4 years.

@michaldybczak try this if you don’t need dGPU: Hybrid graphics - ArchWiki.
I use udev rules way, works great.

1 Like

How does it work? I mean, for most things intel is fine, but I do like to launch some game sporadically. Is prime-run working when udev rules are used or are those (and other methods) simply disabling dGPU permanently (so prime-run won’t work) within hybrid mode?

@cscs, I did try to switch to default hybrid setup. This is what I did:

  1. optimus-manager --cleanup
  2. sudo systemctl disable optimus-manager.service
  3. removed optimus-manager
  4. sudo mhwd -r pci video-hybrid-intel-nvidia-prime
  5. sudo mhwd -a pci nonfree 0300 --force
  6. reboot

System boots normally, but on Wayland I still don’t get multimonitor, so the same as before. I checked the files and I got:


Which is basically empty:

## Generated by mhwd - Manjaro Hardware Detection

and I also got the symlink:

which points to the previous file

I didn’t have the last time, but the result was the same.

So I started experimenting. I restored my backup:


rebooted and everything seems to be OK, for now.

So I restored:


rebooted and… graphical system didn’t start, just as I tried before.

I went to tty2, logged in to my user and tried to “sudo su” and it couldn’t accept my root password. What? The last time I tried it (few days ago), this was all OK. Besides, I just changed the file names with root password, rebooted and now all of a sudden root password stopped working? What the heck?

So I rebooted, went to tty2 and… couldn’t even log in to my user as it also didn’t accept the password… No, it wasn’t CAPS LOCK or NUM PAD.

I booted Manjaro life, chrooted, but there was some issue (I used older Manjaro version, so maybe that was it), but could disable 20-intel.conf on the system (the last change that broke graphics) from rooted Manjaro live…

I’m back on the native system and don’t know what to do.

Ah, by the way, the conf files that seemingly disappeared, they are there after all. They were just hidden ;). I forgot to check. I have no idea why some .bak files become hidden in one places and not others, while the file is without dot at the beginning. Still, it seems like coming back from optimus-manager is not so easy, because old configs are not working well and I probably miss something.

The issue with not being able to access admin or my user is a scary thing - I can’t revert changes, I can’t restore backup and only live system can help. However, that’s another issue.

Basically, I can’t access nvidia (prime-run is not working) and Wayland has no multimonitor support, which is evidently tied to the faulty hybrid setup. Because all was working on optimus-manager, I assume, the issue is with graphical configs.

I will check arch wiki, but if you have some suggestions, let me know. I can restore my backup, but that brings me nowhere, so I’m still experimenting.

EDIT: I figured out, that if the optimus-manager config was working for me, I just compare it to the old /etc/X11/nvidia-xorg.conf. There were many, many changes, so I just changed it to what optimus-manager had. Rebooted into X11 and prime-run seems to be working, multimonitor as well.
Wayland is still not having multimonitor or prime-run. However, becasuse all those configs are in /etc/X11, there have to be for X11 only and Wayland needs configs in different place. Right? Optimus-manager was probably symlinking it to that place and that is why Wayland worked correctly and that is what I am missing now.

EDIT 2: I found out, that Wayland is not working via configs as X11, but directly using kernel mode settings, which is way harder to understand.
Also, I know why setting 20-intel.config was problematic. It simply pointed to intel driver, which I don’t have since 3 years, I use modesetting, which is default for hybrid graphics. So basically, in hybrid intel is running everything and this config was forcing none existent driver for intel, hence graphics was a no-show.

Yeah I dont know where this is from… old in whatever case it appears.

At this point, the only issue is the lack of multimonitor support on Wayland. It basically either doesn’t detect it (nothing happens), or detects it partially by showing the screen configuration pop-up, but after this is set, secondary monitor is not showing. If everything was correct, the system wouldn’t even ask anything and just used the last used configuration.

Anyway, prime-run is working, and I found out that I don’t need any graphic configs in:

Without them, default options are used. I can add specific configs, but those don’t change much, maybe aside of introducing another issues (multimonitor on X11 stopped working if intel config was there).

From what I can tell, MHWD is doing all the work:

/etc/modprobe.d/mhwd-nouveau.conff - blacklists noveau (no problem, I don’t use it)
/etc/udev/rules.d/90-mhwd-prime-powermanagement.rules - I don’t touch that
/etc/X11/xorg.conf.d/90-mhwd.conf - symlink, points to /etc/X11/mhwd.d/nvidia.conf , but that is empty, so all defaults
/etc/modprobe.d/mhwd-gpu.conf - this is tricky, it has inside:

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm
options nvidia "NVreg_DynamicPowerManagement=0x02"

It blacklists noveau again, but also some drm. I don’t understand, if drm and nvidia-drm are different modules?

/etc/modules-load.d/mhwd-gpu.conf - this ensures that nvidia-drm is loaded, I think, because inside I see:


Wayland uses kernel modules, not configs (at least not entirely), so nvidia-drm is essential and it seems to work. When I run Wayland, prime-run works. That means, the detection of secondary monitor also should work, but it doesn’t. No idea why and where to look for debug info.

Optimus-manager was only providing a dynamically changed config in /etc/X11/xorg.conf.d/ depending on chosen mode (interl, hybrid, nvidia) on session reload (used daemon for this). I can use the same config that optimus-manager used for hybrid session and all is OK, aside this multimonitor issue on Wayland. To avoid conflicts, other graphical configs were disabled manually. Pretty simple.

This is the one thing that eludes me. What is different? Why this one config for hybrid in optimus-manager worked and I could use secondary monitor on Wayland, and why the same config (or lack of it - basic defaults provided by MHWD are in place) is not working anymore for this one thing? Logic would suggest that the only thing here is MHWD, but its default options are sparse.

I’m thinking about experimenting with disabling this drm blacklist in MHWD. Or maybe diabling noveau blacklist, because in optimus-manager, noveau was possible to use in hybrid. Maybe noveau was providing somehow the multimonitor support?

EDIT: Disabling noveau blacklists or dmr blacklists did nothing. Those configs were unchanged during optimus-manager, so this isn’t it either. Modules load was the same, unless optimus-manager was loading something extra, but there was no additional config in /etc/modules-load.d/ .

At this moment it’s all guessing and fishing. I need to learn a bit more or get some specific debug info to figure it out.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.