Issues saving Nvidia settings

Ohh thats right, I really didnt consider the idea that anyone would write the entire config file so I forgot to add that I also needed to turn off “Sync to VBlan” and “Allow Flipping”. Anyway im rebooting

Okay so i rebooted, the Display configuration has reset, OpenGL Image and the PowerMizer pref mode remain automatic as before, althought theres a new menu available on the latter.

How did i missed that? :slight_smile: Please change it to:

nvidia-settings --load-config-only
exec $(get_session)

No need for the exec part. Reboot and test again.

1 Like

Hahah, my b.
I fixed it and rebooted, its still the same automatic config

I guess i wouldnt mind disabling iGPU.

Apparently you are not the only one with this issue

Later i will do a test on my other install.



1 Like

Im not planning on using 2 screens in the future, but what do you mean with

The passthrough is if you will use one GPU for virtualbox or qemu

Like plugging a 2nd GPU to power the VM?

Exactly! It will use it as if was native.

By the way, have you tried to create profiles for the Nvidia GPU with the gwe from repository? GreenWithEnvy

Damn i think i misread, i only have 1 (nvidia) GPU. I should uninstall 450xx,

and reinstall nvidia 450xx. Is there any guide you’d recommend?

Yes, you do have just one dGPU = Nvidia (dedicated GPU)
That GPU is supported by the 450xx drivers you have already installed.

The iGPU is the AMD one (integrated GPU). If your system works, then you can let it enabled. Do a test with it disabled. In that case the only driver you have to remove is the video-linux.

If you insist on reinstalling the video-nvidia-450xx driver, then the /etc/X11/mhwd.d/nvidia.conf file will be rewritten to default.

As i mentioned here

regarding the nvidia-settings --load-config-only failing to load at startup. So it might be an issue that needs addressed elsewhere.

For what exactly? We just went trough the install and custom config part :slight_smile:

1 Like

Oh i thought me dont being able to save the configs was primarily related to having selected non-free drivers and that that was reflected on having a non nvidia driver

For disabling the igpu -that i now get what it is-. I understood you suggested it may solve the issue

Im going to try this first

From BIOS Settings, but in reverse from what is in this video.

1 Like

Ive just replaced video-nvidia-450xx with video-hybrid-amd-nvidia-450xx-prime, since i forgot it was the default from the Auto-Installer. No noticeable changes even after repasting your nvidia.conf. Would you advice downgrading the 450xx with any other .ver in particular? Im open to follow any suggestions

ps. I succeeded in applying the GWE recommended custom fan profile, althought im at a loss when trying to set the min and max clock speed.

ps2. Im not sure if its worth mentioning, when i sudo nvidia-settings, I get

(nvidia-settings:1841): GLib-GObject-CRITICAL **: 09:12:45.721: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

If you open Nvidia X Server Settings, do you have options in it?

Why are you using sudo ?
If you do that and save the .nvidia-settings-rc has no longer your permissions and ownership. Because of that it will fail to load. There, now you know why is not working

Since you went the road on installing video-hybrid-amd-nvidia-450xx-prime when i don’t think has any positive effect installed on a Desktop PC where the dGPU is totally independent from the iGPU, then try them all :slight_smile:

Yes “Sync to this display device” -Auto -VGA-0

Ouch, because at the start of this journey if i didnt use sudo it wouldnt let me save the display config and from then on i continued using it

Okay so, i could save the .nvidia-settings-rc in my /home, but the issue persists …