Nvidia Settings ignored

I’m running into an issue here where Nvidia Settings isn’t reading my config files. First main issue is that in my xorg.conf file in /etc/X11/mhwd.d/nvidia.conf file I specifically set;

Option    "Coolbits" "24"

in the config file, but it’s not reading the conf file and an application that I use to apply overclocking profiles and fan control profiles is unable to change the fan settings. It set the to allow me to use overclocking profile, but not fan control, which is should be, given the Coolbits option that I set, because you can enable multiple features.

ArchWiki - NVIDIA/Tips and tricks - Enabling Overclocking

This setting use to work properly before with the Coolbits value set to 24, I was able to adjust both clock speed, voltage and fan speeds.

I use GWE (GreenWithEnvy) for overclocking and fan control

Says here I need Coolbits 4 to be set, but I’ve already provided that in my xorg.conf but it’s being ignored. Value 24 should enable both the overclocking as well as fan control.

Further shown in the Nvidia Settings panel that it didn’t even read the Coolbits option that I set which should be read from the xorg.conf when its been set in the file.

Second to this issue is that Nvidia Settings seems to ignore any options I’ve saved for PowerMizer and OpenGL settings despite having a .nvidia-settings-rc file in my /home/user directory, it completely ignores the PowerMizer preferences for Preferred Mode by setting it to Auto instead of Prefer Maximum Performance mode. In the OpenGL settings I specifically set Sync to VBlank to Off and Image Settings to High Performance but keeps being force defaulted to Quality setting.

lastly here’s my config file from /etc/X11/mhwd.d/nvidia.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 450.66

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AOC AG322FWG4"
    HorizSync       160.0 - 160.0
    VertRefresh     48.0 - 144.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1070"
    Option         "NoLogo" "1"
    Option         "Coolbits" "24"

Section "Screen"

# Removed Option "metamodes" "1920x1080_144 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-5"
    Option         "metamodes" "1920x1080_144 +0+0 {AllowGSYNCCompatible=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    Option         "RegistryDwords" "PerflevelSrc=0x2222"
    Option         "ConnectedMonitor" "DFP-5"
    Option         "CustomEDID" "DFP-5:/etc/X11/dp2.bin"
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

I’ve tried setting Coolbits option under both Device and Screen sections but neither worked.

Seems to be the same issue as here:

So make sure you did not saved .nvidia-settings-rc after you opened Nvidia X Settings using sudo.
Other wise, in the same topic i mentioned this:

1 Like

If the above doesn’t work, can you remove comment xinerama?

That was already there in the file, and thats just for the ordering of the screen layouts.

it’s never done with sudo.