Issues playing games on Steam through Proton-GE

After this update I’m experiencing issues playing games on Steam through Proton-GE. Running Deep Rock Galactic I get the message

A D3D11-compatible GPU (Feature Level 11.0, Shader Model 5.0) is required to run the engine.

Other games show similar messages.

$ inxi --gpu
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Dell
    driver: nvidia v: 470.141.03 alternate: nouveau,nvidia_drm
    non-free: 515.xx+ status: current (as of 2022-08) arch: Ampere
    code: GAxxx process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:25a0 class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:2 chip-ID: 0c45:6a15 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3456x2160 s-dpi: 144 s-size: 609x381mm (23.98x15.00")
    s-diag: 718mm (28.28")
  Monitor-1: eDP-1 model: Samsung 0x414d built: 2020 res: 3456x2160 hz: 60
    dpi: 261 gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6")
    ratio: 16:10 modes: 3456x2160
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes

+1 I have this issue.

That’s great. However, your post neither helps the original person nor yourself solve the issue. If you need further assistance, please create your own topic.

As always, startup options:

VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json %command%

Problem is that steam doesn’t find the location of the vulkan json file. I have this problem for a while now. I just add this and I am good to go. You should also add prime-run (since hybrid gpu) and gamemoderun (be sure that the gamemode service is running).

1 Like

This can all be resolved by installing frogging family’s


(Granted you have an NVIDIA card. I personally recommend the 5.15 drivers, always dkms. Also I would use their tkg-pds kernel. Oh and disable Optimus completely.

1 Like

How, pray tell? I can run any of my Steam games with Proton with no issues.

:warning: Not supported (or will even work) on Manjaro as they’re designed to work on Arch.

To me it looks like it’s running on the Intel Graphics and not the Nvidia Driver, have you tried prime-run command?