Issues getting Brother MFC-J497DW to print

Hello. As the title says I’m trying to install my Brother MFC-J497DW over the network, but for some reason I can’t get it to respond at all.

I’ve installed the drivers using pamac build brother-mfc-j497dw, I installed the SANE drivers using pamac build brscan4, and configured the drivers using sudo brsaneconfig4 -a name=Brother model=mfcj497dw ip=, and set the printer up in CUPS using ipp, with my address as ipp://, as the archlinux support page suggests. I also tried simply ipp://, as well as just using the default setup that cups automatically detects, but those don’t work either. Of course, I have made sure the cups service is running and that internal ip address is correct for the printer, and I can ping the printer from my computer and it responds fine. Also the printer itself does work fine, I can print to it from other OS with no issues.

When I start a job on the printer, I get a message saying the job was sent, and the job is listed as completed in CUPS, but the printer does not respond at all.

From browsing its manual, that model doesn’t seem to support IPP.
Since it does mention AirPrint, try that instead.

Hi fellow manjarees,
by coincidence, I have the very same problem, with the very same model. I use manjaro with KDE and till now, I was able to simply add the printer via system settings GUI. But after a fresh install, I encountered a new bug that appeared recently in kde-add-printer 450154 – LPD printer discovered but address/queue fields are empty (that does not seem to be resolved anytime soon): The adress field remains empty, when trying to add the discovered network printer.

So, as the OP suggested, I tried adding the printer via CUPS local web interface. But to no avail:
Under localhost:631 > Administration > Add Printer > it is found as “Discovered Network Printer” and the connection is identified as “lpd://BRWD81265085917/BINARY_P1”. But, after being added, it just stays silent. When trying to print a test page, the print job immediately switches to “stopped”.

I can ping the printer via IP, the packages manjaro-printer, brother-mfc-j497dw and cups* are installed.


PS: The PC can communicate with the device! I can use the scanner, that is installed via brscan.

Thanks for the reply. Maybe I’m missing a package or something, but I don’t see any options for AirPrint under the ‘Add Printer’ setup in CUPS. It seems to support:

  • AppSocket
  • ipp
  • ipps
  • http
  • https

I have tried to set up the printer to the best of my abilities using all of these protocols, but none of them work.

Do you have network discovery enabled? It may help.

Yes, everything was already installed and configured as the article you linked says. And network discovery is working, CUPS does discover the printer automatically. When I set the printer up in this way, it uses the connection ‘lpd://BRW30C9ABAB103F/BINARY_P1’. But when I try to print, the job will error out with “Unable to locate printer “BRW30C9ABAB103F”.”.

I had some issues with printer drivers lately where they would take half an hour per page to print. So is it not ever printing or just taking a really long time?

Also, I want to confirm that I have the same issue mentioned above where I have to add/modify printers in the web interface as the gnome interface does nothing.

It does not print. I’ve left the jobs pending overnight and there’s still no reaction from the printer.

This should help.

Afraid not. As the article suggest, I tried to set up the printer using:

  • ipp://
  • lpd://
  • socket://

All of these had the exact same result; the job is listed as ‘completed’ but nothing actually prints.

Something that I found that helps when installing a new printer, regardless of the OS and you have this problem.
First turn PRINTER off, DON’T DISCONNECT any wiring, use the power switch then turn the COMPUTER off, turn the PRINTER back on and finish by turning the computer back on.
Go into Print History in both the computre and the printer and clear it, then run the test print.
For whatever reason, I found that this is the most productive method of getting a recalcitrant printer to work.
Remember PCPC.
Two more things to check, is there actually paper in the machine and was the strip that covers the opening to the toner cartridge removed, and yes both instances have happened more than once.
One last thing, if afterwards you get a lot of paper jams, try a different brand of paper.
Where I worked we had a number of name brand printers and exclusively using their own brand of paper, after numerous repair attempts on one of them - all the others ran without problems - with numerous parts replacement, we basically wound up with a new machine, I just for the hell of it used some cheap paper from the local big box store that we had sitting around tried it and subsequently went through 5 cases of it before getting another jam not caused by misfed paper.

The printer does work fine from other devices and even from a Windows install on the same machine, so the issue absolutely not with the printer. Nevertheless I double checked everything as you suggested but no change.

There’s an old thread from
That has a few ideas that are, at least, looking at.

Also if it works from other devices, check that you’re using the proper addresses in your settings.

Yes, I did already try using lpd://, but it doesn’t work. I am for sure using the proper address.

Exact same problem here. Tried all the adresses above according the arch wiki.
@maycne.sonahoz : Airdrop? Isn’t that proprietary Apple stuff?

So, long story short, seems we have a bug here:
I do have a second machine with Manjaro that has been setup two years ago. The printer is working fine there, connection is shown as dnssd://…
So, the problem is not that manjaro is unable to use the printer, once it is installed. The problem is, that we can not install it anymore. This only affects the setup of the printer itself. I can use the scanner with brscan!

So maybe something is amiss with the DNS service discovery?

Maybe it helps when you see the instructions Brother supplies for installing that printer driver:

Printer Drivers | Downloads | MFC-J497DW | United States | Brother

This is the driver download page, which also contains their instructions.

Nah. :slight_smile: This is not driver related (see post above). We are talking about a systemwide problem to install (discover) a new network printer. I doubt that this is related to the printer model btw. I am pretty sure, that this must be a general problem, introduced in one of the latest updates. What makes me scratch my head, is that I am unable to add the printer manually, though.

See: 450154 – LPD printer discovered but address/queue fields are empty

I wouldn’t know - I don’t own that device,
but those are the instructions Brother gives for that particular model.

Ok, I am so far as to pinpoint the problem to DNSSD. Obviously, something is broken. Unfortunately, all I could find was the small bug report, that I shared above. Once the printer is installed, it is smooth sailing. I therefore assume, that the problem occurs only on a fresh installation, when the printer has to be discovered for the first time. So, the bug reports will follow in the months / years to come…

There is a SOLUTION anyhow! It is possible to connect the printer driverless via it’s ip (set a fixed IP in the router) manually:

Thank god (or better, the godlike @ namitutonka ) for this tutorial!

Amazingly, this did resolve the issue. Thanks you.