Issue with uploading a LibreOffice generated docx files to Google Drive

This is related to this now closed thread: Insane problem with opening uploaded office docs in Google Drive on Manjaro

Essentially the same issue as the OP in that thread: if I save a file in .docx format from LibreOffice and upload it to Google Drive, Google does not recognise it (reporting ‘Unknown format’) and in turn does not open it with Google Docs.

After some research and experimenting I found out that simply removing the .docx extension from the file and uploading it to Google Drive seems to trigger some sort of ‘autodetection’ where eventually the file is correctly handled as a Word file.

Posting this in case it might be helpful for someone else with a similar issue and searching the web for a solution.


Hi @lorenzosu,

I have an the idea that this is happening because it is a proprietary format. I don’t know if I’m correct or how to test if it is that.

What happens if you try it with the open-source .odt format?

I use .odt locally and as the main format for my documents as I use LibreOffice.

With Google Drive .odt works but the caveat is that Google Drive will then converted to a ‘Google Docs’ file, so essentially you end up with two file (if you want to use the editor). On the other hand since a while Google Docs suppo .docx ‘natively’ meaning if you upload a .docx file you are directly editing that file.

I think initially .odt was the preferred and supported format by Google Docs but then they shifted to .docx, probably to keep up competition with the MS online apps.

My main use case with Google Docs / Drive is sharing with people.

1 Like

Possibly. And I just read Open format (ECMA-376, ISO/IEC 29500 to be exact.)

So…I think…yeah, I don’t know what I think anymore…

Hey, that’s pretty cool you returned to this problem with a solution (of sorts).

My problem is gone, because meanwhile the laptop (10th gen Intel Dell XPS) is gone and the job that was attached to it too. I used to have to upload loads of .docx and .xlsx docs we received to our company Google Suite Drive. I encountered that problem only on that particular Manjaro install on my laptop. I tried several other Manjaro and Endeavour installs and they all uploaded the exact same documents to Google Drive without a fault. Still no idea what was causing it :upside_down_face: