Issue with mesa after [Stable Update] 2021-04-09

Hi, I faced an issue with mesa (upgraded from 20.3.4-3 to 21.0.1-1 in today’s update [Stable Update] 2021-04-09 - Kernels, Systemd, Gnome 40 Apps, Mesa 21.0.1, Kernels, Browsers): I am no longer able to start a Windows game: Gta San Andreas; previoulsy it worked like a charm: was enough to start it using a bash script

cd "~/.wine/drive_c/Program Files (x86)/GTA San Andreas/"
mangohud wine ./gta_sa.exe

Since today, launching it from Terminal, I see the following generic error message:

X Error of failed request: GLXBadFBConfig

The game runs with dxvk.
Another game (Need For Speed Porsche) which runs with OpenGL, works ok without errors.

And I have no clue what the error message means…
But I had the idea of downgrading all mesa packages from 21.0.1-1 to 20.3.4-3 and the dxvk game back to works as before.

My inxi:

System:    Kernel: 4.14.227-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.14-x86_64 root=UUID=0d37cf27-2ff0-4234-a80e-4be323299166 rw i915.fastboot=1 
           i915.modeset=1 i915.enable_rc6=0 i915.enable_dc=0 quiet "acpi_osi=Windows 2009" libahci.ignore_sss=1 
           random.trust_cpu=on pcie_aspm=force scsi_mod.use_blk_mq=1 nowatchdog nmi_watchdog=0 mitigations=off 
           nospec_store_bypass_disable noibrs noibpb nopti nospec nospectre_v1 no_stf_barrier 
           kvm-intel.vmentry_l1d_flush=never audit=0 loglevel=0 udev.log_priority=0 rd.udev.log_priority=0 
           rd.systemd.show_status=false net.ifnames=0 systemd.unified_cgroup_hierarchy=true noresume 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP ProBook 6470b v: A1029D1102 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Hewlett-Packard model: 179C v: KBC Version 42.38 serial: <filter> BIOS: Hewlett-Packard v: 68ICE Ver. F.73 
           date: 08/07/2018 
Battery:   ID-1: BAT0 charge: 60.2 Wh (98.0%) condition: 61.4/61.4 Wh (100.0%) volts: 12.5 min: 10.8 
           model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Unknown 
           Device-1: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400 Plus serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech Wireless Mobile Mouse MX Anywhere 2S serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
Memory:    RAM: total: 15.55 GiB used: 2.09 GiB (13.4%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
           stepping: 9 microcode: 20 cache: L2: 3 MiB bogomips: 19967 
           Speed: 2539 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 2539 2: 2288 3: 2923 4: 2894 
           Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de 
           ds_cpl dtes64 dtherm dts epb ept erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs ida lahf_lm lm 
           mca mce mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 
           pts rdrand rdtscp rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
           tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
           Type: l1tf mitigation: PTE Inversion; VMX: vulnerable 
           Type: mds status: Vulnerable; SMT vulnerable 
           Type: meltdown status: Vulnerable 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 status: Vulnerable: __user pointer sanitization and usercopy barriers only; no swapgs barriers 
           Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:0166 class-ID: 0300 
           Display: x11 server: X.Org 1.20.10 compositor: picom v: git-dac85 driver: loaded: intel display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 360x202mm (14.2x8.0") s-diag: 413mm (16.3") 
           Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") diag: 354mm (13.9") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.3.4 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403 
           Sound Server-1: ALSA v: k4.14.227-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
Network:   Message: No Device data found. 
           Device-1: TP-Link Archer T9UH v1 [Realtek RTL8814AU] type: USB driver: 8814au bus-ID: 4-3:2 chip-ID: 2357:0106 
           class-ID: 0000 serial: <filter> 
           IF: wlan0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> scope: link 
           WAN IP: <filter> 
Bluetooth: Message: No Bluetooth data was found. 
Logical:   Message: No LVM data was found. 
RAID:      Message: No RAID data was found. 
Drives:    Local Storage: total: 698.65 GiB used: 78.77 GiB (11.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 4B6Q scheme: MBR 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB block-size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 023 scheme: MBR 
           Message: No Optical or Floppy data was found. 
Partition: ID-1: / raw-size: 465.76 GiB size: 457.45 GiB (98.22%) used: 36.55 GiB (8.0%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
           label: N/A uuid: 0d37cf27-2ff0-4234-a80e-4be323299166 
           ID-2: /home/<filter>/mounts/servicedisk raw-size: 232.88 GiB size: 228.23 GiB (98.00%) used: 42.22 GiB (18.5%) 
           fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: servicedisk uuid: 8412b438-5d7b-48bd-bfb1-46666bb7ac64 
Swap:      Alert: No Swap data was found. 
Unmounted: Message: No Unmounted partitions found. 
USB:       Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
           Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip-ID: 8087:0024 
           class-ID: 0900 
           Hub-3: 1-1.2:3 info: VIA Labs VL813 Hub ports: 4 rev: 2.1 speed: 480 Mb/s chip-ID: 2109:2813 class-ID: 0900 
           Device-1: 1-1.2.1:4 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 98mA chip-ID: 046d:c52b class-ID: 0300 
           Device-2: 1-1.2.2:5 info: Logitech F310 Gamepad [DirectInput Mode] type: HID driver: logitech,usbhid interfaces: 1 
           rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 046d:c216 class-ID: 0300 serial: <filter> 
           Hub-4: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
           Hub-5: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip-ID: 8087:0024 
           class-ID: 0900 
           Device-1: 2-1.6:3 info: Broadcom HP Portable SoftSailing type: <vendor specific> driver: N/A interfaces: 4 rev: 2.0 
           speed: 12 Mb/s chip-ID: 0a5c:21e1 class-ID: fe01 serial: <filter> 
           Hub-6: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
           Hub-7: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
           Device-1: 4-3:2 info: TP-Link Archer T9UH v1 [Realtek RTL8814AU] type: Network driver: 8814au interfaces: 1 
           rev: 3.0 speed: 5 Gb/s power: 864mA chip-ID: 2357:0106 class-ID: 0000 serial: <filter> 
Sensors:   System Temperatures: cpu: 42.0 C mobo: 0.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 159 Uptime: 7m wakeups: 6 Init: systemd v: 247 tool: systemctl Compilers: gcc: 10.2.0 Packages: 
           pacman: 1673 lib: 435 Shell: Bash v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.03

Seems I’m not the only one which faced issue with Mesa 21:

On Reddit I found a workaround:

X Error of failed request: GLXBadFBConfig after ubuntu update : linux_gaming

I reupdated mesa packages (I don’t like held back packages on a rolling release) to 21.0.1-1 and added this environment variable:


And the game works again as it should.



Yep, I see, but I encountered the issue with mesa 21.0.
And also the previous release (Mesa 20.3) is above 20.1, which you mentioned.
I miss something?

No. It shall be fixed by upgrading the packages in the repository.

Indeed. And in the meantime, waiting for a fixing in the next mesa release (as you can see on Reddit and on Bugzilla, mesa 21 is problematic also for other people) I’m using export MESA_GL_VERSION_OVERRIDE=4.4 in the game’s script: a workaround, not a proper solution.
Also many thanks to you for investigating.

1 Like

The above solution (…=4.4) solved the problem under Wine, however, it turned out to generate other problems with chromium, opera (and maybe other packages) that did not start.

Mesa update (to 21.0.2) did not solve my problem with Wine /.exe in my system.

But an entry MESA_GL_VERSION_OVERRIDE=4.5 works better because there are no problems with browsers.

Sorry for the late response to everyone.
With mesa 21.0.3-3 (introduced in [Stable Update] 2021-05-06 ) I no longer need the env variable export MESA_GL_VERSION_OVERRIDE=4.4.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.