Is it possible to show AUR packages in the GUI?

In KDE when I’m going to “Add/Remove software” I can activate this option and when I search something, it’s show me the AUR packages.

Is it possible in XFCE? I activated Enable AUR in the config (removing the #) but only the packages that I can see are from flatpak or snap and I’m installing everything from the console. But I don’t have the switch like in KDE.

I would like to see in the GUI too, if is possible.

Sorry for all this questions, it’s my first time with XFCE.

Why wouldn’t it be? pamac is desktop-agnostic. It’s a gtk3 or gtk4 application — depending on which one you have installed — and it works the same regardless of whether you’re in Plasma, GNOME, Xfce or whatever.

1 Like

Exactly the same option exists in xfce, as it is the same software.
Did you modify /etc/pamac.conf :

## Allow Pamac to search and install packages from AUR:

Thanks @Aragorn and @Denis_Pom.

Yes, like I said in the post I enabled AUR but when I’m going to the GUI, always appears flatpak and snap. I cannot check it now because is the laptop of my work (in home i’m using KDE) but yes, the first things that I did was open the GUI and try to enable like the image in my first post, when I saw the switch was not here, I searched in google and If I’m not wrong I removed the # of the line EnableAUR but I continue without see the option.

On monday I will recheck again and I will update the post here! :slight_smile:

Thanks always for the help!

There has been some issues surrounding pamac and the copy of the aur_package database provided by AUR.

Manjaro uses a cdn to serve the database and there has been several issues over the past many moons.

These issues could be the cause of the missing list of available custom scripts.

There has been other reports of Pamac exhausting memory and this has been tracked down to - if you guess AUR - you are spot on.

I highly recommend the disable AUR and as this only affects the GUI - you should still be able to using the CLI.

Check if Software Mode is disabled in pamac GUI settings


grep software_mode ~/.config/pamac/config

Is pamac in 'Software Mode"? Disable it.

So yes, if:

grep software ~/.config/pamac/config
2:software_mode = true


sed -i 's/software_mode = true/software_mode = false/g' ~/.config/pamac/config

:wink: Juz bored.

Can anyone explain to me this ‘software mode’ option, it makes no sense to me…

Ah, it’s a ‘non-native speaker’ type bug.

That item should be labelled ‘Repository Mode’.

It simply seems to deactivate Flatpak and Snaps… which might be a good idea, but they are actually software too…

Where’s the bug report? This one comes up nearly every week!

Neither do I see the use but if you see it like a shop with to displays

  1. All the nitty gritty stuff - like addons and drivers and what not
  2. Nice boxes of ready to consume apps

I think the software mode intends to be that filter - only the ready to consume apps.

1 Like


Ah, so more like ‘Software Store’… I see it now… it doesn’t disable flatpaks for me, but I was just reading a response from the past that says it simply enables/disables ‘appstream’ data.

Thanks. Now I can see AUR option


Software Mode was activated!.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.