Is it necessary to use VPN?

Good morning, I have an issue blocking some features of the applications such as Discord connection does not work well and I need to use VPN I tried to use openvpn I searched a lot but I did not find a file that works well and it will take a long time to find the file I went to change the DS, does that help?

I have another issue, I want to update the Discord program. I downloaded the update file in tar.gz format, unzipped the file and launched the application by ./Discord How do you install the software update?

do not post screenshots of text - screenshots removed

No, it’s not; just as it’s not necessary to wear seatbelts when driving.

However, if you don’t, you might sacrifice an amount of privacy, if that’s of concern to you; and in the case of seatbelts, you might get fined if caught.

You could start by completely removing the downloaded package.

Discord is available in the official Manjaro repositories; always use the repo version before looking for foreign packages:

# Search for a package in Manjaro repositories:
pacman -Ss discord

# Search for information about that package:
pacman -Si discord

# Install the package
sudo pacman -S discord

Discord would be automatically updated every time you perform an update.

I hope this helps. Cheers.


Thank you bro for your help

I know it’s a liability issue. They’re not looking to see if anyone’s using VPN.

The version I’m using now is from Manjaro’s warehouses.

The version in the repositories is an older version than the one available on the official website and I want to learn how to install the programs in tar.gz format, that’s the main reason

The version in Makhawan Ngaru is 0.0.54-1 and the version on site is 0.0.55

With a little patience, the newer versions will reach Manjaro Stable soon enough. It’s really only Debian (and some Debian-based) distributions that tend to be annoyingly behind, at times.

However, it’s usually best to ask about what you actually hope to achieve in your first post, as you have only now done, as this will typically attract quality answers and save time.

Here are some resources that you may find useful:

I hope this helps. Cheers.

If discord found out there is a new version, but you don’t have the newest version available at Manjaro… i fixed it with this:

~/.config/discord/settings.json and add the following line (don’t forget too add , at the second last line):



Tank you bro the issue is there is no configure file in the folder

do not post screenshots of text - removed

i use this command to run ./Discord version 0.0.54-1

In this case it seems to be packaged much like a portable app - extract and run. I imagine you would need to download the next full version rather than an update, and install it as you did before.

thank you bro for you help i add it

do not post screenshots of text - removed

how will install it ?

how can i download it ?
i download the last version fro discord site
you mean i need to remove app and install the new virsion ?

Yes, that’s right.

I’d still rely more on the version in the official Manjaro repo, if it were me.
Updates would still come soon enough.

i will try it

i find discord_arch_electron 0.0.55-1 in AUR

do not post screenshots of text - removed

Keep in mind packages from the AUR are not supported by either Arch or Manjaro; it’s only a convenience for those willing to accept the reponsibility.

Officially, no support will be offerred.


OK i try also to install it as deb file using sudo dpkg -i discord-0.0.55.deb

do not post screenshots of text - removed

AUR package was updated 2 days ago 2024-06-05
discord-appimage has also been updated today (2024-06-07)
Latest version may also be available as a Flatpak or Snap

Don’t do that - even if you manage to install the Debian tools needed to do it.
But feel free to do it anyway - it’s your system.

The AUR version is the currently newest.

What has the use of Discord to do with using a VPN?

… I know from a long time ago that some used to “change their IP” when they for some reason got kicked from the chat - so the server would not recognize them and they could be in again.
This was usually accomplished by disconnecting and reconnecting - which apparently got you a different IP sometimes.

It would surprise me if that still works.

A VPN gives you that ability - by changing to a different endpoint in another city or another country.
To the other side it appears as if you where there.

tar.gz is only an archive (like .zip) with undefined contents.
manjaro packages are *.pkg.tar.zst - manually installing an application is a huge risk of having your distribution broken (from .deb, .gz, .sh, …)

it’s simple: installing from a file found on the web isn’t designed for rolling-release and is therefore dangerous.

1 Like

The what ?

You cannot. You need to convert it manually

1 Like

You don’t need anything to install after it. Its the fix… the solution to your Topic that i just gave you.

The additional command that bypassed the “Force Update Pop up.” that denied your access to discord.

Your Pictures was removed, just do give your more details how my settings.json file looks like, i hope it helps you:

  "BACKGROUND_COLOR": "#202225",
  "IS_MAXIMIZED": true,
  "IS_MINIMIZED": false,
    "x": 320,
    "y": 148,
    "width": 1366,
    "height": 714
  "enableHardwareAcceleration": false,
  "debugLogging": false,
  "MINIMIZE_TO_TRAY": false,
  "OPEN_ON_STARTUP": false,
  "chromiumSwitches": {}

I mean, its your choice… if you want to make your life complicated because you can’t wait a few days to get this brand newest version, its a free world :crazy_face:

Convert what, now? :thinking:

Both the package in the repos and the AUR already package the .deb.

I know - the topic kind’a drifted from the title to discord and - despite the availability in the repo - a comment on installing discord using dpkg - so the comment was about using dpkg and a deb file.