Internal SSD hard drive is not recognized under KDE Manjaro Linux, but it is under windows

I had KDE Manjaro Linux installed on my notebook for quite some time, in addition to a Windows system that I haven’t used anymore.
After a crash nothing worked anymore. I replaced my SSD and my normal SATA hard drive in my notebook. In order for the hard drives to be recognized again, I had to reinstall Windows 10. Both hard drives are now properly recognized in Windows 10. On the SSD hard drive is currently installed Windows 10, that I want to destroy later again, when I will have Linux installed as the only operating system. However, I can’t get that far.

When I boot with the Manjaro KDE USB live stick, the SSD drive is not recognized. And not at all, even with the commands:

fdisk -l

Also it is not detected with KDE partition manager nor gparted.
What can I do now???

Thanks a lot for your help, Rulinux

P.S.: It seems the has been integrated into Thus you can find German and English issues.
Should be rather posted in English or German or both is fine?

I suppose it used a NTFS file system. Did you remember to disable Fast Startup?

yes, fast startup is disabled in bios as well as in Windows itself. It is currently still both NTFS.

Could be a driver issue. Maybe you bought a new drive that needs some quirks and is not yet fully supported by Linux. What drive is it? Please also read

Regarding your P.S.
You should post in English. There is a German forum here

but there might be fewer people reading it.

output of lsblk?

Also can’t you format the drive you want to use for Manjaro from Windows first?

lsblk does not list the device.

I have used now

sudo dmseg

It shows in the log.

Switch your BIOS from RAID to AHCI mode to use them.

But I do not know where to find in Bios, if it works.

So far I found out that there is no way for settings in the BIOS nor an UEFI for adjusting SATA Controller for correct AHCI and Raid Controller.

Finally I had to reinstall Windows on my notebook killing Linux. First time installation still did not enable to recognize the second internal hard disk with Linux USB-Live-Stick but only within Windows.

Because UEFI is directly addressed via Windows and cannot be set by itself, I have done some settings in the Windows registry in hope for solving the problem for Linux for correct AHCI and Raid hard disk detection. Here is a description in German
Change AHCI mode

After having done these settings the computer did not start any OS anymore. Then I reinstalled Windows again completely with all updates and upgrades. With the second installation routine a repair function of Windows took place. After finalizing all updates and upgrades for Windows finally both hard disk were also detected within USB-Live-Stick. These procedure took 1,5 days.

Than I could reinstall Linux completely and solely on my computer. I replaced the basic installation of the /home directory with the one from my last timeshift backup.

After 1,5 weeks total work my computer finally worked again.

For help for others with the same problem, I have written down my solution here in the forum.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.