Intel integrated Graphics driver lagging and slow on Gnome / Wayland

I’m really new to both this forum software and Linux in general, please hold my hand!

I am totally new here, using i3 10 gen chipset in my laptop.
Newly installed manjaro.
But its really lagging badly when i run YouTube videos or any video even when i try to open a image it really lag a lot.

I think its my driver issue, any solution please?
I didn’t install any driver manually.

inxi --admin --verbosity=7 --filter --no-host --width            ✔ 
  Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=0566d135-95da-44e2-b22c-aea5a93d8e1b rw quiet splash apparmor=1 
  security=apparmor resume=UUID=4147c4d2-ef51-4b65-bfa0-b20393b771de 
  Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Notebook product: DC4103M v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Notebook model: NL40_50CU serial: <filter> UEFI: INSYDE v: 1.07.01TDCL 
  date: 05/28/2020 
  ID-1: BAT0 charge: 33.0 Wh (81.7%) condition: 40.4/36.2 Wh (111.7%) 
  volts: 12.2 min: 11.4 model: Notebook BAT type: Li-ion serial: <filter> 
  status: Discharging 
  RAM: total: 7.47 GiB used: 1.85 GiB (24.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i3-10110U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: EA cache: L2: 4 MiB bogomips: 20810 
  Speed: 800 MHz min/max: 400/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni 
  popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss 
  ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: CLEVO/KAPOK 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300 
  Device-2: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 1-7:3 
  chip-ID: 5986:9102 class-ID: 0e02 
  Display: wayland server: 1.20.11 compositor: gnome-shell driver: 
  loaded: i915 note: n/a (using device driver) - try sudo/root display-ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.1.5 
  direct render: Yes 
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: CLEVO/KAPOK 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus-ID: 00:1f.3 chip-ID: 8086:02c8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.32 running: yes 
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel 
  port: 4000 bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: CLEVO/KAPOK driver: r8169 v: kernel port: 3000 bus-ID: 01:00.1 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp1s0f1 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 238.47 GiB used: 10.27 GiB (4.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: BIWIN model: SSD size: 238.47 GiB 
  block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  type: SSD serial: <filter> rev: T0609B0L temp: 32.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 229.37 GiB size: 224.71 GiB (97.97%) 
  used: 10.27 GiB (4.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 0566d135-95da-44e2-b22c-aea5a93d8e1b 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: NO_LABEL uuid: 393D-433F 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: 4147c4d2-ef51-4b65-bfa0-b20393b771de 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: Shenzhen Rapoo Rapoo 2.4G Wireless Device 
  type: Mouse,Keyboard driver: hid-generic,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s power: 100mA chip-ID: 24ae:2013 class-ID: 0301 
  Device-2: 1-7:3 info: Acer BisonCam NB Pro type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:9102 
  class-ID: 0e02 
  Device-3: 1-10:4 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 8087:0aaa class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 226 Uptime: 1h 34m wakeups: 1 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: N/A Packages: pacman: 1135 lib: 296 
  flatpak: 0 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06 
1 Like

Hi @griffin,

I might not be able to help you, but I CAN point you in the right direction:



@griffin Please stop creating duplicate threads. Your other two have been removed.

1 Like

oh, noted

Can i get any solution ?

Please review the tutorials @Mirdarthos linked above. As mentioned therein, please do not post screenshots of terminal output. Please edit your first post (if it still allows you to) and post your system details as outlined.

Is that ok?

  1. In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
    Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
    Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
    Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    instead of like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    (as that makes both our lives much easier)

  2. No need to do anything right now as I’m a moderator here on this site and have fixed it for you already. However, in the future I might not see your post so review my edits by pushing the orange pencil above the post I just fixed. :wink:

  3. unfortunately, you’re on Gnome/Wayland so I can’t help you any further than the edit…


1 Like

Thats so kind of you. i will try to learn that properly <3

here is whats happening when i play a normal video

but it was ok in windows 10

From your title, it means that this lag does not occur on Xorg?

OP probably doesn’t know what the difference is between Wayland and Xorg. I edited that into the title to attract the right experts…


I tried XFCE ,and same issue with there too.

Is it something about manufacturers?
Or should i do something with BIOS?

What does printenv |grep VA say?

Its not showing any output in the terminal :frowning:

Any solution? Or any suggestions about where i can get the solution ? :frowning:

You still haven’t provided any details that could help us help you.

:warning: If you bump this post one more time, the post will be closed.

Please see the Forum Rules:

Bro can you please tell me ,which specific information you actually need ?

Skipping already installed config 'video-linux' for device: 0000:00:02.0 (0300:8086:9b41) Display controller Intel Corporation CometLake-U GT2 [UHD Graphics]

is that a issue?

Just install xdpyinfo with sudo pacman -S xorg-xdpyinfo, and this error message will be gone.
Your original issue is not easy as that though.

Pls post the output of
tree -L 3 /etc/X11
mhwd -li

1 Like
/etc/X11/xorg.conf.d/90-mhwd.conf                                                         ✔ 
zsh: no such file or directory: /etc/X11/xorg.conf.d/90-mhwd.conf
tree -L 3 /etc/X11                                                            127 ✘  13s  
├── mhwd.d
├── xinit
│   ├── xinitrc
│   ├── xinitrc.d
│   │   ├──
│   │   ├──
│   │   └──
│   └── xserverrc
└── xorg.conf.d
    └── 00-keyboard.conf

4 directories, 6 files
mhwd -li                                                                                  ✔ 
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Now try to install modesetting driver with sudo mhwd -i pci video-modesetting. Reboot when it finishes and pray :slight_smile:

Same issue still :frowning:
any suggestions ?
like should i go for another environment , i tried XFCE but same issue

Is there any solution?