Installing Manjaro on erased iMac?


This question is generic, so I don’t think there’s a need to provide the usual system info.

The generic part is this: a blank/erased HDD on an iMac.

Only too late it came to my attention, in some Arch Wiki article, that the safest way to deal with Apples is to save a partition for the iMac’s own system.

Too late, thus. Therefore, upon installation of the newest Manjaro KDE I simply went for the option where the new partition completely replaces the old partition. Dumb. But I have now learned to consult Arch/Manjaro and to be 100% certain before doing anything. At the time I had only read more general claims about how installing Linux on old hardware works such wonders. I thought I would do this to my old iMac from 2009 (21 inches screen).

It all went well. Until it didn’t. Upon some boot the infamous apple-black screen appeared. At which point I found the said Arch article. Et cetera. So before trying to even solve that issue (though I have read a lot about it by now), I thought it best to consult you guys.

My question is therefore: is there any hope at all in installing Manjaro/Linux on such an erased iMac disk? If so, what is the fool-proof method?

The Gods know I have searched the net. But I find many conflicting views. Thus, since I am no “Linux/iMac constellation expert,” I ask you kindly to help me find an answer.

Thanks, dear Linuxians!

if possible , try to just format in GPT with apple tool the disk ,
you can after install others partitions , do not format /boot/efi

if not possible , try with Alt to boot , USB Iso manjaro ,and select the disk

1 Like

I suggest you use the Apple network installer - OptionCmdR while powering up - to restore macOS then you can create the dualboot afterwards.

Your best option is to use macOS - you willl likely run into various annoying issues in the long run.

Apple branded hardware is for macOS and that is my personal opinion after trying myself to get Linux running on such hardware.

1 Like

Thanks for support!

So just like @linux-aarhus, you suggest that, if I want to install Manjaro on it, best option is dualboot (dualboot meaning one partition for macOS and another partition for Manjaro)?

I was hoping to get it to 100% Manjaro, but seems you both says that’s not possible. What a sad state of affairs - for Apple, that is.

Thanks for helping me out!

A full install thus seems impossible. If you can’t, surely I can’t. Or, I don’t have that much time to try and resolve it.

Second best solution is a dualboot, you say. I will try that out now. Is this article good? iMac Aluminum - ArchWiki

If there’s an even better article, could you please point me to an article describing step-by-step the safest method?

As regards the dualboot: what are the typical problems to expect?

Also, if I go back to a full macOS, my iMac is from 2009, so what are the best OS options to make it functioning again? Is this article correct? What Version Of macOS Can My Mac run? | Macworld

Many thanks!

I have no idea on which macOS is for which system - and for how to do it - I would put more faith in the Arch wiki.

1 Like

A 2009 Imac can run manjaro on its own with no problems. I’m using a similar mbp from 2009 and I wiped macos from the disk in 2011.

The first step is to correctly identify the exact model at everymac, as far as I can see we’re talking about IMac 10.1. iMac 21.5-Inch "Core 2 Duo" 3.06 (Late 2009) Specs (Late 2009, MB950LL/A*, iMac10,1, A1311, 2308):

Then research the search string: "arch linux apple late 2009 “imac 10,1"”

Since this model uses a radeon graphic it should cause less trouble than nvidia equipped imacs. For imacs with 64bit efi (after 2006) Refit or any additional bootloaders are not required. Will add inxi of my 2009 mbp to show disk partitioning and setup.

Boot any manjaro boot stick with ‘option’ key pressed and pick ‘Efi’ to continue.

Older Imacs and MBPs have a little quirk when they are left switched off for long and their bios battery is dead in which case you end up with a black screen and you have to reset the NVRAM, a fairly easy procedure. Have a look here:


Thanks for helping out, @6x12!

Well, I did boot with a flashdrive and it did work fine (except Firefox was incredibly slow, eventually always causing the machine to freeze). Until it upon boot endlessly repeats producing that pesky black screen. I have come to the knowledge, thus far, that this is a very common issue. Seemingly unsolvable.

I have found tons of threads and posts grappling with this black-screen issue, but not 1 fully proven method that puts an end to the misery.

Now, you say you have had no problems. Good news! You also mentions graphics. So here’s perhaps why I get stuck. Now, I am not 100% sure, but I believe my imac has an NVIDIA graphics card: iMac (Early 2009) - Technical Specifications (UK) I remember this from inspecting the hardware after first installing Manjaro.

Also, upon this inspecting I remember also that only less than half the actual RAM was found (1,7 RAM).

So what’s your experience with NVIDIA?

Hi again. I have tried, but to no avail: black-screen returns immediately. I am not allowed access to anything. Let me describe what happens.

Upon pressing AltcmdR while pressing the start-up button, I hear the mac startup sound, screen comes on in light grey color for about 6 seconds, then the black screen reappears, and I can hear the machine is on. That’s all. (I have tried with and without the network cable inserted, and with and without bootable flashdrive.)

Oh, ok, you said 21" in your first post and 10,1 was the only 21" 2009 model.

Can you ran inxi -Fz to determine the exact hardware please. If it’s an nvidia card it will be the same as the one I’m using, Device-1: NVIDIA C79 [GeForce 9400M]. Do not install the proprietary driver, nouveau will work. Since you can boot that means you are on nouveau.

Also try to run a check on the hard drive, it may well be the actual issue, that’s how my 2008 imac died around 2015, any of those (hitachi?) drives still going in 2022 may be on their last leg.
Should a test show bad health, the drive is relatively easy to swap but using an external ssd plugged into a usb port and installing onto that should give a definite performance boost and should allow you to evaluate the machine to decide if an internal drive swap is worth it.

One more thing I noticed: those Imacs came with min 2GB ram, yours shows 1.7 which is 2GB minus 256MB shared to the graphics. That is not enough to run it stable nowadays. Are you sure it’s got 4GB ram? If yes undo the little screw that covers the ram slots, reseat the two modules and clean the contacts with dry q-tips. (Ram upgrade is super easy and relatively cheap)

Here the inxi of my MacOS free 2009 mbp converted to ssd:

  Kernel: 5.10.121-1-MANJARO arch: x86_64 bits: 64 Desktop: MATE v: 1.26.0
  Type: Laptop: Apple: MacBookPro5,4 date: 06/15/09
  ID-1: BAT0 charge: 78.1 Wh (99.9%) condition: 78.2/77.8 Wh (100.5%)
  Info: dual core model: Intel Core2 Duo P8700 bits: 64 
  Speed (MHz): avg: 1317 min/max: 798/2527 cores: 1: 1839 2: 796
  Device-1: NVIDIA C79 [GeForce 9400M] driver: nvidia v: 340.108
  Device-2: Apple Built-in iSight type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2 driver: X:
    loaded: nvidia gpu: nvidia resolution: 1440x900~60Hz.
  Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.10.121-1-MANJARO running: yes
  Sound Server-2: PipeWire v: 0.3.52 running: yes
  Device-1: NVIDIA MCP79 Ethernet driver: forcedeth
  IF: enp0s10 state: down
  Device-2: Broadcom BCM4322 802.11a/b/g/n Wireless LAN driver: wl
  IF: wlp4s0 state: up 
  Local Storage: total: 111.79 GiB used: 67.55 GiB (60.4%)
  ID-1: / size: 85.87 GiB used: 67.55 GiB (78.7%) fs: ext4
  ID-2: /boot/efi size: 511 MiB used: 3.7 MiB (0.7%) fs: vfat
  ID-1: swap-1 type: partition size: 3.95 GiB used: 0 KiB
  System Temperatures: cpu: 46.0 C gpu: nvidia temp: 50 C
  Memory: 3.59 GiB used: 1.4 GiB (39.0%) 
1 Like

I have a macBook Pro from 2017 - which can be reinstalled by downloading the matching release from Apple.

The keypress is implying an Apple keyboard - I don’t know if it works with any hardware or there may be special sequences or even it is supported on your hardware.

My efforts to install on Apple hardware goes back many years and since the failed attempts and learning about the troubles members have - I am only confirmed in abandoning the thought of installing Linux on Apple.

I can provide nothing useful with relation to Apple hardware.

1 Like

Then why chime in? You are a well respected and knowledgeable member of this forum but I noticed similar discouraging posts from you on almost all Mac topics I tried to provide assistance. Not helpful.

Yes, I will do. First, though, I am in the process in downloading High Sierra, which I believe is the latest OS possible for my iMac.

And as with everything I do these last days, about everything is sluggish and annoying, lol, so downloading now is snailing about, suggesting the download will take 5 hours.

I return with output for inxi asap! Thank you!

My plan is to re-install macOS with High Sierra, then install Manjaro alongside as @linux-aarhus suggested. But I need to know fully what to do with the mac partition.

It’s just so incredibly annoying with Apple and Microsoft. I feel it’s like buying a fancy, shiny new Ferrari, though never being able to get “under the hood.” You don’t own that Ferrari - at all. It’s incredible that we have let us been duped to accept Apple and Microsoft’s deals.

Well, I am now in the process of downloading High Sierra ISO (latest possible OS). I will reinstall, and then install a separate partition for Manjaro.

Thank you for your help.

I think your drive is failing or one of your ram modules has died…
As my mbp partitions show, MacOS is not necessary:

~ >>> sudo fdisk -l                                                            
Disk model: Crucial_CT120M50
Disklabel type: gpt
Device           Size          Type
/dev/sda1        512M    EFI System
/dev/sda3       87.4G    Linux filesystem
/dev/sda4       19.6G    Linux filesystem
/dev/sda5          4G    Linux swap

Could be the iMac drive is corrupted. Will find out later.

But right now I am downloading via my Lenovo laptop. Crazily low speed right now. Coming back to report asap. Could be hours, though …

That is because Apple hardware is notoriously difficult and I want to give those who tries the headsup - the warning that the endeavour may not succeed.

If no one stands up then we may end up with a lot of frustrated users who may blame Manjaro where it is more likely how Apple put together their hardware.

It is the same for AUR - it is unsupported - but if no one stands up - everyone will believe that AUR is supported and issues can pointed back to Manjaro perhaps even blamed.

Some, like your (touchbar?) 2017 mbp no doubt is.

I tried linux (Mint) on an 2006 intel imac; it worked out of the box. In 2009 I took a mint-usb to the apple store and booted a mbp; it worked and I bought it.
After removing OSX to make space I tried all sorts of multiboot setups, your openbox manjaro included, all good. Booting from usb, I copied the original drives partitions with gparted to an ssd then swapped the drives, fixed the fstab and it worked. Recently I downloaded the latest manjaro iso and again everything works.

On ‘unibody’ intel mbps 2009-2012 and the corresponding imacs there may be the usual (obsolete) nvidia or some nouveau temp, sleep issue but that’s more or less (drives are getting old…) it.

I answer on topics that concern these units because I know they should work trouble free. Furthermore, dedicated suppliers still provide detailed videos and free tool sets for drive swaps, memory upgrades or battery replacements; all done within an hour. A 2009 laptop that looks timeless, boots in under 20 secs and last 4.5h on battery can still be a pleasure to use.

And that’s great. I know that some Apple hardware based on Intel may work with Linux but for the most part they are more trouble than it’s worth.

There’s still a lot of computer owners out there who thinks - a computer is a computer so any OS will do - but that is not true. Those users deserves to know that getting their Apple branded hardware running with Linux for some hardware it is a walk in the park - but for other - it’s a pain.

A lot of hardware exist which has been put together with the sole purpose of running Windows. That means that in a lot of devices which only works with Windows and is a pain to get working with Linux - the same with Apple and macOS albeit the Designed-For-Windows devices is easier to find solutions for because of Windows dominance on pc market.

I takes no genius to realize that Apple does not want they branded hardware nor their OS to be easily accessible with relation to maintenance and installation outside their eco-system.

macOS is based on BSD and in that sense it should be freely accessible but it’s not.

Apple is storing specific strings in the system firmware to prevent installation of their OS on non Apple systems. And while there is workarounds for that - it paints a picture of a company doing everything they can to prevent what they see as unauthorized use of their intellectual property.

It is like the Ferrari example mentioned earlier - you don’t get to open the hood and if you need service you contact an autorized to top-of the oil - even topping-of the cooling liquid must be done by an authorized chopshop.