Installing libseat from Official repos (community) gives error

Following this post, I tried installing wlroots and xdg-desktop-portal-wlr from repos. libseat is dependency for wlroots, but trying to install it gives error:

Checking integrity...
Error: libseat: signature from "Brett Cornwall <>" is unknown trust
Failed to commit transaction:
invalid or corrupted package

I tried changing mirrors, but error still remains. Is it safe to install this package? Should i try to stop pacman from checking ?

I’m not sure what happened there. I tried to reinstall that same package “libseat” and it was successfully done.
Anyway did you try if obs works without need of these packages in the post? Maybe at its current state what prevented it to work is solved.

I was trying it because OBS was not working in wayland

Sorry I made a question with an obvious answer. Anyway I told to the maintainer of the package that it might need those packages, but I got no answer

will building obs from source not require me to install all of the above? I even tried resetting keys but got same error

I don’t know what is going on with obs-studio in manjaro honestly, I checked on github and those packages that were necessary for me aren’t even mentioned.

Brett’s key expired. Look this thread Maintainer pgp keys expired

This command should work:

sudo pacman -U

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.