Installing Drivers for AMD RX 6500 XT

Hello, as the title implies I have a AMD RX 6500 XT gpu. These cards are only 2 months old on the market and as such there is basically no information online about how to configure them for gaming on manjaro. I used the auto install open-source driver feature, but I am noticing significant amounts of graphical bugs while in graphics-intensive games, as well as general fps choppiness. I’ve also noticed that manjaro does not seem to be able to identify my gpu, it being listed as “unknown device name”:

I’ve tried various guides on how to install amd proprietary drivers, but none of them were specific to my gpu and they either have not worked or in one instance it got my system stuck in a boot-loop and I had to rollback from the tty.

I am new to using linux for gaming so I apologize if this turns out to be an easy question, but I am very eager to learn. I am using a AMD Ryzen 5 2600 CPU, an Asus TUF gaming X570-PLUS motherboard, and I am on linux kernel 5.16.7-1.

Give system info with inxi -Fazy command.

1 Like

If that is indeed the case, its free driver may only be available in recent kernels… if available yet.
Keep a look out for kernel updates.

Here you go; Sorry I didn’t include this from the beginning but I didn’t know the command,

  Kernel: 5.16.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=1fae18e3-59db-4891-bfc3-9d0c99b27483 rw quiet apparmor=1
    security=apparmor resume=UUID=d88ae5f3-9569-46df-a259-20f919e72b70
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4203
    date: 02/09/2022
  Device-1: hidpp_battery_0
    model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: Discharging
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1711 high: 3889 min/max: 1550/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2049 2: 1364
    3: 1633 4: 1385 5: 1375 6: 1373 7: 3889 8: 1557 9: 1556 10: 1374 11: 1547
    12: 1438 bogomips: 81477
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 24 [Radeon RX 6400 / 6500 XT] vendor: Gigabyte
    driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-1 empty: HDMI-A-1 bus-ID: 0a:00.0 chip-ID: 1002:743f
    class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 5-2:2 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: DisplayPort-0 mapped: DP-1 model: ViewSonic XG2401 SERIES
    serial: <filter> built: 2018 res: 1920x1080 hz: 120 dpi: 92 gamma: 1.2
    size: 531x299mm (20.9x11.8") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD BEIGE_GOBY (DRM 3.44.0 5.16.7-1-MANJARO LLVM 13.0.0)
    v: 4.6 Mesa 21.3.5 direct render: Yes
  Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.1 chip-ID: 1002:ab28 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0c:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 5-2:2 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.16.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2526 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8168 v: 8.049.02-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 3-5:2 chip-ID: 8087:0025 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.36 TiB used: 583.1 GiB (41.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD4
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 023 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A02 scheme: GPT
  ID-1: / raw-size: 448.31 GiB size: 440.2 GiB (98.19%)
    used: 239.73 GiB (54.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.15 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 36.0 C mobo: 39.0 C gpu: amdgpu temp: 47.0 C
    mem: 52.0 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 365 fan-3: 878 fan-4: 0 fan-5: 1306
    fan-6: 0 fan-7: 0 gpu: amdgpu fan: 0
  Processes: 349 Uptime: 3h 14m wakeups: 10 Memory: 15.6 GiB
  used: 4.25 GiB (27.3%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.1 Packages: 1584 pacman: 1569 lib: 373 flatpak: 0
  snap: 15 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13

Thank you for linking a guide.
How would I tell if a particular kernel has the updated drivers I need?

Please use preformatting: [HowTo] Use preformatting in a forum post

That page is supposed to tell it, though even i have trouble reading it…

According to Phoronix, this card should already be supported in recent kernel and mesa

The Radeon RX 6500 XT does work with the current open-source Linux driver stack and its code is the Beige Goby driver path that has been present in the Linux kernel and Mesa since last year.

It should work out of the box nowadays. We can see it is recognized properly in inxi, it is using amdgpu, so it sounds good to me. Weird that it is not recognized under Manjaro Settings though.

What exactly is the issue then? what happens in what game?

Maybe you can reconfigure monitor setting to have 144Hz instead of 120Hz (or less), and/or make sure AMD freesync is enabled and working? Variable refresh rate - ArchWiki

Maybe you’re trying to run games at too high video settings and your system can not handle it.

1 Like

Thanks. I’m going to look into this later when I get home. Manjaro KDE recognizes my 6800XT in System Settings but there’s micro stutters in the UI and in games (my daughter got really frustrated playing Roblox, CoD:MW worked fine, Dying Light 2 exhibited micro stutters and still, the UI). I’ve tried changing refresh rates, disabling compositor, installing the next RC kernel (I’m on Testing), changing BIOS settings regarding PCIe…no avail. I’m going to also try creating a fresh account to see if I’ve some borked graphic settings or booting from USB. There was almost no stutter on my 5700XT, right now I assume the drivers were more mature for that card.

EDIT: Boo! My monitor doesn’t feature FreeSync.

I’m starting to think I lost the silicon lottery on this one :roll_eyes:

Seems like it does ViewSonic XG2401 24" 144Hz Gaming Monitor

I had this card for testing in my PC for about a week. It worked out of the box without issues.

I never posted specs of my monitor.

Okay, I got rid of the microstuttering on my last boot. I changed a couple of settings in my BIOS; I set my memory to its native 2666MHz (I had it at 3000MHz which had been working fine but I wanted to try it anyway) and disabled ‘PCIe Native Power Management.’ IMHO the latter setting was the culprit. I noticed KDE’s UI was snappy again and tried a couple of games; Fallout 4, Dying Light 2 and (because of the kids) Roblox. All were smooth but I was still seeing tiny texture areas blip in and out of existence.

I had to sleep but I’ll be doing more testing when I get home.

Odd thing is [that] I temporarily had an Asus TUF 6800 OC edition 6800 that had given me no problems but returned it because I’d ordered the XT edition and was sent that card (bastards tried to get over on me or are incompetent). The shroud, heatsink and fans are significantly smaller on this reference 6800XT.

@Omano, a personal thank you because I see you try to help a lot of people on the forums. :smiling_face:

…scratch all that, I came home and everything’s janky again. I’m going to exchange or return the card. I tried all ports, DP and HDMI, swapped molex/power cables (I’ve a 850W PSU), lowering resolution, a fresh account…I give up. This card should just work. I swapped my PowerColor Red Devil 5700XT back in and everything is buttery.

Although this thread isn’t about the same video card I feel it’s applicable to my 6800XT experience. I’m at a loss of what else to do (although I haven’t tried booting from USB).

It must’ve been the video card. MicroCenter, after explaining everything I tried, allowed me to exchange the card and pay the difference for a Red Devil 6800XT (I’ve had a Red Devil RX580 and 5700XT and they’re great cards, ironically from the same manufacturer). This sucker’s in OC mode and buttery smooth. MAN that hurt my pocket and I’m grateful for an understanding wife! lol

@Mami you might need to exchange the card if you can.