Installer freezes due to 100% CPU usage on plasmashell[AMD Zen5]

So I have a new computer decided to try and install Manjaro to it. Put the install iso on a USB drive and booted from there. My mouse is not available on the desktop not sure why and everything is super sluggish. I try to use keyboard navigation instead of the mouse, but all I succeed in doing is changing the language on the greeter/installer.

Ctrl+alt+f2 to get to a terminal run top and I see plasmashell is pegged at 100% CPU, and it doesn’t ever seem to finish whatever it’s trying to do.

Hardware wise it’s a 7900x CPU from AMD (12 core) and a rx7900 xtx GPU. The desktop is probably trying to run without a GPU driver, and that is pegging a CPU core completely, I guess trying to render.

How do I get past this? Can I install the driver’s in the command line somehow? Is there an image besides the KDE one I should use for installation and later switch to KDE?

I’m not a complete neophyte when it comes to Linux but troubleshooting this seems a little beyond me, has anyone else encountered this issue? Any ideas for workarounds? I can’t get anything done in the GUI, it’s completely unresponsive so it will have to be done through the terminal.

Any suggestions would be most welcome, thanks in advance.

can you go to testing branch and update ?
open a terminal and try ,you will need also kernel 6.2

sudo pacman-mirrors --api --set-branch testing 
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu 
sudo mhwd-kernel -i linux62

from wiki

The first two commands work fine they update a bunch of packages, but the kernel update results in an error.

(5/5) Updating Grub-Bootmenu
/usr/bin/grub-probe: error: failed to get canonical path to ‘overlay’
Error: command failed to execute correctly.

No change, rebooted, no change and all the updates where undone. I’m booting from a USB with the ISO writen to it, so not sure how to update that.

Thanks a lot for your time and help.

if you boot from usb Live manjaro
you have to chroot
open a terminal

sudo manjaro-chroot -a
pacman-mirrors --api --set-branch testing 
pacman-mirrors --fasttrack 5 && sudo pacman -Syyu 
pacman -S linux62 linux62-headers
exit ( quit chroot )

then reboot

Sudo manjaro-chroot -a isn’t working;

grub-probe:error: cannot find a grub drive for /dev/sda1. Check your
grub-probe:error: cannot find a grub drive for /dev/sda1. Check your
Mounting (Arch) [/dev/nvme2n1p2]

The sda is the live USB, the nvme drive is my old linux root from my previous computer that I tried to install arch over before deciding that might be a bit too ambitious. It lacks pacman-mirror commands (and a lot else) and isn’t in a viable state.

I’ve been googling how to work around that but without much luck. I can’t mount /dev/sda because it’s already mounted as /run/miso/bootmnt.

see this

can you stop gpu from your cpu in UEFI motherboard ?
before install apply

sudo pacman -R xf86-video-amdgpu

or try new iso ( with 6.1 LTS kernels)

Thank you so much, using the nightly build solved the problem.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.