Installer crashed immediately when installing Manjaro (XFCE) 22.0.3 on VirtualBox VM on a new machine

My machine is Windows and is newly bought in 2022. When mounted the mentioned Manjaro’s ISO (checksum verified correctly) in VirtualBox and click install after booted up, the installation window simply disappeared. The virtual harddisk is 12GB formatted with msdos partition table with 1 partition only. I run the installation program from terminal with this command:

/bin/calamares_polkit %f

And got crash in the terminal output:

02:40:44 [6]: void Config::setLocaleIndex(int)
Index 58 Selected locale “zh_CN”
… No translation for “tz_” “zh_CN” using default (en)
… Loaded QRC translation “calamares_” “zh_CN”
02:40:44 [6]: void Calamares::SlideshowQML::loadQmlV2Complete()
QML component complete, API 2
/bin/calamares_polkit: line 6: 3646 Killed pkexec --disable-internal-agent “/usr/bin/calamares” “-D6” “$@”

Is the installer broken? Thank you.

I have just found out the reason. Originally, I have allocated 1536MB of RAM to the VM. After I added memory to 2048MB, the installer can be run successfully without crash.

Thus, using Manjaro 22.x must need >= 2GB of RAM!


Still not work with 2GB of RAM - the installation progress step hangs.

Even after I increased RAM to 2560 MB (2.5GB), it hangs at 57% progress at “Configuring locales” (>= 5 min) and then the installer disappeared (crashed).

I think there may be memory leak in the installer!

The Manjaro team better checks your memory usage at installation, please. (The claimed system requirement is 2GB RAM)

Thank you.

Hi @johnny_temp ,
Welcome to the forum, I wonder whether you could read this post in order to solve the problem.

Manjaro Installer Crashing

With a recent change to the Calamares installer and the general size of the ISO the system requirements is at least 4G RAM

Hope it helps, regards

1 Like