Installed NVIDIA Packages, now Linux won't boot

turns out im not even connected to my wifi lol… help please?

Can’t you plug an ethernet cable for the time being?

It says its missing aur packages some xorg font things but nothing else. Everything else seems to be on date except for the Minecraft launcher

You missed 450xx-prime

Seems to have worked. Turns out I had to be connected to wifi. Now should I reboot?

UPDATE: Booted into linux. Am I ready to launch games etc.?

Now you’ll be able to run both cards, to run with nvidia need to run any aplication with prime-run %command%

As mentioned by @visone you need to launch application with prime-run if you want to use the Nvidia card.

To do so in Steam, right click your game, click properties, and click SET LAUNCH OPTIONS, and paste prime-run %command% (literally copy past this all for Steam).

Now by default you use the integrated video chip from CPU, and can use the high performance card on demand with prime-run program_name

i sorta redownloaded video-nvidia-450xx and linux won’t boot again. Do i have to go through the same thing again?

Ps: I can’t uninstall that package

UPDATE: I just checked to see which drivers I have installed. I have the hybrid one, video-modesetting and the one i downloaded just recently. I am trying to uninstall the third one but I am unable to.

what happens when you run mhwd -r pci <name of hybrid driver here>

WIth your current setup your system is in hybrid mode, meaning: everything starts with Intel GPU by default. If you want to start something with Nvidia, add environmental modifier prime-run, so for example, if you want to start OBS with Nvidia, you open it in terminal with:

prime-run obs

The same for Steam:

prime-run steam

You can modify your launcher commands (.desktop files) and add this modifier and then those apps would start with Nvidia automatically.

You can also start Steam with Intel but launch a game with Nvidia by adding launch parameters in Steam:

prime-run %command%

All games using DXVK will use Nvidia automatically even without additional parameters.

If you want more control over your GPUs, see my tutorial:

However, judging from how you handled current problem, you are not experienced enough to meddle with optimus-manager, so I recommend staying on the current hybrid setup till you get more experience and knowledge on how system works.

At the moment it’s enough you just jump to point 9 and read about hybrid mode. Since you are using 450xx drivers, multiple monitors will work in case you have such need.

That’s not the case. I am unable to uninstall the 450xx drivers. I cant access linux.

If i try to remove the 450xx driver, it will spit out an error. Although for the hybrid driver im not sure. I really dont wanna go through the same process of installing again

what is the error it gives when you try to remove it? Can you paste it?

Hold on a moment. I am updating the system as it required an update. I will edit this comment as soon as im done

UPDATE: removing nvidia-450xx-utils breaks dependency nvidia-utils required by nvidia-prime Error: pacman failed!

sudo pacman -R nivida-prime
you shouldn’t need it. I’m running 440xx and don’t seem to have it installed.
then run mhwd -li which will show you all drivers installed.
then mhwd -r pic <all drivers listed from previous command>
then mhwd -i pic video-nivida-440xx
Note if 440xx was in the out of mhwd -li then just don’t remove it and reboot

the prime driver is the one i was told to install. I think that if i remove it ill have to reinstall it because its needed for my laptop

oh ok then reinstall it after the steps I wrote above.

UPDATE: Booted into Linux after:
uninstalling prime driver
uninstalling 450xx driver
installing prime driver back.

I will be marking the correct answers as I think the problem has been solved. Thank you all

Install 440xx before this or else you won’t have a driver to run. I take it you’ll probably have to do this from tty now.

Just checked out my system. You may also need to install these.


not sure about opencl

Should I install these now or should I uninstall the prime drive, install the ones you told me and then install prime?