Installation failed and no more ssd

I justed tried to install manjaro on my brand new laptop and at the and of the installation, I got a message that the installation failed and I have to retry it. I would like to retry but now in the calamares installer, I can’t find my ssd. It just disappeared.

If you have any ideas please tell me. Thank’s for all :grinning:

Open gparted, if you can see the SSD, delete failed partitions and retry the installation.

No the ssd doesn’t appear in gparted. Here is the the problem. I can’t see it neither on gparted and fdisk.

1 Like

check if the disk is detected in bios, if not its dead…

1 Like

If the disk is not detect by the bios, is there some usb bootable tools to edit the disk ?



This might be handy as well:

I had the last times a lot of trouble with ssd’s. That one, what are cheap to buy from the big e-marketplace and even with a ‘repaired’ crucial ssd. The market is right now flooded with them.
Most of them have a manipulated bios on them, what report more space, as there really is.
If you copy datas on them, they become slower and slower, as more there is copied on them, and then stop very soon. The only way to see some signs from them again, is to power off the pc, and they magically appear again. You can format them with windows, because it seems, they are designs for it, that they can avoide there the error detection.
I hope, you didnt buy one from those, otherwise, send it back, and tell the seller, its a scam.
You can not do anything with them.
Not sure, if this sellers really now about it, or only sell some cheap stuff with her profit margin.

1 Like

Ufff… bad news. As @brahma told you, if the BIOS doesn’t recognize the disk it’s very likely that means dead SSD.

Next step should be testing the SSD in another computer but you say in first message that is a brand new laptop so better return to the shop and use the warranty.

I don’t see anything in the BIOS. When I try to make a diagnose, it’s wrote that I have no drive installed. I have now two questions: can an installation kill a ssd ? And do I still have a warranty after trying to install manjaro ? Thank’s for all

Sure - there are write operations issued to the device and it might fail because of that.
“Installations” however are no more dangerous as any other (writing) use of the device though.
Any other write operation of similar extend might have yielded the same result.

That depends on the warranty conditions of your device manufacturer which mostly are:

  • TBW (terrabytes written) below a certain threshold
  • device age and/or purchase age

A (device) warranty wouldn’t expire because you tried to install Manjaro (or linux in general).

No. Unless you blame the last thing that was done on a worn out/bad disk to be the culprit. In that case writing a single letter into a file can kill it.

Open your PC and check sata/power cable, switch to a different M.2 port, etc.

This may work also with ssd

If the SSD was defective, may fail during an installation, writing some files or simply while idle…

Installing/run an OS is a part of SSD’s usual tasks, so warranty can’t be void for this.

1 Like