Install spotify with Aur

I installed the package as in the wiki, but the app was not installed. Does anyone know why? (tried to install with pamac)

I could search for it - but I won’t :wink:

I not only tried - but I did.
pamac build spotify
it did build and install - and was usable :wink:
(it did start, from the menu, but I don’t (yet) have an account to test it further)

Were there any error messages pamac prompted?
You may post them here to get more details for us to help.

Did you try to use yay to install it?

yay is an AUR-helper, which you have to install first, since it’s not installed ootb.
Then you may install spotify with
yay -S spotify

Please do not use sudo with it.

I uploaded the file via aur with pamac, but the file icon is not visible. I could not understand that there is a .deb extension in the file folder. I couldn’t upload the photo because I don’t know how to upload it

The pkgbuild repackage the .deb archive into an Arch package

Maybe not the popular method, but you could go and install Spotify using a Flatpak instead. Would need to enable flatpak support in Pamac preferences first. Then use Pamac to search for and install. Restart system and it will be there ready to use.

What do you guys think?

Please take a look at the comments section of the Spotify AUR site and see if there is any help for you:

Only thing I can tell you is that AUR version works perfectly for me (after updating GPG key)

Thanks to everyone I’ll try suggestions

i don’t see tar and similar extensions that look like this

From where have you got all these files?? There shoudn’t be any .deb files anyway. Follow these steps to install spotify through aur if you are not able to do so with any aur helper:

sudo pacman -S git base-devel --needed
git clone
cd spotify
makepkg -si

Are you able to launch spotify now?? What are the errors if any.

the internet is still loading a little slow

You can fix the GPG key issue by using:

curl -sS | gpg --import -
cd ~/spotify
makepkg -si


Failed to install built package(s).

it reads like this


the package gets built, but cannot be installed
(at least that is what I interpret your response to mean)

Is the package actually there?
ls spotify*zst

If it is, if this gets you the following output:

then use pacman to install it:
sudo pacman -U spotify-1:

he found the tar file, but he’s giving this error now

what error?
Can you be a bit more verbose? :wink: