Install seems to work well, after a reboot the GUI is unusable

“Newbie” here.
At first glance, every Linux distribution is laggy on my desktop computer, and I never understood why (i tried Debian, Ubuntu and Kali)… Today, I finally figured out it may be because of the Nvidia drivers.

So I tried again, but decided to use Manjaro instead, as it is my laptop’s distribution.

On a very fresh install, everything seems to work fine, except the usual lag (for exemple trying to select files in Dolphin makes the computer jump some frames…), but then I try to install the drivers.

I tried with the “Hardware configuration” by default in Manjaro, installing nvidia-utils and lib32-nvidia-utils, but :

  • it is still laggy
  • after one rebbot, i can log in, and now there is only my pointer, on the window, taking up the whole screen. I need to use another TTY output if I want to continue using my computer :frowning:

For the hardware… :
Intel Core i5-8400 (2.8 GHz)
MSI GeForce GTX 1070 Ti ARMOR 8G, 8 Go

Manjaro version : 22.1.3

How should I install graphical drivers ?

First, provide the basic info to your system:

inxi -Fza

If you can`t access your system use the USB stick which you used to install the system.

Inxi command output :

  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=9295b79d-34ae-4154-8227-d8460fb46dd0 rw quiet splash
    resume=UUID=f110e432-e120-495b-9b44-f45fe4e28803 udev.log_priority=3
  Console: pty pts/1 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME Z370-A v: Rev X.0x serial: <filter> part-nu: SKU
    uuid: a4fc40f0-f1b7-e9de-5660-b06ebfba71a3 UEFI-[Legacy]: American Megatrends v: 2801
    date: 01/13/2021
  Info: model: Intel Core i5-8400 socket: LGA1151 bits: 64 type: MCP arch: Coffee Lake gen: core 8
    level: v3 note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB
    L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB desc: 1x9 MiB
  Speed (MHz): avg: 800 min/max: 800/4000 base/boost: 2800/8300 scaling: driver: intel_pstate
    governor: powersave volts: 0.9 V ext-clock: 100 MHz cores: 1: 800 2: 800 3: 800 4: 800 5: 800
    6: 800 bogomips: 33613
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: Micro-Star MSI driver: nvidia v: 545.29.06
    alternate: nouveau non-free: 545.xx+ status: current (as of 2024-01; EOL~2026-12-xx)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 4 link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1b82
    class-ID: 0300
  Device-2: KYE Systems (Mouse Systems) PC-LM1E Camera driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-13:4 chip-ID: 0458:6006 class-ID: 0102
    serial: <filter>
  Display: server: v: with: Xwayland v: 23.2.3 compositor: kwin_wayland driver:
    X: loaded: nvidia gpu: nvidia tty: 236x56
  Monitor-1: Unknown-1 size-res: N/A in console modes: 640x480
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2 drv: swrast gbm:
    drv: kms_swrast surfaceless: drv: nvidia inactive: wayland,x11,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: mesa v: 23.3.3-manjaro1.1
    note: console (EGL sourced) renderer: llvmpipe (LLVM 16.0.6 256 bits), NVIDIA GeForce GTX 1070
  API: Vulkan v: 1.3.274 layers: 1 device: 0 type: discrete-gpu name: NVIDIA GeForce GTX 1070 Ti
    driver: nvidia v: 545.29.06 device-ID: 10de:1b82 surfaces: N/A
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4 link-max: lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f0 class-ID: 0403
  Device-3: KYE Systems (Mouse Systems) PC-LM1E Camera driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-13:4 chip-ID: 0458:6006 class-ID: 0102
    serial: <filter>
  Device-4: Razer USA Kraken 7.1 V2 driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-6:3 chip-ID: 1532:0510 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss type: oss-emulator
    tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: n/a (root, process) with: 1: pipewire-pulse status: off
    2: wireplumber status: active 3: pipewire-alsa type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020 bus-ID: 00:17.0
    chip-ID: 8086:2822 rev: class-ID: 0104
  Local Storage: total: 3.75 TiB used: 9.34 GiB (0.2%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT2000P3SSD8 size: 1.82 TiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: P9CR30A temp: 25.9 C scheme: MBR
  SMART: yes health: PASSED on: 71d 4h cycles: 627 read-units: 14,856,814 [7.60 TB]
    written-units: 14,694,270 [7.52 TB]
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164 family: FireCuda 3.5
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s tech: HDD
    rpm: 7200 serial: <filter> fw-rev: CC41 temp: 24 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 1y 353d 4h cycles: 4012 read: 1.58 PiB
    written: 16.43 TiB Pre-Fail: attribute: Spin_Retry_Count value: 100 worst: 100 threshold: 97
  ID-3: /dev/sdb maj-min: 8:16 vendor: GALAX model: TA1D0120A size: 111.79 GiB block-size:
    physical: 512 B logical: 512 B sata: 3.2 speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 11.0
    temp: 33 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 2y 3d 17h cycles: 4041 written: 13.8 MiB
  ID-1: / raw-size: 1.79 TiB size: 1.76 TiB (98.37%) used: 9.34 GiB (0.5%) fs: ext4
    block-size: 4096 B dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes compressor: zstd
    max-pool: 20%
  ID-1: swap-1 type: partition size: 34.41 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p2 maj-min: 259:2
  System Temperatures: cpu: 25.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 32 GiB available: 31.29 GiB used: 1.17 GiB (3.7%)
  Processes: 197 Power: uptime: 12m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: shutdown,reboot,suspend,test_resume image: 12.5 GiB
    daemons: upowerd, org_kde_powerdevil, power-profiles-daemon Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1129 libs: 321 tools: pamac pm: flatpak pkgs: 0 Compilers:
    clang: 16.0.6 gcc: 13.2.1 Shell: Sudo (sudo) v: 1.9.15p5 default: Bash v: 5.2.21
    running-in: pty pts/1 (SSH) inxi: 3.3.32

I see nothing there that could be the cause.

Please provide the output of:

/usr/bin/top --iterations=1 --batch | head -n +20

Top command output :

top - 16:55:46 up 0 min,  2 users,  load average: 3,73, 0,88, 0,29
Tâches: 205 total,   1 en cours, 204 en veille,   0 arrêté,   0 zombie
%Cpu(s):  0,0 ut,  2,7 sy,  0,0 ni, 97,3 id,  0,0 wa,  0,0 hi,  0,0 si,  0,0 st 
MiB Mem :  32036,6 total,  30561,6 libr,   1046,4 util,    814,8 tamp/cache     
MiB Éch :  35240,2 total,  35240,2 libr,      0,0 util.  30990,2 dispo Mem 

    PID UTIL.     PR  NI    VIRT    RES    SHR S  %CPU  %MEM    TEMPS+ COM.
   1382 amaurice  20   0   12476   5888   3712 R  16,7   0,0   0:00.04 top
      1 root      20   0   22740  12956   9888 S   0,0   0,0   0:01.19 systemd
      2 root      20   0       0      0      0 S   0,0   0,0   0:00.00 kthreadd
      3 root      20   0       0      0      0 S   0,0   0,0   0:00.00 pool_wo+
      4 root       0 -20       0      0      0 I   0,0   0,0   0:00.00 kworker+
      5 root       0 -20       0      0      0 I   0,0   0,0   0:00.00 kworker+
      6 root       0 -20       0      0      0 I   0,0   0,0   0:00.00 kworker+
      7 root       0 -20       0      0      0 I   0,0   0,0   0:00.00 kworker+
      8 root      20   0       0      0      0 I   0,0   0,0   0:00.00 kworker+
      9 root       0 -20       0      0      0 I   0,0   0,0   0:00.00 kworker+
     10 root      20   0       0      0      0 I   0,0   0,0   0:00.02 kworker+
     11 root      20   0       0      0      0 I   0,0   0,0   0:00.00 kworker+
     12 root       0 -20       0      0      0 I   0,0   0,0   0:00.00 kworker+

OK, I see absolute no reason for any lagging. I mean:

…the Nvidia drivers are installed, and

…it’s not as if your PC is under heavy load.

So I don’t have a clue. But someone else here might, though.

The GUI is sometimes lagging, that’s a thing. But after the first reboot (and I actually reboot many times since)… the GUI is completely crashed (the screen is black apart from the mouse pointer which takes easily the half of it) :frowning:
I need to use TTY to test, or SSH (to post outputs here lol)

I believe you, but I just don’t know. Have you tried the Gnome or Xfce or any other version, for that matter? Heck, it might even be a good, or worthwhile idea to do a memtest from a live environment…

Looks like you’re using Wayland. Someone just a day or two ago had a similar problem, and I suggested that they try X11, they said it works for them.

I think a lot of the Wayland issues have been worked on for the upcoming KDE/Plasma 6 release so things should work better then.

I miss the desktop entry… something like

  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux

this not full EFI
you have to redo install , and before check these points in your EFI

  • Secure boot is off
  • CSM is off
  • USB mass sorage on
  • all disks on AHCI ( not raid )
  • no optane / Rst
  • No Legacy

also on boot USB live manjaro
you should see

< partition 1 or 2 > → this one for install UEFI
boot with no free drivers

then before install, open a terminal and recheck

inxi  -Fxza
test -d /sys/firmware/efi && echo efi || echo bios
sudo efibootmgr -v
sudo parted -l 

Hey, indeed, went back on it and switching to X11 indeed works !

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.