Install deb package manjaro

Hello! Is it possible to install the debian package in manjaro? If so, how? I can’t find it on the internet.

What Debian package?

It is possible to create a PKGBUILD to extract a .deb and install the files. There are quite a few AUR packages that do this.

Hello! – PKGBUILD: command not found

Please tell me if it’s not difficult . can’t open in manjaro – filename.deb

Welcome to the forum! :slight_smile:

A PKGBUILD is a file for building Arch packages, usually but not always from source code. It’s a script that gets invoked by makepkg.

If you don’t know what we’re talking about here, then the short answer to your question is unfortunately “No”. It can be done, but you probably won’t be able to do it, because it requires a serious amount of knowledge of how package management works in Arch and Arch-based distributions.

1 Like

What can’t you open? What program? It might already be in the AUR (Arch User Repository).

Ok! Thank you for your cooperation)

1 Like

Which deb package do you want to install? Which application?

The idea is that you look for software in the Manjaro repository. If you do not find it there, then you look in the AUR ─ the Manjaro package managers support access to the AUR (“Arch User Repository”) ─ and then you can usually get it to work, even though it may require that the package be compiled locally on your machine.

If you still can’t find what you’re looking for in the AUR, then Manjaro offers Snap, FlatPak and AppImage, through which you can install (less integrated but sandboxed) software.

1 Like

Thank you for your cooperation)! the developer indicated the path, it remains only to find out how) ‘’“If you’re running another dist. you may still be able to run it by extracting the .deb and moving the files and data folders to the correct directories. The directions below will install it on Arch Linux”"

Ok! I solve the problem in the way indicated by the developer.

yes : but write instructions in a PKGBUILD text file and after, upload this file in AUR :wink:

1 Like

moved the package to manjaro format according to the developer’s instructions. successful, the application works very well. thank you all.

Which application? Is it a secret? :thinking:

I guess “the application” was a grammar mistake. Anyhow, I’ve got a very similar problem: there are some packages I use to design e-learning materials with: eXeLearning and QuExt ; the latter is in beta, and neither is available in the AUR (not even older versions). eXe is available in Snap, but that’s not exactly a good package format to do some beta testing of components with.

I tried converting QuExt with debtap, and it worked all right. However, the dependency qt5-default could not be met. I ran into similar problems some time ago trying the same with eXeLearning. Now my hunch is that if I tried to debtap qt5-default I’d either run into the same problem again, this time with an unmet dependency of that package, or I’d somehow mess something up big time, throwing KDE into confusion or whatever.

Is there any good advice anyone could give me? With eXeLearning, my workaround is using Wine, but as for QuExt… The dev is trying to solve it, but I’m lucky to know him -I’m less lucky with loads of other applications where the same may happen.

Why not use the portable version? Also the source is available.

That would translate to qt5-base.

1 Like

Thanks a million. Using your guidance as to the dependency I managed to install QuExt -but it still won’t run, giving me the error

/usr/lib/quext/quext-bin: symbol lookup error: /usr/lib/quext/quext-bin: undefined symbol: _ZN8QtCharts6QChart8setThemeENS0_10ChartThemeE, version Qt_5

I’ve sent both that error and the debtap-created package to the developer: he might find it useful.

As for the portable version of eXe, last time I tried it gave me bunch of errors, and I didn’t trust the building-from-source path not to b***h out on me with, again, dependency issues and suchlike. I’d tried that, too, with debtap, and there were quite a few that weren’t found, so I decided to speed up the process using Wine :wink: That was back during confinement, and time was pressing.